Problema

La connettività MPA di NSX Edge è inattiva a causa di un arresto anomalo del servizio dell'infrastruttura.

Causa

Il fatto che i dischi del nodo NSX Edge siano pieni o la perdita di memoria può causare l'arresto anomalo di determinati processi e generare questo errore. La CLI admin get managers può restituire il nodo di Manager attivo (se l'arresto anomalo si è verificato dopo la registrazione corretta di Manager) e la CLI admin get controller restituirà l'errore Impossibile recuperare l'elenco dei controller.

Soluzione

  1. Eseguire la CLI admin get diagnosis config o GET API /api/v1/transport-nodes/{transport-node-id}/node/diagnosis per diagnosticare gli errori relativi all'integrità dei nodi NSX Edge causati quando i servizi diventano inattivi.
  2. Eseguire la CLI admin get cores-dumps per verificare se sono stati generati core (in /var/core o /image/core) a causa dell'arresto anomalo del servizio. Se è presente un dump core, eseguire il comando top -o %MEM come root per verificare quale processo di NSX sta utilizzando troppa memoria e la CLI admin get filesystem-status per verificare se le partizioni utilizzate da NSX sono piene o quasi piene.
  3. Eseguire la CLI root /etc/init.d/nsx-proxy | nsx-nestdb status per recuperare lo stato dei servizi dell'infrastruttura in esecuzione nel nodo NSX Edge.
  4. Pulire lo spazio su disco, quindi avviare tutti i servizi dell'infrastruttura arrestati nell'host eseguendo il comando /etc/init.d/<service-name> start (come soluzione temporanea). Se sono presenti core, aprire una richiesta di supporto per VMware.