NSX Edge
Problema
Lo stato di NSX Edge è INATTIVO o DANNEGGIATO perché i tunnel BFD verso l'NSX Edge remoto sono inattivi.
Causa
Tra due NSX Edge, viene eseguita una sessione BFD nell'interfaccia di gestione e una o più sessioni BFD in ogni interfaccia VTEP. Un NSX Edge considera il proprio peer non raggiungibile solo quando tutte le sessioni BFD verso tale Edge (quella di gestione e tutte quelle VTEP) sono inattive.
Soluzione
- Per ottenere informazioni sui dispositivi VTEP di NSX Edge, eseguire la CLI admin get host-switch.
- Per verificare lo stato della porta fisica, eseguire get physical-port <vtep device>. Quindi, in edge-1> get phy fp-eth0.
Physical Port
ADMIN_STATUS : up <----------------- should be "up"
DRIVER : net_vmxnet3
DUPLEX : full
ID : 0
LINK : up <----------------- should be "up"
- Eseguire le CLI admin get diagnosis topology e get edge-cluster status per verificare che l'Edge sia integro con stato Attivo di Elevata disponibilità del cluster Edge, stato Attivo del nodo Edge e stato Attivo dell'amministratore. Verificare quindi che lo stato di VTEP sia Attivo e lo stato delle sessioni di controllo dell'integrità BFD.
Interface : nsx-edge-vtep
Device : fp-eth0
Session : 71.23.54.3:71.23.54.1
Status : Unreachable
Interface : nsx-edge-vtep.1
Device : fp-eth1
Session : 71.23.54.4:71.23.54.2
Status : Unreachable
Se lo stato è Non raggiungibile o il segnale del router adiacente è inattivo, verificare la connettività IP utilizzando il ping ICMP.
- Poiché le interfacce TEP si trovano nel tunnel VRF per gli Edge, avviare il ping dal tunnel VRF 0 negli Edge e, se sono presenti più TEP, specificare l'indirizzo IP di origine o l'interfaccia utilizzati per il ping.
- Eseguire la CLI admin "get logical-routers" per ottenere il VRF del tunnel seguito dal ping.
vrf 0
ping 71.23.47.8 source 71.23.46.1 repeat 3
- Eseguire la CLI admin get neighbor per verificare se ARP è in fase di risoluzione per la sessione BFD.
- Eseguire la CLI admin get interface per verificare lo stato dell'interfaccia con il tunnel BFD inattivo.
- Se uno degli stati è Non raggiungibile, verificare che il cablaggio underlay sia corretto.
- Se il ping ICMP funziona ma lo stato di VTEP è Non raggiungibile, verificare che gli indirizzi IP di VTEP non siano già in uso.