L'aggiornamento di NSX Application Platform non è riuscito a causa di un errore.

Problema

Il tentativo di aggiornamento di NSX Application Platform non è riuscito e viene visualizzato l'errore Distribuzione di Coordinatore aggiornamento: chiamata al plug-in post-distribuzione non riuscita.

Causa

Se viene persa la connettività tra il nodo del piano di controllo Kubernetes e un pod esistente, il gestore certificati Kubernetes non è in grado di inviare correttamente il certificato al pod esistente e le chiamate API di uscita inviate al NSX Manager non riescono. Questo problema può verificarsi anche se si verifica un problema di connettività dal nodo del coordinatore aggiornamento al nodo del piano di controllo Kubernetes.

Soluzione

Per risolvere questo problema, eseguire i seguenti passaggi.

  1. Accedere all'appliance NSX Manager con l'account root.

  2. Al prompt del sistema, eseguire il comando seguente per riavviare i pod.

    napp-k rollout restart deployment cluster-api trust-manager 
  3. Attendere il riavvio dei pod cluster-api e trust-manager.

  4. Quando i pod sono di nuovo online, riavviare la distribuzione del coordinatore aggiornamento utilizzando il comando seguente.

    napp-k rollout restart deployment upgrade-coordinator
  5. Attendere il riavvio del coordinatore aggiornamento.

  6. Riprovare l'aggiornamento di NSX Application Platform utilizzando la scheda Sistema > Aggiornamento nell'interfaccia utente di NSX Manager. Per dettagli, consultare Aggiornamento dell' NSX Application Platform.