Aggiornate il: 17 OTT 2019

VMware Tools | 17 OTT 2019 | Build 14773994

Verificare la disponibilità di aggiunte e aggiornamenti a queste note di rilascio.

Contenuto delle Note di rilascio

Le note di rilascio riguardano i seguenti argomenti.

Novità

  • È consigliabile eseguire l'aggiornamento a questa versione di VMware Tools se si utilizza la funzionalità di individuazione dei servizi nativi in vRealize Operations Manager 8.0 oppure vRealize Operations Service Discovery Management Pack con le versioni precedenti di vRealize Operations Manager (7.x o precedente). Per ulteriori dettagli, fare riferimento all'articolo KB 75122.

Rilasci precedenti di VMware Tools

  • Per le versioni precedenti di VMware Tools, vedere la pagina della documentazione di VMware Tools.

Prima di iniziare

  • VMware Tools 11.0.1 supporta i sistemi operativi guest seguenti:
    • windows.iso supporta Windows Vista e versioni successive. 
      • VMware Tools 11.0.1 dipende da e include Microsoft Visual C++ Redistributable per Visual Studio 2015, 2017 e 2019. Durante la preparazione del sistema per l'installazione di VMware Tools 11.0.1, Microsoft Visual C++ Redistributable per Visual Studio 2015, 2017 e 2019 viene installato nel sistema come prerequisito. L'installazione o l'aggiornamento a VMware Tools 11.0.1 non sono supportati per le versioni di Windows che non soddisfano i prerequisiti e i clienti devono continuare a utilizzare VMware Tools 10.2.x o versioni precedenti finché non applicano una patch al sistema operativo Windows o non lo aggiornano in modo che soddisfi i prerequisiti per VMware Tools 11.0.1. Fare riferimento all'aggiornamento di Microsoft KB2977003 per i download di Visual C++ più recenti supportati.
      • Prerequisiti a livello del sistema operativo Windows
        • Windows Server 2019
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012 R2 con aggiornamento Microsoft KB2919355
        • Windows 8.1 con aggiornamento Microsoft KB2919355
        • Windows Server 2012 
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1)
        • Windows 7 Service Pack 1 (SP1)
        • Windows Server 2008 Service Pack 2 (SP2)
        • Windows Vista Service Pack 2 (SP2)
    • darwin.iso supporta Mac OS X versione 10.11 e successive.
    • Per informazioni dettagliate su linux.iso, fare riferimento alle Note di rilascio di VMware Tools 10.3.21.
    • Per informazioni dettagliate su solaris.iso, fare riferimento alle Note di rilascio di VMware Tools 10.3.10.
  • Le immagini ISO di VMware Tools per alcuni sistemi operativi guest al termine del loro ciclo di vita sono bloccate. Alcune immagini ISO non sono incluse nel VIB tools-light di ESXi. Per ulteriori dettagli, vedere la pagina Documentazione di VMware Tools. Tutte le immagini ISO di VMware Tools sono disponibili per il download da http://my.vmware.com.
  • VMware Tools per Windows: i file eseguibili (.exe) del programma di installazione a 32 bit e a 64 bit sono disponibili per il download. Questi file consentono di semplificare l'accesso e l'installazione di VMware Tools nei sistemi operativi guest Windows.

Nota importante relativa all'aggiornamento a ESXi 6.0 o versione successiva

Risoluzione dell'incompatibilità e linee guida generali: durante l'aggiornamento degli host ESXi alla versione ESXi 6.0 o successiva, se si utilizzano versioni non recenti di Horizon View Agent, fare riferimento agli articoli della Knowledge Base seguenti:

Internazionalizzazione

VMware Tools 11.0.1 è disponibile nelle lingue seguenti:

  • Inglese
  • Francese
  • Tedesco
  • Spagnolo
  • Italiano
  • Giapponese
  • Coreano
  • Cinese semplificato
  • Cinese tradizionale

Informazioni sul supporto del prodotto

  • L'immagine iso di Windows precedente a Vista per VMWare Tools non è più inclusa nel pacchetto di ESXi. Gli utenti che necessitano dell'immagine iso di Windows precedente a Vista possono scaricarla. Per informazioni sul download, vedere la pagina per il download dei prodotti.

Avviso di interruzione del supporto delle funzionalità

  • La prossima versione di VMTools non potrà più essere installata in Windows Vista SP2 e Windows Server 2008 SP2.
  • Il driver balloon è stato rimosso da VMware Tools 11.0.0 per MacOS.
  • VMware Tools 11.0.0 blocca il supporto per i guest Solaris.
  • Gli strumenti tar (linux.iso) e gli OSP forniti con VMware Tools 10.3.5 continueranno a essere supportati. Tuttavia, le versioni successive a VMware Tools 10.3.5 includeranno solo le correzioni per gli errori critici e per la sicurezza, ma non il supporto delle nuove funzionalità in questi tipi di VMware Tools (strumenti tar e OSP). È consigliabile che i clienti utilizzino open-vm-tools per i sistemi operativi che supportano open-vm-tools. Per ulteriori informazioni sui diversi tipi di VMware Tools, vedere https://blogs.vmware.com/vsphere/2016/02/understanding-the-three-types-of-vm-tools.html

Nota di compatibilità

  • A partire da VMware Tools versione 10.2.0, l'installazione di VMware Tools basata su script Perl per FreeBSD non è più disponibile. I sistemi FreeBSD sono supportati solo tramite i pacchetti open-vm-tools disponibili direttamente dai repository dei pacchetti FreeBSD. I pacchetti FreeBSD per open-vm-tools 10.1.0 e versioni successive sono disponibili dai repository dei pacchetti FreeBSD.

Supporto della personalizzazione del sistema operativo guest

La Matrice di supporto della personalizzazione del sistema operativo guest presenta i dettagli relativi ai sistemi operativi guest la cui personalizzazione è supportata.

Matrice di interoperabilità

La matrice di interoperabilità dei prodotti VMware fornisce dettagli sulla compatibilità delle versioni correnti e precedenti dei prodotti VMware. La matrice di interoperabilità dei prodotti VMware di VMware Tools 11.0.0 può essere applicata a VMware Tools 11.0.1.

Installazione e aggiornamenti per questo rilascio

È possibile scaricare VMware Tools dalla pagina Download prodotti.

I passaggi per installare VMware Tools variano a seconda del prodotto VMware e del sistema operativo guest installati. Per informazioni sui passaggi generali per l'installazione di VMware Tools nella maggior parte dei prodotti VMware, vedere la pagina relativa alle istruzioni di installazione generali di VMware Tools (1014294). Per configurare productLocker in modo che punti all'archivio dati condiviso, fare riferimento all'articolo KB 2004018.

Per istruzioni specifiche sull'installazione, l'aggiornamento e la configurazione di VMware Tools, consultare la pagina relativa alla documentazione di VMware Tools.

Driver del guest Windows installati da VMware Tools

VMware Tools 11.0.1 supporta le versioni dei driver seguenti in un sistema operativo guest Windows.

Driver VMware Tools 11.0.1
Driver hardware
vmci

9.8.16.0

vsock

9.8.16.0

pvscsi

1.3.15.0

wddm

8.16.07.0000

xpdm

12.1.8.0

vmxnet3

1.8.16.0

vmxnet2

2.2.0.0

vmmouse

12.5.10.0

vmusbmouse

12.5.10.0

vmaudio

5.10.0.3506

efifw 1.0.0.0
Driver software
vmrawdsk.sys

1.1.5.0

vmmemctl.sys

7.5.4.0

vmhgfs.sys

11.0.40.0

vsepflt.sys

11.0.0.0

vnetflt.sys

11.0.0.0 (solo per la firma del codice in modalità Kernel, Windows Vista e Windows 2008)

vnetWFP.sys 

11.0.0.0 

glgxi.sys

2.2.0.0

giappdef

2.2.0.0

DLL di sicurezza
vmwsu.dll

2.0.0.0

Problemi risolti

  • Perdita di memoria in vmtoolsd.

    In vmtoolsd si verifica la perdita di memoria quando vengono utilizzate le API di vSphere ListGuestAliases e ListGuestMappedAliases.

    In questa versione il problema è stato risolto.

Problemi noti

  • Una partizione di copia shadow (volume ghost) viene creata in Gestione dispositivi Windows dopo la creazione di uno snapshot di inattività.

    Dopo la creazione di uno snapshot di inattività in un disco GPT, viene creata una partizione di copia shadow di Microsoft.

    Soluzione:

    La partizione di copia shadow può essere eliminata utilizzando la configurazione seguente nel file VMware tools.conf:

    [vmbackup]
    deleteShadowCopyPartition=true

  • La sospensione di una macchina virtuale guest Linux mediante una versione qualsiasi di open-vm-tools potrebbe non riuscire con alcune versioni di SELinux.

    Un'operazione di sospensione del guest in un guest Linux che esegue una versione qualsiasi di open-vm-tools e con SELinux abilitato può bloccarsi e, in definitiva, non riuscire.

    L'errore può manifestarsi nei modi seguenti:
      - Visualizzazione del messaggio "Impossibile sospendere la macchina virtuale".
      - Non succede niente e il pulsante "Sospendi guest" viene riattivato. È possibile che le connessioni IPv4 vengano chiuse.
      - Si verifica una sospensione ritardata, ma gli indirizzi IPv4 vengono persi quando la macchina virtuale viene ripresa.

    Anche un "blocco" apparente che supera i 30 secondi è un'indicazione del problema.

    Per ulteriori dettagli, vedere l'articolo KB 74722.

    Soluzione:

    Aggiornare i pacchetti selinux-policy e selinux-policy-targeted alla versione più recente resa disponibile dal fornitore di Linux.  Se gli aggiornamenti dei pacchetti non sono disponibili o se il problema persiste, è consigliabile provare la soluzione seguente:

    Creare un'esenzione per l'accesso negato di vmtools/NetworkManager utilizzando il comando audit2allow per generare un modulo del criterio SELinux caricabile locale come descritto nell'articolo KB 74722.

  • Il driver glxgi di AppDefense registra un errore nel Visualizzatore eventi

    Il driver glxgi di AppDefense registra nel Visualizzatore eventi un errore simile al seguente:

    "The glxgi service failed to start due to the following error: uA device attached to the system is not functioning."

    Gli eventi si verificano quando l'opzione Integrità guest è disabilitata.

    Soluzione:

    L'evento non influisce in alcun modo sul sistema e può essere ignorato.

  • Avvisi del Visualizzatore eventi generati dai driver di esecuzione dell'avvio di VMware Tools glxgi, pvscsi, vsepflt e vsock 

    Quando si dispone di una macchina virtuale con avvio protetto in cui sono abilitati Microsoft Hyper-V e la sicurezza basata su virtualizzazione tramite Device Guard ed è applicato il criterio di integrità del codice, i driver glxgi, pvscsi, vsepflt e vsock potrebbero generare nel registro eventi avvisi simili ai seguenti.

    Nome registro:      Microsoft-Windows-CodeIntegrity/Operational
    Origine:        Microsoft-Windows-CodeIntegrity

    Registro operativo:

    Avvisi 

    ID evento:      3083    
    Livello:         Avviso

    Descrizione:
    Controllo dell'integrità del codice: nel sistema è caricato il modulo del kernel system32\DRIVERS\vsock.sys che non soddisfa i requisiti di WHQL.
    Contattare l'entità di pubblicazione per verificare la disponibilità di un modulo del kernel compatibile con WHQL. 

    Soluzione:

    Questi avvisi possono essere ignorati. I driver vengono caricati e funzionano in modo normale.

  • L'installazione del pacchetto di VMware Tools non viene completata

    Durante l'installazione di VMware Tools mediante il comando di installazione, viene visualizzata una finestra di dialogo con una barra di stato. Questa finestra di dialogo mostra l'avanzamento dell'installazione del pacchetto ridistribuibile di VC 2017 che viene utilizzato da VMware Tools. L'installazione del pacchetto ridistribuibile di VC 2017 non viene completata impedendo l'avvio della finestra di dialogo di installazione generica di VMware Tools.

    I registri dell'installazione di VMware Tools sono disponibili in percorsi simili ai seguenti nella cartella temporanea:

     %temp%\vminst.log e %temp%\vmmsi.log

    Il problema si verifica con il sistema operativo Windows Vista Service Pack 2 in cui è installato il pacchetto di Microsoft Document Explorer 2008, quando VMware Tools installa il pacchetto ridistribuibile di Microsoft VC 2017.

    Soluzione:

    Per installare VMware Tools: 

    1. Disinstallare il pacchetto di Microsoft Document Explorer 2008 dal sistema operativo Windows Vista Service Pack 2. 
    2. Installare o aggiornare VMware Tools eseguendo nuovamente l'installazione.
  • L'installazione o l'aggiornamento a VMware Tools 10.3.0 potrebbe richiedere più tempo e il sistema operativo Windows potrebbe richiedere un riavvio

    È possibile che il processo di installazione sembri in corso e che venga visualizzato un messaggio simile al seguente:
    "Preparazione di 'VMware Tools' per l'installazione..."

    Durante questo processo, all'utente potrebbe venire richiesto di riavviare il sistema operativo. 

    Soluzione:

    Per ulteriori informazioni, vedere l'articolo KB 55798.

  • La funzionalità di trascinamento non funziona in Ubuntu.

    La funzionalità di trascinamento non funziona in una macchina virtuale Ubuntu 16.04.4 a 32 bit installata mediante Easy Install. Nello stesso sistema non funziona nemmeno la funzionalità copia e incolla.

    Nota: questo problema si verifica in VMware Tools in esecuzione su Workstation e Fusion.

    Soluzione:

    • Aggiungere l'opzione di avvio del kernel Linux modprobe.blacklist=vmwgfx.
    • Per accedere a risoluzioni più ampie, rimuovere l'opzione svga.guestBackedPrimaryAware = "TRUE" dal file VMX.
  • Il montaggio delle cartelle condivise non è disponibile in una macchina virtuale Linux.

    Se la funzionalità Cartelle condivise viene abilitata in una macchina virtuale Linux mentre è spenta, il montaggio delle cartelle condivise non è disponibile al riavvio.

    Nota: questo problema si verifica in VMware Tools in esecuzione su Workstation e Fusion.

    Soluzione:

    Se la macchina virtuale è accesa, disabilitare e abilitare la funzionalità Cartelle condivise dall'interfaccia.
    Per risolvere il problema definitivamente, modificare /etc/fstab e aggiungere una voce per fare in modo che la funzionalità Cartelle condivise venga montata automaticamente all'avvio.
    Ad esempio, aggiungere la riga:
    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • Per Solaris 11.4 viene visualizzato un messaggio di avviso relativo all'errore di verifica della firma del modulo kernel di VMware Tools.

    Il criterio predefinito di avvio verificato di Solaris è impostato su "avviso" nella versione 11.4 di Solaris. Quando viene caricato un modulo senza firma, viene visualizzato il messaggio di avviso seguente:

    "solaris-11.4 krtld: Warning: Signature verification of module /kernel/drv/amd64/vmmemctl failed"

    Soluzione:

    VMware non fornisce moduli del kernel firmati per Solaris nelle versioni di VMware Tools. Man mano che ogni modulo del kernel di VMware Tools viene caricato, nella console o nel registro di sistema (/var/log/messages) viene visualizzato un messaggio di avviso.
    In modalità "avviso", il modulo viene comunque caricato nel kernel.

check-circle-line exclamation-circle-line close-line
Scroll to top icon