Le proprietà ICA in VMware Identity Manager devono includere la proprietà di crittografia impostata sullo stesso livello di crittografia configurato nei server XenApp della farm. In caso contrario, gli utenti non possono accedere alle applicazioni o ai esktop pubblicati da Citrix.
Problema
Quando un utente si connette a una risorsa pubblicata da Citrix da
VMware Identity Manager, viene visualizzato il messaggio di errore seguente.
Non si dispone del livello di crittografia appropriato per accedere a questa sessione
Causa
VMware Identity Manager non imposta i livelli di crittografia. Se il livello di crittografia impostato nel server XenApp è più elevato di quello predefinito utilizzato in Citrix Receiver, viene visualizzato l'errore seguente.
È necessario impostare un livello di crittografia più elevato in VMware Identity Manager.
Soluzione
- Accedere alla console di VMware Identity Manager.
- Fare clic sulla scheda Impostazioni. , quindi fare clic su
- Nel riquadro a sinistra, fare clic su Citrix XenApp o Citrix XenDesktop, in base alla propria distribuzione.
- Apportare le modifiche seguenti nelle sezioni Configurazione ICA e Configurazione ICA NetScaler.
- Nella casella di testo Proprietà client ICA, impostare il livello di crittografia con la seguente proprietà:
EncryptionLevelSession=EncRC5-128In questo esempio il livello di crittografia viene impostato su 128, ma è necessario modificarlo impostandolo sul livello configurato nei server XenApp.
- Nella casella di testo Proprietà avvio ICA, impostare il livello di crittografia immettendo o modificando la proprietà seguente:
[EncRC5-128]
DriverNameWin16=pdc128w.dll
DriverNameWin32=pdc128n.dll
In questo esempio il livello di crittografia viene impostato su 128, ma è necessario modificarlo impostandolo sul livello configurato nei server XenApp.
- Nella casella di testo Proprietà client ICA, impostare il livello di crittografia con la seguente proprietà: