Le proprietà ICA in Workspace ONE Access devono includere la proprietà di crittografia impostata sullo stesso livello di crittografia configurato nei server XenApp della farm. In caso contrario, gli utenti non possono accedere alle applicazioni o ai esktop pubblicati da Citrix.

Problema

Quando un utente si connette a una risorsa pubblicata da Citrix da Workspace ONE Access, viene visualizzato il messaggio di errore seguente.
Non si dispone del livello di crittografia appropriato per accedere a questa sessione

Causa

Workspace ONE Access non imposta i livelli di crittografia. Se il livello di crittografia impostato nel server XenApp è più elevato di quello predefinito utilizzato in Citrix Receiver, viene visualizzato l'errore seguente.

È necessario impostare un livello di crittografia più elevato in VMware Identity Manager.
Nota: Workspace ONE Access era in precedenza denominato VMware Identity Manager.

Soluzione

  1. Accedere alla console di Workspace ONE Access.
  2. Fare clic sulla scheda Catalogo > App virtuali, quindi fare clic su Impostazioni.
  3. Nel riquadro a sinistra, fare clic su Citrix XenApp o Citrix XenDesktop, in base alla propria distribuzione.
  4. Apportare le modifiche seguenti nelle sezioni Configurazione ICA e Configurazione ICA NetScaler.
    1. Nella casella di testo Proprietà client ICA, impostare il livello di crittografia con la seguente proprietà:
      EncryptionLevelSession=EncRC5-128
      In questo esempio il livello di crittografia viene impostato su 128, ma è necessario modificarlo impostandolo sul livello configurato nei server XenApp.
    2. Nella casella di testo Proprietà avvio ICA, impostare il livello di crittografia immettendo o modificando la proprietà seguente:

      [EncRC5-128]

      DriverNameWin16=pdc128w.dll

      DriverNameWin32=pdc128n.dll

      In questo esempio il livello di crittografia viene impostato su 128, ma è necessario modificarlo impostandolo sul livello configurato nei server XenApp.