Nessun grafico o dato visualizzato nei grafici delle prestazioni.

Problema

Quando in un grafico delle prestazioni non sono presenti dati, il grafico appare vuoto e viene visualizzato il messaggio Nessun dato disponibile.

Causa

Le cause della mancanza di dati nei grafici delle prestazioni qui descritti si basano sul presupposto che la configurazione di rollup predefinita per il sistema vCenter Server non sia stata modificata. Le cause includono, senza limitazione alcuna, gli scenari seguenti:
  • Le metriche introdotte in ESXi 5.0 non sono disponibili per gli host che eseguono versioni precedenti.
  • I dati vengono eliminati quando si rimuovono o si aggiungono oggetti a vCenter Server.
  • I dati dei grafici delle prestazioni per gli oggetti di inventario spostati in un nuovo sito da VMware vCenter Site Recovery Manager vengono eliminati dal sito precedente e non copiati nel nuovo sito.
  • I dati dei grafici delle prestazioni vengono eliminati quando si utilizza VMware vMotion in tutte le istanze di vCenter Server.
  • Le statistiche in tempo reale non sono disponibili per gli host disconnessi o per le macchine virtuali spente.
  • Le statistiche in tempo reale vengono raccolte sugli host e aggregate ogni 5 minuti. Dopo aver raccolto sei punti dati per circa 30 minuti, viene eseguito il rollup del database di vCenter Server per creare la statistica 1 giorno. Le statistiche 1 giorno potrebbero non essere disponibili per 30 minuti dopo l'ora corrente, in base a quando è iniziato il periodo di campionamento.
  • Viene eseguito il rollup delle statistiche 1 giorno per creare un punto dati ogni 30 minuti. Se si verifica un ritardo nell'operazione di rollup, le statistiche 1 settimana potrebbero non essere disponibili per 1 ora dopo l'ora corrente. Sono necessari 30 minuti per l'intervallo di raccolta di 1 settimana, più 30 minuti per l'intervallo di raccolta di 1 giorno.
  • Viene eseguito il rollup delle statistiche di 1 settimana per creare un punto dati ogni due ore. Se si verifica un ritardo nelle operazioni di rollup, le statistiche di 1 mese potrebbero non essere disponibili per 3 ore. Sono necessarie 2 ore per l'intervallo di raccolta di 1 mese, più 1 ora per l'intervallo di raccolta di 1 settimana.
  • Viene eseguito il rollup delle statistiche di 1 mese per creare un punto dati ogni giorno. Se si verifica un ritardo nelle operazioni di rollup, le statistiche potrebbero non essere disponibili per 1 giorno e 3 ore. L'intervallo di raccolta dell'anno precedente richiede un giorno, più 3 ore per l'intervallo di raccolta dell'ultimo mese. Durante questo periodo di tempo, i grafici sono vuoti.

Soluzione

  • Non è disponibile alcuna soluzione.