Lo stato dell'agente vSphere HA su un host è Agente non raggiungibile per un minuto o più. Per risolvere questa situazione, potrebbe essere necessario l'intervento dell'utente.

Problema

vSphere HA segnala che un agente ha stato Agente non raggiungibile quando l'agente per l'host non può essere contattato dall'host primario o da vCenter Server. Di conseguenza, vSphere HA non è in grado di monitorare le macchine virtuali nell'host e potrebbe non essere in grado di riavviarle dopo un errore.

Causa

Un agente vSphere HA può trovarsi nello stato Agente non raggiungibile per diversi motivi. Questa condizione spesso indica che un problema di rete impedisce a vCenter Server o all'host primario di contattare l'agente nell'host o che tutti gli host nel cluster non sono riusciti. Questa condizione può anche indicare la situazione improbabile in cui vSphere HA è stato disattivato e quindi riattivato nel cluster mentre vCenter Server non era in grado di comunicare con l'agente vSphere HA nell'host, oppure che nell'agente host ESXi nell'host si è verificato un errore e il processo watchdog non è stato in grado di riavviarlo. In questi casi, un evento di failover non viene attivato quando un host passa allo stato Non raggiungibile.

Soluzione

Stabilire se vCenter Server segnala che l'host non risponde. In tal caso, è presente un problema di rete, un errore dell'agente host ESXi o un errore generale del cluster. Una volta risolta la condizione, vSphere HA dovrebbe funzionare correttamente. In caso contrario, riconfigurare vSphere HA sull'host. Analogamente, se vCenter Server segnala che gli host rispondono ma lo stato di un host è Agente non raggiungibile, riconfigurare vSphere HA in tale host.