Prima di eseguire l'aggiornamento, è necessario assicurarsi che i seguenti prerequisiti siano rispettati.

Requisiti della configurazione del sistema

Prima di iniziare un aggiornamento, verificare che i seguenti requisiti di sistema siano soddisfatti.

  • Verificare che tutte le appliance e i server facenti parte della distribuzione soddisfino i requisiti di sistema relativi alla versione più recente. Vedere vRealize Automation Support Matrix all'indirizzo https://www.vmware.com/support/pubs/vcac-pubs.html.

  • Consultare il documento VMware Product Interoperability Matrix sul sito Web di VMware per informazioni sulla compatibilità con altri prodotti VMware.

  • Verificare che la versione di vRealize Automation dalla quale si sta effettuando l'aggiornamento sia in condizioni di funzionamento stabili. Correggere eventuali problemi prima di effettuare l'aggiornamento.

  • Se si esegue l'aggiornamento da vRealize Automation 6.2.x, registrare la chiave di licenza di vCloud Suite utilizzata per l'ambiente vRealize Automation corrente. In seguito all'aggiornamento, le chiavi di licenza esistenti verranno rimosse dal database. Non è necessario registrare la licenza se si effettua l'aggiornamento da vRealize Automation 7.x.

Requisiti di configurazione dell'hardware

Prima di iniziare un aggiornamento, verificare che i seguenti requisiti di sistema siano soddisfatti.

  • Prima di scaricare l'aggiornamento è necessario configurare l'hardware esistente. Vedere Incremento delle risorse hardware di vCenter Server per vRealize Automation 6.2.4 o 6.2.5.

  • Per poter eseguire l'aggiornamento sono necessari almeno 18 GB di RAM, 4 CPU, disco1 = 50 GB, disco3 = 25 GB e disco4=50 GB.

    Se la macchina virtuale è presente in vCloud Networking and Security, potrebbe essere necessario allocare più spazio RAM.

    Benché il supporto generico per VMware vCloud ® Networking and Security ™ 5.5.x (vCNS) sia terminato nel settembre 2016, le proprietà personalizzate di VCNS sono ancora valide per l'utilizzo in VMware NSX ™. Per ulteriori informazioni, vedere l'articolo della knowledge base End of Availability and End of General Support for VMware vCloud Networking and Security 5.5.x (2144733) (Fine della disponibilità e del supporto generico per VMware vCloud Networking and Security 5.5.x) all'indirizzo http://kb.vmware.com/kb/2144733.

  • Il sito Web IaaS primario, il database Microsoft SQL e il nodo Model Manager devono disporre di Microsoft .NET Framework 4.5.2 e di almeno 5 GB di spazio libero su disco.

  • Il sito Web IaaS primario, il database Microsoft SQL e il nodo Model Manager devono disporre di JAVA SE Runtime Environment 8, a 64 bit, aggiornamento 91 o successivo installato. Dopo aver installato Java, è necessario che la variabile di ambiente JAVA_HOME sia impostata sulla nuova versione in ogni nodo del server.

  • È necessario disporre di almeno 5,3 GB di spazio libero su disco nella partizione radice di ogni appliance vRealize Automation per scaricare ed eseguire l'aggiornamento.

  • Verificare la sottocartella /storage/log e rimuovere eventuali file ZIP precedenti archiviati per liberare spazio.

Prerequisiti generali

Prima di iniziare un aggiornamento, verificare che i seguenti requisiti di sistema siano soddisfatti.

  • Si dispone dell'accesso a un account di Active Directory con formato username@domain e autorizzazioni di binding alla directory.

  • Si dispone dell'accesso a un account con formato SAMaccountName dotato di privilegi sufficienti per unire il sistema al dominio creando dinamicamente un oggetto computer o per l'unione a un oggetto creato precedentemente.

  • Si dispone dell'accesso a tutti i database e a tutti i bilanciamenti del carico interessati o partecipanti all'aggiornamento di vRealize Automation.

  • Il sistema viene reso non disponibile per gli utenti durante l'esecuzione dell'aggiornamento.

  • Si disabilita ogni applicazione che effettua una query su vRealize Automation.

  • Verificare che Microsoft Distributed Transaction Coordinator (MSDTC) sia attivo in tutte le istanze di vRealize Automation e nei server SQL associati. Per istruzioni, vedere l'articolo della knowledge base di VMware Errore di varie attività dopo l'aggiornamento o la migrazione a VMware vCloud Automation Center (vCAC) 6.1.x (2089503) all'indirizzo http://kb.vmware.com/kb/2089503.

  • Se il proprio sito utilizza un'appliance vRealize Orchestrator esterna e la distribuzione utilizza un'appliance vRealize Orchestrator esterna connessa a Identity Appliance, effettuare l'aggiornamento di vRealize Orchestrator prima di aggiornare vRealize Automation.

  • Se si effettua l'aggiornamento di un ambiente distribuito configurato con un database PostgreSQL incorporato, esaminare i file nella directory pgdata nell'host master prima di aggiornare gli host di replica. Andare alla cartella di dati PostgreSQL sull'host master nel percorso /var/vmware/vpostgres/current/pgdata/. Chiudere tutti i file aperti nella directory pgdata e rimuovere gli eventuali file con suffisso .swp. Verificare che tutti i file di questa directory abbiano la proprietà corretta: postgres:users.

  • Se è stato installato un componente del catalogo di componenti comuni, è necessario disinstallarlo prima dell'aggiornamento. Per informazioni su come disinstallare, installare e aggiornare i componenti del Catalogo dei componenti comuni, vedere la guida all'installazione del catalogo di componenti comuni.