Quando si fa clic su Installa aggiornamenti nella pagina dello stato dell'aggiornamento dell'interfaccia di gestione dell'appliance vRealize Automation, viene visualizzato un messaggio di errore relativo all'agente di gestione.

Problema

Il processo di aggiornamento non va a buon fine. Viene visualizzato il messaggio che informa che è impossibile aggiornare l'agente di gestione nel nodo x. In alcuni casi, il messaggio riporta più nodi.

Causa

Questo problema può essere causato da diverse condizioni. Il messaggio di errore identifica solo l'ID del nodo della macchina interessata. Ulteriori informazioni sono disponibili nel file All.log per l'agente di gestione nella macchina in cui si è verificato l’errore di comando.

Nota:

L'aggiornamento di vRA potrebbe non riuscire dopo che il nuovo MSI dell'agente di gestione è stato aggiornato internamente in modo corretto. In questi casi, è possibile scaricare manualmente il nuovo MSI dalla console nella pagina dei download di VMware.

Eseguire queste attività sui nodi interessati in base alle proprie circostanze:

Soluzione

  • Se il servizio dell'agente di gestione non è in esecuzione, avviare il servizio e riavviare l'aggiornamento sull'appliance virtuale.
  • Se il servizio dell'agente di gestione è in esecuzione e l'agente di gestione viene aggiornato, riavviare l'aggiornamento sull'appliance virtuale.
  • Se il servizio dell'agente di gestione è in esecuzione ma l'agente di gestione non viene aggiornato, eseguire un aggiornamento manuale.
    1. Nel browser, accedere alla pagina di installazione di IaaS.

      https://vrealize-automation-appliance-FQDN:5480/installer

    2. Scaricare ed eseguire il programma di installazione dell'agente di gestione.
    3. Riavviare la macchina dell'agente di gestione.
    4. Riavviare l’aggiornamento sull’appliance virtuale.