Se si verificano problemi relativi al contatore delle prestazioni di Windows, è possibile che i server IaaS vengano segnalati come disconnessi.

Problema

Dopo l'installazione o l'aggiornamento dell'agente di gestione, il server IaaS invia ping all'appliance vRealize Automation. Il problema si verifica quando i ping non riescono, causando uno stato Non connesso per il server IaaS nella scheda Cluster dell'interfaccia di gestione dell'appliance vRealize Automation.

Nel server IaaS, viene visualizzato un errore simile al seguente nel file dell'agente di gestione All.log.

[UTC:2019-05-25 16:09:37 Local:2019-05-25 18:09:37] [Error]: [sub-thread-Id="4" context="" token=""] System.InvalidOperationException: Category does not exist.
at System.Diagnostics.PerformanceCounterLib.CounterExists(String machine, String category, String counter)
at System.Diagnostics.PerformanceCounter.InitializeImpl()
at System.Diagnostics.PerformanceCounter.NextSample()
at System.Diagnostics.PerformanceCounter.NextValue()
at VMware.IaaS.Component.Metrics.MetricsUtility.CalculateMachineProcessorMeasure(Int32 samplePeriodMilliseconds)
at VMware.IaaS.Management.Agent.ManagementEndpointService.CollectEnvironmentInfo()
at VMware.IaaS.Management.Agent.ManagementEndpointService.<PingAsync>d__0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1.ConfiguredTaskAwaiter.GetResult()
at VMware.IaaS.Management.Agent.ManagementAgent.<<PingManagementEndpointAsync>b__1f>d__23.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at VMware.IaaS.Management.Agent.ManagementAgent.<ExecutePeriodicAction>d__8.MoveNext()

Causa

Esiste un problema noto per cui i contatori delle prestazioni di Windows si danneggiano nel tempo causando l'errore.

Soluzione

Rigenerare tutti i contatori delle prestazioni, inclusi i contatori estendibili e di terze parti.

  1. Nel server IaaS, aprire un prompt dei comandi come Amministratore.
  2. Rigenerare i contatori:

    cd C:\Windows\system32

    lodctr /R

    cd C:\Windows\sysWOW64

    lodctr /R

  3. Sincronizzare nuovamente i contatori con Strumentazione gestione Windows (WMI):

    WINMGMT.EXE /RESYNCPERF

  4. Arrestare e riavviare i registri di prestazioni e il servizio Avvisi.
  5. Arrestare e riavviare il servizio Strumentazione gestione Windows.

Operazioni successive

Se i passaggi precedenti non risolvono il problema, vedere l'articolo 300956 del supporto tecnico Microsoft o l'l'articolo 2554336 del supporto tecnico Microsoft. Gli articoli descrivono come reimpostare manualmente i record del registro associato. È consigliabile eseguire prima il backup del registro.