Site Recovery Manager は、他のサービスに依存します。いずれかのサービスが実行されていない場合、Site Recovery Manager サーバ は起動しません。
問題
Site Recovery Manager インストーラを実行して
Site Recovery Manager のインストール、修復、または変更を行った後、または
Site Recovery Manager サーバ を再起動した後に、
Site Recovery Manager サーバ が起動しないか、または起動してから停止します。
原因
vCenter Server が実行されていない場合、それが Site Recovery Manager データベースに接続できない場合、または Site Recovery Manager が必要とする他のサービスが実行されていない場合、Site Recovery Manager サーバ が起動しないことがあります。
解決方法
- 最新の Site Recovery Manager サーバ ログ ファイルと Windows イベント ビューアで、エラーがあるかどうかを確認しす。
ほとんどのエラーは、
Site Recovery Manager サーバ のログ ファイルに表示されます。その他のエラーは、Windows イベント ビューアに表示されることがあります。たとえば、
Site Recovery Manager のログ サービスが開始される前に
Site Recovery Manager データベースを初期化するとします。データベース初期化中にエラーが発生した場合は、Windows イベント ビューアに表示されます。証明書の検証に関するエラーは Windows イベント ビューアに表示されます。
- Site Recovery Manager が拡張する vCenter Server インスタンスが実行されていることを確認します。
vCenter Server サービスが
Site Recovery Manager サーバ とは異なるホストで実行され、
vCenter Server サービスが停止すると、
Site Recovery Manager サーバ は正常に起動しますが、間もなく停止します。
- Site Recovery Manager データベース サービスが実行されていることを確認します。
組み込みデータベースを使用する場合は、VMware Postgres サービスが実行されていることを確認します。外部データベースを使用する場合は、適切な SQL Server サービスまたは Oracle Server サービスが実行されていることを確認します。
- Site Recovery Manager サーバ をインストールしたマシンにログインします。
- Site Recovery Manager が vCenter Server に接続できることを確認します。
- Windows の [コントロール パネル] から [プログラムと機能] を開きます。
- [VMware vCenter Site Recovery Manager] のエントリを選択し、[変更] をクリックします。
- [次へ] をクリックします。
- [変更] を選択します。
- vCenter Server のアドレスが正しいことを確認します。
vCenter Server マシンが固定アドレスではなく DHCP を使用している場合など、
Site Recovery Manager のインストール後に
vCenter Server のアドレスが変更されている場合は、
Site Recovery Manager を削除してから再インストールして再構成します。
- vCenter Server のパスワードを入力し、[次へ] をクリックします。
Site Recovery Manager のインストール後に
vCenter Server のパスワードを変更している場合は、新しいパスワードを入力します。
- [既存の証明書を使用] を選択し、[次へ] をクリックします。
- Site Recovery Manager データベースの認証情報が正しいことを確認します。
- Site Recovery Manager データベースが十分な接続を許可していることを確認します。
Site Recovery Manager ログに
GetConnection:使用可能な接続の待機中 というメッセージが含まれている場合は、データベース接続の最大数を増やします。これらの設定を変更する前に、データベース管理者に相談してください。
- [次へ] をクリックします。
データベースへの接続に失敗した場合は、
Site Recovery Manager インストーラを終了し、
手順 6 に進みます。
- [既存のデータを使用] を選択し、[次へ] をクリックします。
- Site Recovery Manager サービスのユーザー アカウントが正しいことを確認し、[次へ] をクリックします。
ローカル システム アカウント以外のアカウントを使用する場合は、ユーザー名とパスワードが正しいことを確認します。
- [インストール] をクリックして Site Recovery Manager の構成を更新するか、または変更していない場合は、[キャンセル] をクリックします。
- Site Recovery Manager が Site Recovery Manager データベースに接続できることを確認します。
- Windows ODBC データ ソース アドミニストレータ ユーティリティ、C:\Windows\System32\Odbcad32.exe を開きます。
- Site Recovery Manager のシステム DSN を選択し、[構成] をクリックします。
- データベースの設定を確認します。
- Site Recovery Manager が正しいデータベース サーバに接続しようとしていることを確認します。
- Site Recovery Manager データベースのログイン認証情報が正しいことを確認します。
- 認証方法が正しいことを確認します。
- [データ ソースのテスト] をクリックします。
接続が正しく構成されていると、
[ODBC データ ソースのテスト] ウィンドウに正常に終了したという結果が表示されます。
- 接続テストに失敗した場合は、データベース プロバイダから提供されている管理ソフトウェアを使用して Site Recovery Manager データベースを再構成します。
- Windows Server Manager ユーティリティを開き、 を選択します。
- Site Recovery Manager が必要とするサービスが実行されていることを確認します。
- Windows Server
- Windows Workstation
- 保護ストレージ
- Windows Server Manager ユーティリティで [VMware vCenter Site Recovery Manager サーバ] サービスを選択し、[起動] または [再起動] をクリックします。