Site Recovery Manager は、他のサービスに依存します。いずれかのサービスが実行されていない場合、Site Recovery Manager Server は起動しません。
問題
Site Recovery Manager インストーラを実行して Site Recovery Manager のインストール、修復、または変更を行った後、または Site Recovery Manager Server を再起動した後に、Site Recovery Manager Server が起動しないか、または起動してから停止します。
原因
Platform Services Controller または vCenter Server が実行されていない場合、Site Recovery Manager Server が Site Recovery Manager データベースに接続できない場合、または Site Recovery Manager が必要とする他のサービスが実行されていない場合に、Site Recovery Manager Server が起動しないことがあります。
解決方法
- 最新の Site Recovery Manager Server ログ ファイルと Windows イベント ビューアで、エラーがあるかどうかを確認しす。
ほとんどのエラーは、Site Recovery Manager Server のログ ファイルに表示されます。その他のエラーは、Windows イベント ビューアに表示されることがあります。たとえば、Site Recovery Manager のログ サービスが開始される前に Site Recovery Manager データベースを初期化するとします。データベース初期化中にエラーが発生した場合は、Windows イベント ビューアに表示されます。証明書の検証に関するエラーは Windows イベント ビューアに表示されます。
- Site Recovery Manager で拡張する Platform Services Controller インスタンスと vCenter Server インスタンスが実行中であることを確認します。
Platform Services Controller または vCenter Server サービスが Site Recovery Manager Server とは異なるホストで実行され、vCenter Server サービスが停止すると、Site Recovery Manager Server は正常に起動しますが、間もなく停止します。
- Site Recovery Manager データベース サービスが実行されていることを確認します。
組み込みデータベースを使用する場合は、Site Recovery Manager ホストの Windows サーバ マネージャ ユーティリティを開き、 を選択して VMware vCenter Site Recovery Manager 組み込みデータベース サービスが実行中であることを確認します。
外部データベースを使用する場合は、適切な SQL Server サービスまたは Oracle Server サービスがデータベース ホストで実行されていることを確認します。
- Site Recovery Manager Server をインストールしたマシンにログインします。
- 修正モードで Site Recovery Manager インストーラを実行し、インストールが正しく構成されたか確認します。
使用するインフラストラクチャで IP アドレスの変更を簡単にするには、可能な限り IP アドレスではなく、完全修飾ドメイン名 (FQDN) を指定します。
Platform Services Controller のアドレスが正しいことを確認します。
Site Recovery Manager のインストール後に vCenter Single Sign-On のパスワードを変更している場合は、新しいパスワードを入力します。
vCenter Server アドレスが正しいことを確認します。vCenter Server マシンが固定アドレスではなく DHCP を使用している場合など、Site Recovery Manager のインストール後に Site Recovery Manager のアドレスが変更されている場合は、Site Recovery Manager を削除してから再インストールして再構成します。
Site Recovery Manager Server のローカル ホスト アドレスが正しいことを確認します。
Site Recovery Manager データベースの認証情報が正しいことを確認します。
Site Recovery Manager データベースが十分な接続を許可していることを確認します。Site Recovery Manager ログに GetConnection:使用可能な接続の待機中 というメッセージが含まれている場合は、データベース接続の最大数を増やします。これらの設定を変更する前に、データベース管理者に相談してください。
Site Recovery Manager サービスのユーザー アカウントが正しいことを確認します。ローカル システム アカウント以外のアカウントを使用する場合は、ユーザー名とパスワードが正しいことを確認します。
- Windows ODBC Data Source Administrator ユーティリティを実行し、Site Recovery Manager が Site Recovery Manager データベースに接続できるか確認します。
- Windows Server Manager ユーティリティを開き、 を選択します。
- Site Recovery Manager が必要とするサービスが実行されていることを確認します。
Windows Server
Windows Workstation
保護ストレージ
- Windows Server Manager ユーティリティで VMware vCenter Site Recovery Manager サーバ サービスを選択し、起動 または 再起動 をクリックします。