Site Recovery Manager ソリューション ユーザーに IP カスタマイズまたはゲスト OS 内の呼び出し操作を実行する権限がない場合、リカバリ プロセス中にエラーが発生することがあります。

問題

Site Recovery Manager ソリューション ユーザーにリカバリする仮想マシンのゲスト OS に対する適切な権限がない場合、リカバリ プロセス中に次のいずれかのエラー メッセージが表示されることがあります。
GuestPermissionDenied
CannotAccessFile

原因

この問題は、 Site Recovery Manager ソリューション ユーザーがゲスト OS のファイルにアクセスする権限またはコマンドを実行する権限を持たないゲスト OS ユーザーにマッピングされている場合に発生します。

解決方法

  1. Site Recovery Manager を使用してゲスト ユーザー マッピングを構成する場合は、VMware Tools サービスを実行するゲスト OS ユーザーにファイルにアクセスする権限またはコマンドを実行する権限があることを確認します。
    ゲスト ユーザー マッピングの自動構成を有効または無効にする方法については、 リカバリ設定の変更を参照してください。
  2. (オプション) ゲスト ユーザー マッピングを手動で構成する場合は、リカバリ サイトにローカルな Site Recovery Manager ソリューション ユーザーを適切な権限を保有するゲスト OS ユーザーにマッピングします。
  3. リカバリ プランを再実行します。