一部のメトリックはヘルプデスク API に依存しています。

問題

ヘルプデスク API が原因でヘルプデスク メトリックが欠落する

Horizon セッションに関するすべてのプロトコル メトリック、履歴パフォーマンス メトリック、アプリケーション メトリックが欠落します。

原因

  1. [RDS の履歴パフォーマンス メトリック収集の有効化] フラグが False に設定されているため、CPU 全体、メモリ全体、ディスク IOPS メトリックが無効になり、履歴パフォーマンス メトリックのヘルプデスク API 呼び出しがオフになっています。

  2. [プロトコル パフォーマンス メトリックの収集を有効にする] フラグが False に設定されているため、フレーム レート、遅延、受信パケット ロス、転送パケット ロス、帯域幅送信使用率のメトリックが無効になり、プロトコル メトリックのヘルプデスク API 呼び出しがオフになっています。

  3. [アプリケーション メトリックの収集を有効にする] フラグが False に設定されているため、CPU、ディスク使用率メトリックが無効になり、Horizon アプリケーション セッションのヘルプデスク API 呼び出しがオフになっています。

  4. Horizon Agent でヘルプデスク API プラグインが有効になっていないため、アダプタがメトリックを収集できません。症状として、ログに「ErrorCode=1001 - Unable to forward message to the AgentHelpDesk queue: NoQueueHandler」というエラー メッセージが記録されます。

解決方法

  1. Horizon Agent でヘルプデスク プラグインを有効にし、Horizon ヘルプデスク ライセンスが使用可能であることを確認します。

  2. アダプタの詳細設定で対応するフラグを有効にします。