Horizon Administrator が ThinApp アプリケーションをアンインストールできません。

問題

ThinApp アプリケーションのインストール ステータスに、Uninstall Error(アンインストール エラー) と表示されます。

原因

このエラーの一般的な原因には次のようなものがあります。

  • Horizon Administrator がアンインストールしようとしたときに、ThinApp アプリケーションがビジー状態だった。
  • 接続サーバ ホストとマシン間のネットワーク接続が切断されている。

問題の原因に関する詳細は、Horizon Agent と接続サーバのログ ファイルで参照できます。

Horizon Agent ログ ファイルは、マシンの drive:\Documents and Settings\All Users\Application Data\VMware\VDM\logs(Windows XP システムの場合)または drive:\ProgramData\VMware\VDM\logs(Windows 7 システムの場合)にあります。

接続サーバ ログ ファイルは接続サーバ ホストの drive:\Documents and Settings\All Users\Application Data\VMware\VDM\logs ディレクトリにあります。

解決方法

  1. Horizon Administrator で、[カタログ] > [ThinApps] の順に選択します。
  2. ThinApp アプリケーションの名前をクリックします。
  3. [マシン] タブをクリックし、マシンを選択し、[インストールを再試行] をクリックしてアンインストール操作を再試行します。
  4. アンインストール操作が依然として失敗する場合は、ThinApp アプリケーションをマシンから手動で削除し、[デスクトップのアプリ ステータスを削除] をクリックします。
    このコマンドによって、Horizon Administrator での ThinApp アプリケーション割り当てが解除されます。マシン内のファイルや設定は削除されません。
    重要: このコマンドは、ThinApp アプリケーションをマシンから手動で削除した後にのみ使用してください。