Horizon Client からサーバに直接接続できない場合、またはデスクトップやアプリケーションの資格が Horizon Client に表示されない場合、サーバで Workspace ONE モードが有効になっていない可能性があります。

問題

  • Horizon Client からサーバに直接接続すると、Horizon ClientWorkspace ONE ポータルにリダイレクトします。
  • URI またはショートカットでデスクトップまたはアプリケーションを開くか、ファイルの関連付けからローカル ファイルを開くと、Workspace ONE ポータルにリダイレクトされ、認証が実行されます。
  • Workspace ONE からデスクトップまたはアプリケーションを開き、Horizon Client を開始すると、資格のある他のリモート デスクトップまたはアプリケーションを Horizon Client で表示したり、開いたりすることができなくなります。

原因

Horizon 7 バージョン 7.2 以降では、Horizon 管理者が接続サーバ インスタンスで Workspace ONE モードを有効にできます。接続サーバ インスタンスで Workspace ONE モードが有効になっている場合、この動作は正常です。

解決方法

Workspace ONE を使用して、Workspace ONE が有効になっているサーバに接続し、リモート デスクトップとアプリケーションにアクセスしてください。