Connection Server で証明書に関する問題があると、Horizon Console に接続できなかったり、サーバに対して赤色の健全性インジケータが表示されたりします。

問題

問題がある Connection Server インスタンスでは、Horizon Console に接続できません。同じポッドにある別の Connection Server インスタンス上で Horizon Console に接続すると、問題の Connection Server インスタンスのダッシュボード健全性インジケータが赤色で表示されています。

他の Connection Server インスタンスから赤色の健全性インジケータをクリックすると、SSL 証明書: 無効ステータス:(空白)が表示され、有効な証明書が見つからなかったことを示します。VMware Horizon ログ ファイルには、ERROR タイプのログ エントリと「キーストアに正規の証明書がありません」というエラー テキストが含まれます。

VMware Horizon ログ データは、Connection Server インスタンスの <Drive Letter>:\ProgramData\VMware\log\ConnectionServer にあります。
注: このファイル パスは、ログ ファイルの実際の場所 ( <Drive Letter>:\ProgramData\VMware\VDM\logs)にリダイレクトするシンボリック リンクです。

原因

次のような理由で証明書が VMware Horizon サーバに正常にインストールされなかった可能性があります。

  • 証明書が Windows ローカル コンピュータ証明書ストアの個人フォルダ内にない。
  • 証明書ストアに証明書のプライベート キーがない。
  • 証明書に [vdm] のフレンドリ名がない。
  • 証明書が v3 証明書テンプレートから生成された(Windows Server 2008 以降のサーバの場合)。VMware Horizon はプライベート キーを検出できませんが、証明書スナップインを使用して Windows 証明書ストアを検証する場合、ストアにはプライベート キーがあることが示されます。

解決方法