Security Intelligence 機能は正常に有効化されましたが、一部のサービスが劣化しています。

問題

Security Intelligence 機能は正常に有効になりましたが、その健全性が PARTIALLY UP または DOWN と報告されています。この劣化状態は、Security Intelligence 機能の有効化直後か、そのライフサイクルでの後のステージで報告されます。

原因

次のような原因が考えられます。

  1. Docker レジストリに TKC またはアップストリーム Kubernetes ワーカー ノードからアクセスできない。
  2. Security Intelligence アプリケーション ポッドが Running 状態に到達できなかった。

解決方法

Kubernetes のインフラストラクチャ管理者と相談のうえ、問題の修正を試みてください。次の解決策を試してください。番号はそれぞれ、前のセクションで示した問題の番号に対応しています。

  1. 必要なポッドをすべて起動できるかどうかを確認します。ポッドを起動できるかどうかは、Docker レジストリにアクセスできるかどうかによって異なります。認証または認可の問題が原因で Docker レジストリにアクセスできないかダウンロード操作に失敗した場合、Kubernetes ワーカー ノードは、ワークロードの実行に必要な Docker コンテナ イメージをダウンロードできないことがあります。Docker レジストリの接続の問題を修正してから Security Intelligence 機能を削除し、有効化を再度試みてください。
  2. すべてのポッドが Running 状態になり、すべてのジョブが正常に完了したことを確認します。Docker コンテナ イメージがダウンロードされたら、ポッドを起動して実行できる必要があります。Running 状態でないポッドについては、次の describe コマンドを使用してイベントを確認します。
    napp-k describe pod <pod-name>
    正常に完了しなかったジョブについては、次のコマンドを使用してログを確認します。
    napp-k logs <pod-name>

上記の解決策でも問題が解決できない場合は、VMware のサポートにお問い合わせください。