NSX Manager ユーザー インターフェイスを使用した NSX Application Platform サポート バンドルの収集を実行できません。

問題

NSX Application Platform を展開または削除しようとしましたが、操作を完了する前に失敗しました。NSX Application Platform にアクセスできなくなったため、NSX Manager ユーザー インターフェイスを使用してサポート バンドルにアクセスし、操作が失敗した理由を探る方法がなくなりました。

原因

展開または削除の操作が失敗した理由は複数考えられます。

解決方法

展開または削除の操作が失敗した理由を見つけるには、次の情報を参照し、 NSX Manager CLI を使用してサポート バンドルを収集します。
  1. NSX Manager アプライアンス CLI に admin ユーザーとしてログインします。
  2. サポート バンドルを生成する前に、CLI プロンプトで次のコマンドを入力します。
    set napp kubeconfig
  3. kubeconfig ファイルの内容を入力し、Ctrl + D キーを押します。

    このアクションは、NSX Application Platform で使用されている既存の kubeconfig ファイルをオーバーライドします。

  4. 次のコマンドを使用してサポート バンドル ファイルを取得します。support-bundle-filename は、システムが、生成したサポート バンドル ファイルに使用するファイル名です。
    get support-bundle file support-bundle-filename.tgz
    

    有効な kubeconfig ファイルの内容を入力すると、support-bundle-filename.tgz ファイルの展開後、/napp フォルダ内に NSX Application Platform サポート ログ ファイルが見つかります。

    入力した kubeconfig ファイルの内容が無効な場合、/napp フォルダは空になります。

  5. サポート バンドル ファイルを NSX Manager ホストからリモート ホストの場所に安全に転送するには、次のコマンドを使用します。
    copy file support-bundle-filename.tgz url remote-host-url

    remote-host-url の形式は scp://<username>@<ip-address>:<dir> です。<username> が、リモート ホストに対してアクセス権のある有効なユーザー アカウントです。<ip-address> は、リモート ホストの IP アドレスです。<dir> は、サポート バンドル ファイルの転送先となるフォルダです。