システムが Postgres データベースを展開しようとしたときに、NSX Metrics 機能の展開中にエラーが発生しました。

問題

NSX Metrics 機能で使用される Postgres データベースの展開中に、システムで問題が発生しました。

原因

メトリック Postgres データベースの展開が失敗する理由は複数あります。

解決方法

  1. システムが NSX Application Platform を正常に展開したことを確認します。
  2. NSX Manager コマンド ライン インターフェイス (CLI) にアクセスできる場合は、次の手順を使用して、NSX Metrics ログに記録されているエラーを調査します。NSX Manager CLI にアクセスできない場合は、手順 3 で提供されている情報を使用します。
    1. NSX Manager アプライアンスに root ユーザーとしてログインします。
    2. 後続の helm および kubectl コマンドの呼び出しに対してスーパーバイザーまたはアップストリーム Kubernetes 構成上の TKG クラスタをマークします。
      export KUBECONFIG=/config/vmware/napps/.kube/config
    3. 次のコマンドを使用して、システムが Metrics Helm チャートを正常に展開したことを確認します。
      helm --namespace nsxi-platform list --all --filter 'metrics'

      STATUS プロパティには、deployed が表示される必要があります。

    4. 次のコマンドを使用して、セットアップ ポッドが展開され、正常に完了したことを確認します。
      kubectl --namespace nsxi-platform get pods --selector='app.kubernetes.io/instance=metrics,app.kubernetes.io/name=postgresql-ha'
    5. 次のコマンドを使用して、展開されなかった、または Ready 状態でないセットアップ ポッドのログを調べます。
      kubectl --namespace nsxi-platform logs <POD_NAME>
  3. NSX Manager CLI にアクセスできない場合は、ユーザー インターフェイスを使用した NSX Application Platform のサポート バンドルの収集の情報を使用して NSX Application Platform サポート バンドルを収集します。名前が metrics-postgresql-ha で始まるスーパーバイザーまたはアップストリーム Kubernetes ポッド上の TKG クラスタのサポート バンドル ログを調べます。
  4. ログで報告されたエラーを解決します。
  5. ログで報告されたエラーを解決したら、NSX Manager ユーザー インターフェイスを使用して NSX Application Platform の展開を再試行します。