タイムアウトのため、NSX Application Platform 展開操作に失敗しました。
問題
NSX Application Platform の展開が完了できず、操作がタイムアウトになりました。
原因
NSX Application Platform の展開プロセスでは、メッセージング、データ ストレージ、分析などに使用される複数のサービスがインストールされます。展開の開始から 20 分以内にこれらのサービスが開始されない場合、展開プロセスはタイムアウト エラーで停止します。タイムアウト エラーの原因としては、CPU の競合、ストレージの競合、ネットワーク接続の問題など、インフラストラクチャの問題が考えられます。
解決方法
- root アカウントで NSX Manager アプライアンスにログインします。
- 次のコマンドを使用して、nsxi-platform ポッドが正常に展開されていることを確認します。
napp-k get pods --selector='app.kubernetes.io/instance=nsxi-platform'
ポッドの状態が「実行中」または「完了」のいずれかの場合、ポッドが正常に起動したことを意味します。
引き続きポッドの状態が次のいずれかの場合は、ポッドが正常に起動しなかったことを示す可能性があります。
- Init/Podinitializing/CrashLoopBackOff
- 保留
- ContainerCreating
- ImagePullBackOff
- ErrImagePull
- ImageInspectError
- CreateContainerConfigError
- 展開の開始から 20 分以内にいずれかのポッドが起動せず、タイムアウト エラーが発生して展開が停止した場合は、CPU の競合、ストレージの競合、ネットワーク接続の問題など、インフラストラクチャに問題があるかどうかを調べます。問題を解決して、NSX Manager ユーザー インターフェイスから NSX Application Platform の展開を再試行します。
- 展開が引き続きタイムアウトになる場合は、次のコマンドを使用して、起動に失敗した各ポッドのログ ファイルを調べます。
手順 2 のコマンド出力で
<POD_NAME> を確認します。
napp-k logs <POD_NAME>
- ログ ファイルで報告されたエラーを解決して、NSX Manager ユーザー インターフェイスから NSX Application Platform の展開を再試行します。
- 展開が引き続き失敗する場合は、VMware のサポートにお問い合わせください。