問題

  • ホストにアクセスできません。ユーザー名またはパスワードが正しくないため、ログインを完了できません。
  • トランスポート ノードの適用タスクがエラー「ノードはすでに存在します」で失敗します。
  • ホストが実態がない状態です。

原因

この問題は、トラフィックの負荷が高く競合状態になるために発生します。API(非推奨)GET /api/v1/transport-nodes/<TN-UUID>/status または GET api/v1/infra/sites/<site-id>/enforcement-points/<enforcementpoint-id>/host-transport-nodes/<host-transport-node-id>/state | status を実行します。この場合、enforcementpoint-idsite-id のデフォルト値は default で、トランスポート ノードを確認すると、トランスポートの状態は不明で、ノードの展開状態は 失敗 と表示されます。

これらのすべてのケースは、削除タスクの開始時に正しくクリーンアップされなかったホスト TN NSX発生するため、NSX Managerに登録されたままです。

この場合、GET トランスポート ノード API と GET トランスポート ノードの状態 API は失敗しますが、GET トランスポート ノードの状態 API は動作し、「ホストのソフトウェアをアンインストールできませんでした。」というエラー メッセージが表示されます。

解決方法

  • 古いエントリの存在を修正するには、ホストからNSXを強制的に削除し、次の API を実行して、セットアップ内の古いホスト エントリを削除する必要があります。
    1. (NSX Manager ユーザー インターフェイス)[ホスト] ページで、[強制的に削除] オプションを選択し、[NSX の削除] をクリックします。
    2. (API) NSX を強制的に削除するには、API https://{{MPIP}}/api/v1/transport-nodes/<Transport-Node-UUID>?force=true&unprepare_host=false を実行します。
    3. (API) 古いエントリを削除するには、API https://{{nsx-mgr-ip}}/api/v1/transport-nodes?action=clean_stale_entries を実行します。