Workspace ONE Access コンソールでディレクトリが正常に同期されましたが、同期されたグループにユーザーがまったく表示されません。

問題

ディレクトリが手動または同期スケジュールに基づいて自動で同期された後に、同期が正常に完了しますが、同期されたグループにユーザーがまったく表示されません。

注: グループにアプリケーションの使用資格が付与されていること、またはグループ名がアクセス ポリシー ルールに追加されていることを確認します。グループを追加して同期すると、グループ名のみがディレクトリに同期されます。グループのメンバーであるユーザーは、グループにアプリケーションの使用資格が付与されるか、グループ名がアクセス ポリシー ルールに追加されるまで、ディレクトリに同期されません。

原因

この問題は、クラスタに 2 つ以上のノードがあり、ノード間で 5 秒以上の時刻の差がある場合に発生する可能性があります。

解決方法

  1. ノード間で時刻の差がないことを確認します。クラスタ内のすべてのノードで同じ NTP サーバを使用し、時刻を同期させます。
  2. すべてのノードでサービスを再起動します。
    service horizon-workspace restart
  3. (オプション)Workspace ONE Access コンソール で、グループを削除し、同期設定で再度追加して、ディレクトリを再同期します。