[クラスタで許容するホスト障害] アドミッション コントロール ポリシーを使用している場合、不十分なフェイルオーバー リソースにより vSphere HA クラスタが無効 (赤) になることがあります。
問題
[クラスタで許容するホスト障害] アドミッション コントロール ポリシーを選択し、特定の問題が発生した場合、クラスタが赤になります。
原因
この問題は、クラスタでホストが切断されている、メンテナンス モードになっている、応答しない、または vSphere HA エラーがある場合に発生することがあります。切断され、メンテナンス モードになっているホストは、通常、ユーザーのアクションによって生じます。応答しない、またはエラーがあるホストは、通常、より深刻な問題、たとえば、ホストやエージェントに障害が発生した、またはネットワークの問題が存在することによって生じます。
この問題の別の考えられる原因として、ほかの仮想マシンよりも著しく大きいメモリまたは CPU の予約がある仮想マシンがクラスタに含まれている場合が挙げられます。[クラスタで許容するホスト障害] アドミッション コントロール ポリシーは、2 つのコンポーネントを構成するスロット サイズの計算、および仮想マシンの CPU およびメモリの予約に基づいています。このスロットサイズの計算が、異常な仮想マシンによって歪曲された場合、アドミッション コントロール ポリシーは制限が付きすぎとなり、赤のクラスタが生じます。この場合は、vSphere HA の詳細オプションを使用してスロット サイズを小さくするか、別のアドミッション コントロール ポリシーを使用するか、またはポリシーを変更して許容されるホスト障害の数が少なくなるようにします。
解決方法
クラスタ内のすべてのホストが健全であること、つまり、接続されており、メンテナンス モードになっておらず、vSphere HA エラーがないことを確認します。vSphere HA アドミッション コントロールは、健全なホストのリソースのみを考慮します。