一定の条件下では、vSphere Distributed Switch 5.5 以降で、既存の LACP 構成から強化された LACP サポートへの変換が失敗する場合があります。

問題

vSphere Distributed Switch をバージョン 5.5 以降にアップグレードした後、既存の LACP 構成から強化された LACP サポートへの変換を開始すると、プロセスの特定の段階で変換が失敗します。

原因

既存の LACP 構成から強化された LACP サポートへの変換には、Distributed Switch を再構成するためのいくつかのタスクが含まれています。変換中に別のユーザーが Distributed Switch を再構成すると、変換が失敗する場合があります。たとえば、ホストからの物理 NIC が別のアップリンクに再割り当てされていたり、分散ポート グループのチーミングおよびフェイルオーバー構成が変更されていたりする可能性があります。

失敗のもう 1 つの原因として、変換中に一部のホストが切断された可能性もあります。

解決方法

強化された LACP サポートへの変換が特定の段階で失敗した場合、変換は部分的にしか完了していません。Distributed Switch および参加しているホストの構成を確認して、LACP 構成が不完全なオブジェクトを特定する必要があります。

表に記載された順に、ターゲット構成をチェックして、変換の各段階で変換が適切に行われたかどうかを確認します。変換が失敗した段階を特定したら、ターゲット構成を手動で完了して、以降の変換段階を続行します。

表 1. 強化された LACP への変換を手動で完了するためのステップ
変換段階 ターゲット構成の状態 ソリューション
1.新しい LAG を作成します。 新しく作成された LAG は、Distributed Switch にある必要があります。 Distributed Switch の LACP 構成を確認して、LAG がない場合には、新しい LAG を作成します。
2.分散ポート グループに、中間 LACP チーミングおよびフェイルオーバー構成を作成します。 新しく作成される LAG は、接続を失わずに物理 NIC を LAG に移行できるスタンバイ状態である必要があります。

分散ポート グループのチーミングとフェイルオーバーの構成を確認します。新しい LAG がスタンバイに設定されていない場合は、そのように設定します。

LAG を使用してすべての分散ポート グループのトラフィックを処理しない場合は、スタンドアロン アップリンクがアクティブで LAG が使用されていない状態に、チーミングおよびフェイルオーバー構成を戻します。

3.スタンドアロン アップリンクから LAG ポートに物理 NIC を再割り当てします。 LAG ポートからのすべての物理 NIC は、スタンドアロン アップリンクから LAG ポートに再割り当てされる必要があります。

物理 NIC が LAG ポートに割り当てられているかどうかを確認します。物理 NIC をすべての LAG ポートに割り当てます。

注: LAG は、物理 NIC を LAG ポートに再割り当てする間、分散ポート グループのチーミングおよびフェイルオーバーの順序でスタンバイ状態のままである必要があります。
4.分散ポート グループに、最後の LACP チーミングおよびフェイルオーバー構成を作成します。

最後の LACP チーミングおよびフェイルオーバー構成は次のとおりです。

  • アクティブ: 新しい LAG のみ
  • スタンバイ: 空
  • 未使用: すべてのスタンドアロン アップリンク
分散ポート グループのチーミングとフェイルオーバーの構成を確認します。LACP を適用するすべての分散ポート グループに、有効な LACP チーミングおよびフェイルオーバー構成を作成します。

たとえば、新しい LAG が Distributed Switch に作成されたことと、分散ポート グループに対して中間チーミングおよびフェイルオーバー構成が作成されたことを確認していると想定します。LAG ポートに割り当てられた物理 NIC があるかどうかの確認を続けます。LAG ポートに物理 NIC が割り当てられていないホストがあることを検出したら、NIC を手動で割り当てます。分散ポート グループの最後の LACP チーミングおよびフェイルオーバー構成を作成して、変換を完了します。