vSphere HA エージェントが、ネットワーク隔離状態です。この状況を解決するには、ユーザの介入が必要です。

問題

ホストがネットワーク隔離状態になっている場合、考慮するのは、隔離されたホストと、プライマリ ロールを保持する vSphere HA エージェントの 2 つです。

  • 隔離されたホストで、vSphere HA エージェントは構成されている隔離への応答を実行中の仮想マシンに適用し、それらの仮想マシンをシャットダウンまたはパワーオフするかどうかを判別します。この判別は、プライマリ エージェントで各仮想マシンを実行することができるかどうかを(仮想マシンのホーム データストアをロックすることによって)チェックした後に行われます。実行できない場合、エージェントは仮想マシンの隔離への応答の適用を保留し、短い遅延の後にデータストアの状態を再度チェックします。
  • vSphere HA プライマリ エージェントがデータストアの 1 つ以上にアクセスできる場合、隔離されたときにホストで実行されていた仮想マシンを監視し、パワーオフまたはシャットダウンされた仮想マシンの再起動を試みます。

原因

次の両方の条件が満たされる場合、ホストはネットワーク隔離されています。

  • 隔離アドレスが構成されていて、ホストがこれらのアドレスに ping できない。
  • ホスト上の vSphere HA エージェントが、別のクラスタ ホスト上で実行しているすべてのエージェントにアクセスできない。
注: vSphere HA クラスタで vSAN が有効になっている場合、クラスタ内の他の vSphere HA エージェントと通信できず、構成済みの隔離アドレスにアクセスできないと、ホストは隔離されていると判断されます。vSphere HA エージェントがエージェント内の通信に vSAN ネットワークを使用していますが、デフォルトの隔離アドレスは依然としてホストのゲートウェイです。そのため、デフォルトの構成では、両方のネットワークとも失敗した場合にのみ、ホストが隔離されていると判断することができます。

解決方法

ホストが隔離アドレスに ping すること、およびほかのホストと通信することを不可能にしているネットワークの問題を解決してください。