vSAN データストアにデータを保存する仮想マシンの状態は、vSAN クラスタの障害が原因で「非準拠」、「アクセス不可」、または「実体なし」と表示されます。
問題
vSAN データストアの仮想マシンが vSAN クラスタの障害を示す次のいずれかの状態になります。
- 仮想マシンが非準拠、そのオブジェクトの一部のコンプライアンス ステータスが非準拠。「vSAN での仮想マシンのコンプライアンスの調査」を参照してください。
- 仮想マシン オブジェクトがアクセス不可または実体なし。「コンポーネントの障害状態の調査」を参照してください。
オブジェクトのレプリカが別のホストで使用可能な場合、vSAN は仮想マシンの I/O 操作をそのレプリカに転送します。
原因
割り当てられた仮想マシン ストレージ ポリシーの要件を仮想マシンのオブジェクトが満たさなくなると、vSAN はそのオブジェクトを非準拠とみなします。たとえば、ホストの接続が一時的に失われている場合があります。「vSAN の問題を示すオブジェクトの状態」を参照してください。
vSAN がオブジェクトの完全なレプリカまたは 50% を超える投票を見つけられない場合、仮想マシンはアクセス不可になります。仮想マシン ホーム ネームスペースが破損しているため、.vmx ファイルがアクセス不可であることを vSAN が検出すると、仮想マシンは実体なしになります。「vSAN の障害時における仮想マシンのアクセシビリティ」を参照してください。
解決方法
クラスタに十分なリソースが含まれていて障害が永続的な場合、vSAN は破損したオブジェクトを自動的にリカバリします。
破損したオブジェクトを再構築するのに十分なリソースがクラスタに含まれていない場合は、クラスタ内の容量を拡張します。「VMware vSAN の管理」を参照してください。