状況に応じて、vCenter Server OIDC を NSX Manager に再登録する必要があります。たとえば、vCenter Server の FQDN/PNID が変更された場合などです。

手順

  1. SSH [Secure SHell] を介して vCenter Server アプライアンスに接続します。
  2. shell コマンドを実行します。
  3. vCenter Server サムプリントを取得するには、次のコマンドを実行します。
    - openssl s_client -connect vcenterserver-FQDN:443 </dev/null 2>/dev/null | openssl x509 -fingerprint -sha256 -noout -in /dev/stdin
    サムプリントが表示されます。たとえば、 08:77:43:29:E4:D1:6F:29:96:78:5F:BF:D6:45:21:F4:0E:3B:2A:68:05:99:C3:A4:89:8F:F2:0B:EA:3A:BE:9D
  4. SHA256 サムプリントをコピーし、コロンを削除します。
    08774329E4D16F2996785FBFD64521F40E3B2A680599C3A4898FF20BEA3ABE9D
  5. vCenter Server の OIDC を更新するには、次のコマンドを実行します。
    curl --location --request POST 'https://<NSX-T_ADDRESS>/api/v1/trust-management/oidc-uris' \
        --header 'Content-Type: application/json' \
        --header 'Authorization: Basic <AUTH_CODE>' \
        --data-raw '{
     "oidc_type": "vcenter",
         "oidc_uri": "https://<VC_ADDRESS>/openidconnect/vsphere.local/.well-known/openid-configuration",
         "thumbprint": "<VC_THUMBPRINT>"
        }'

NSX アプライアンスのパスワードを変更できない

rootadmin、または audit ユーザーの NSX アプライアンス パスワードを変更できない場合があります。

問題

rootadmin、または audit ユーザーの NSX アプライアンス パスワードを、vSphere Client を介して変更すると失敗することがあります。

原因

NSX Manager のインストール時は、3 つのロールすべてに対して 1 つのパスワードのみが受け入れられます。このパスワードを後で変更すると失敗することがあります。

解決方法

  • NSX API を使用してパスワードを変更します。
    詳細については、 https://kb.vmware.com/s/article/70691と『 NSX 管理ガイド』を参照してください。

障害が発生したワークフローと不安定な NSX Edge のトラブルシューティング

ワークフローで障害が発生している場合や NSX Edge が不安定になっている場合は、トラブルシューティング手順を実行することで対処できます。

問題

vSphere Client で分散ポート グループ設定を変更すると、ワークフローで障害が発生し、NSX Edge が不安定になることがあります。

原因

クラスタ設定の NSX Edge クラスタの設定中に作成されたオーバーレイおよびアップリンクの分散ポート グループを削除または変更することは、設計上許可されていません。

解決方法

NSX Edge の VLAN または IP アドレス プール設定を変更する必要がある場合は、まず NSX の要素と vSphere IaaS control plane の設定をクラスタから削除する必要があります。

NSX の要素の削除については、『NSX インストール ガイド』を参照してください。

NSX のトラブルシューティングのためのサポート バンドルの収集

トラブルシューティングのために登録済みのクラスタおよびファブリック ノードのサポート バンドルを収集して、そのバンドルをマシンにダウンロードするか、ファイル サーバにアップロードすることができます。

バンドルをマシンにダウンロードする場合は、マニフェスト ファイルと各ノードのサポート バンドルで構成される単一のアーカイブ ファイルが取得されます。バンドルをファイル サーバにアップロードする場合は、マニフェスト ファイルと個々のバンドルがファイル サーバに個別にアップロードされます。

手順

  1. ブラウザから、管理者権限で NSX Manager にログインします。
  2. [システム] > [サポート バンドル] の順に選択します。
  3. ターゲット ノードを選択します。
    選択可能なノードのタイプは、 [管理ノード][Edge][ホスト]、および [Public Cloud Gateway] です。
  4. (オプション) ログの有効期間を日数で指定します。指定した日数を経過したログは除外されます。
  5. (オプション) コア ファイルおよび監査ログを含めるか除外するかを示すスイッチを切り替えます。
    注: コア ファイルと監査ログには、パスワードや暗号化キーなどの機密情報が含まれている場合があります。
  6. (オプション) バンドルをファイル サーバにアップロードするには、このチェック ボックスを選択します。
  7. [バンドル収集の開始] をクリックして、サポート バンドルの収集を開始します。
    各ノードのログ ファイルの数によって、サポート バンドルの収集にかかる時間が決まります。
  8. 収集プロセスのステータスを監視します。
    [ステータス] タブに、サポート バンドルの収集の進行状況が表示されます。
  9. バンドルをファイル サーバに送信するオプションを設定しなかった場合は、[ダウンロード] をクリックしてバンドルをダウンロードします。

NSX のログ ファイルの収集

エラーの検出やトラブルシューティングのために、vSphere IaaS control plane および NSX コンポーネントのログを収集することができます。ログ ファイルは VMware サポートによって要求される場合があります。

手順

  1. vSphere Client を使用して、vCenter Server にログインします。
  2. 以下のログ ファイルを収集します。
    ログ ファイル 説明
    /var/log/vmware/wcp/wcpsvc.log vSphere IaaS control plane の有効化に関する情報が含まれています。
    /var/log/vmware/wcp/nsxd.log NSX コンポーネントの構成に関する情報が含まれています。
  3. NSX Manager にログインします。
  4. 特定の vSphere IaaS control plane の操作が失敗したときに NSX Manager が返すエラーに関する情報については、/var/log/proton/nsxapi.log を収集します。

NSX の管理証明書、サムプリント、または IP アドレスが変更された場合の WCP サービスの再起動

vSphere IaaS control plane のインストール後に NSX の管理証明書、サムプリント、または IP アドレスが変更された場合は、WCP サービスを再起動する必要があります。

NSX 証明書が変更された場合の vSphere IaaS control plane サービスの再起動

現在、vSphere IaaS control plane では、NSX の証明書かサムプリント、または NSX の IP アドレスが変更された場合、変更を反映するには WCP サービスを再起動する必要があります。どちらかが変更され、サービスを再起動しなかった場合、vSphere IaaS control planeNSX 間の通信が失敗し、NCP が CrashLoopBackoff ステージに切り替わったり、スーパーバイザー リソースがデプロイ不可になったりするなど、特定の症状が発生する可能性があります。

WCP サービスを再起動するには、 vmon-cli を使用します。
  1. vCenter Server に SSH 接続し、root ユーザーとしてログインします。
  2. shell コマンドを実行します。
  3. vmon-cli -h コマンドを実行して、使用する構文とオプションを表示します。
  4. vmon-cli -l コマンドを実行して、wcp プロセスを表示します。

    リストの一番下に wcp サービスが表示されます。

  5. vmon-cli --restart wcp コマンドを実行し、wcp サービスを再起動します。

    Completed Restart service request というメッセージが表示されます。

  6. vmon-cli -s wcp コマンドを実行し、wcp サービスが開始されていることを確認します。
    例:
    root@localhost [ ~ ]# vmon-cli -s wcp
    Name: wcp
    Starttype: AUTOMATIC
    RunState: STARTED
    RunAsUser: root
    CurrentRunStateDuration(ms): 22158
    HealthState: HEALTHY
    FailStop: N/A
    MainProcessId: 34372