データ定義プロセスには、アダプタから提供されるプロパティ、メトリック、ポリシー、データのビューへの追加が含まれます。これらは、vRealize Operations Managerでビューの情報を収集、計算および提供するために使用される項目です。

ビューにデータを追加するには、左側のペインで内容 > ビューを選択します。[ビュー] ツールバーで、プラス記号をクリックしてビューを追加するか、鉛筆をクリックして選択したビューを編集します。ワークスペースの左側で データ をクリックします。新しいビューを作成する場合は、前述の必要な手順を実行してください。

データをビューに追加する方法

複数のサブジェクトを選択している場合は、データを追加するサブジェクトを指定します。左側のパネルのツリーからデータをダブルクリックしてビューに追加します。サブジェクトごとに、追加できるデータが異なる場合があります。

データの変換を構成する方法

データ構成オプションは、ビューおよび選択するデータ タイプによって異なります。ほとんどのオプションがすべてのビューで使用可能です。

表 1. データ構成オプション

構成オプション

説明

メトリック名

デフォルトのメトリック名。

すべてのビューで使用可能。

メトリック ラベル

ビューまたはレポートに表示されるカスタマイズ可能なラベル。

すべてのビューで使用可能。

単位

追加されたメトリックまたはプロパティによって異なる。値を表示する単位を選択できます。例: CPU|デマンド (MHz) の場合、単位 ドロップダウン メニューで値を Hz、KHz、または GHz に変更できます。自動 を選択した場合、スケーリングはわかりやすい単位に設定されます。

すべてのビューで使用可能。

並べ替え順

値を昇順または降順に並べ替えます。

リスト ビューおよび概要ビューで使用可能。

変換

Raw データに適用する計算方法を決定します。変換のタイプを選択できます。

  • 最小値。選択した時間範囲のメトリックの最小値。

  • 最大値。選択した時間範囲のメトリックの最大値。

  • 平均値。選択した時間範囲のすべてのメトリック値の平均。

  • 合計。選択した時間範囲のメトリック値の合計。

  • 最新値。選択した時間範囲内で最も最近に受信したデータ以外のすべてのデータを無視します。

  • 標準偏差。メトリック値の標準偏差。

  • メトリック相関。他のメトリックが最小値または最大値のときに、値を表示します。たとえば、cpu.usage が最大値のときに、memory.usage の値を表示します。

  • 予測。回帰分析を実行し、将来の値を予測します。選択した範囲の最新のメトリック値を表示します。

トレンド以外のすべてのビューで使用可能。

データ系列

トレンド ビューの計算に履歴データ、履歴データのトレンド、および将来の予測を含めるかどうかを選択できます。

トレンド ビューで使用可能。

系列のロール アップ

データがロール アップされる間隔。使用可能なオプションのいずれかを選択します。たとえば、変換として Sumを、ロール アップ間隔として 5 分を選択すると、5 分間隔値が選択されて加算されます。

このオプションは変換構成オプションに適用されます。

すべてのビューで使用可能。

プロジェクト

プロジェクトにはシナリオが含まれています。プロジェクトとは、特定の条件を変更した場合に容量と負荷がどう変化するかを、仮想インフラストラクチャに実際の変更を加えずに行う想定のことです。このプロジェクトを実装する場合、容量要件の内容を事前に確認してください。

すべてのビューで使用可能。選択されたメトリックおよびプロパティによって異なる。

時間設定を構成する方法

時間設定で、データ変換の時間間隔を選択します。これらのオプションは、イメージを除くすべてのビュー タイプで使用可能です。

過去の期間に対する時間範囲を設定したり、あるいは期間の終わりに未来の日付を設定することができます。未来の終了日を選択した際に利用可能なデータが存在しない場合、ビューには予測データが割り当てられます。

表 2. 時間設定のオプション

構成オプション

説明

時間範囲モード

基本モードでは、日付範囲を選択することができます。

詳細モードでは、相対または特定の開始日と終了日をあらゆる組み合わせで選択することができます。

相対的な日付範囲

データ変換の相対日付範囲を選択します。

基本モードで使用可能です。

特定の日付範囲

データ変換の特定日付範囲を選択します。

基本モードで使用可能です。

絶対日付範囲

データ表示の日付または時間の範囲を、各月や各週などの単位で選択します。たとえば、毎月 3 日に前月に関するレポートを実行できます。表示されるのは前月の月初から月末までのデータで、前月 3 日から今月 3 日までのデータではありません。

使用可能な期間の単位は 時間 です。

期間の単位の開始と終了はシステムのロケール設定で決まります。たとえば、欧州諸国の大半で週は月曜始まりなのに対し、米国では日曜始まりです。

基本モードで使用可能です。

相対的な開始日

データ変換の相対開始日を選択します。

詳細モードで使用可能です。

相対的な終了日

データ変換の相対終了日を選択します。

詳細モードで使用可能です。

特定の開始日

データ変換の特定開始日を選択します。

詳細モードで使用可能です。

特定の終了日

データ変換の特定終了日を選択します。

詳細モードで使用可能です。

現在選択されている日付範囲

選択されている日付と時刻の範囲が表示されます。たとえば、2016/5/01 から 2016/5/18 までの日付範囲を選択した場合は、May 1, 2016 12:00:00 AM to May 18, 2016 11:55:00 PMと表示されます。

データを類別する方法

リスト ビューで 次でグループ分け タブから間隔またはインスタンスの内訳列を追加して、データを類別することができます。

表 3. 次でグループ分けオプション

オプション

説明

間隔内訳列の追加(列の設定については、データを参照)

時間間隔で類別されたリソースを選択してデータを確認するには、このオプションを選択します。

データ タブで 間隔内訳 を選択し、列を構成します。時間範囲のラベルを入力し、間隔内訳を選択することができます。

インスタンス内訳列の追加(列の設定については、データを参照)

選択したリソースの全インスタンスのデータを確認するには、このオプションを選択します。

データ タブで インスタンス名 を選択し、列を構成します。ラベルを入力してメトリック グループを選択すると、グループの全インスタンスを類別することができます。非インスタンス集計メトリックの表示 の選択を解除すると、個別のインスタンスのみを表示することができます。インスタンス名のみの表示 の選択を解除すると、メトリック グループ名とインスタンスの内訳列のインスタンス名を表示することができます。

たとえば、メトリック CPU:0|使用量 を選択して、CPU 使用量を表示するビューを作成することができます。インスタンスの内訳列を追加すると、[CPU:0|使用量] 列に別の列の CPU インスタンスの使用量がすべて表示されます(0、1 など)。曖昧さを回避するために、CPU:0|使用量 のメトリック レベルを 使用量 に変更することができます。

フィルタを追加する方法

フィルタ オプションを使用すると、ビューに表示される情報が多すぎるときに基準をさらに追加できます。たとえば、リスト ビューには仮想マシンの健全性に関する情報が表示されます。フィルタ タブで、50% より低いリスク メトリックを追加します。この操作の後、ビューには リスクが 50% より低いすべての仮想マシンの健全性が表示されます。

ビューにフィルタを追加するには、左側のペインで内容 > ビューを選択します。[ビュー] ツールバーで、プラス記号をクリックしてビューを追加するか、鉛筆をクリックして選択したビューを編集します。ワークスペースの左側で データ をクリックし、メイン パネルで フィルタ タブをクリックします。新しいビューを作成する場合は、前述の必要な手順を実行してください。

各サブジェクトには、別個のフィルタ ボックスがあります。アラート ロールアップ、アラート、症状サブジェクトの場合、すべての適用可能なメトリックがフィルタリング用にサポートされているわけではありません。

表 4. フィルタの追加オプション

オプション

説明

追加

基準セットに別の基準を追加します。フィルタによって、指定した条件のすべてを満たす結果が返されます。

別の基準の追加

別の基準セットを追加します。フィルタによって、何らかの基準セットを満たす結果が返されます。

概要行または概要列をビューに追加する方法

概要オプションは、リスト ビューおよび概要ビューでのみ使用可能です。概要ビューでは必須項目となります。複数の概要行または概要列を追加して、異なる集約が表示されるようにそれぞれを構成できます。概要構成パネルで、集約方法、計算に含めるデータまたは除外するデータを選択します。

ビューに概要行または概要列を追加するには、左側のペインで内容 > ビューを選択します。[ビュー] ツールバーで、プラス記号をクリックしてビューを追加するか、鉛筆をクリックして選択したビューを編集します。ワークスペースの左側で データ をクリックし、メイン パネルで 概要 タブをクリックします。新しいビューを作成する場合は、前述の必要な手順を実行してください。

リスト ビューの場合、概要行には指定したサブジェクトによって集約された情報が表示されます。

概要ビューの場合、概要列には データ タブの項目によって集約された情報が表示されます。