vSphere Replication の仮想アプライアンス管理インターフェイス (VAMI) で [保存して再起動] をクリックすると、HMS サービスを起動できず、レプリケーションを管理することができなくなります。

問題

仮想アプライアンス管理インターフェイス (VAMI) を使用して新しい SSL 証明書のインストール、VRM ホストの IP アドレスの変更、または VR タブでの別の設定の適用を行い、 [保存して再起動] をクリックすると、以下のエラー メッセージが表示されます。
 コマンドライン引数がありません。

原因

vSphere Replication アプライアンスの OVF 環境がない、または破損している場合があります。

解決方法

  1. vSphere Replication アプライアンスへの SSH 接続を確立し、/opt/vmware/etc/vami/ に移動します。
  2. ovfEnv.xml を開きます。
    1. ovfEnv.xml ファイルが空でない場合、vServiceEnvironmentSection 要素を検索します。vServiceEnvironmentSection 要素がない場合、vCenter Server マシン上の vCenter Management Web Services プロセスに問題がある場合があります。vCenter Management Web Services が vCenter Server マシン上で実行しており、vSphere Replication アプライアンスをパワーオフおよびパワーオンにしようすることを確認します。アプライアンスをパワーオフ、パワーオンにするには、vSphere Web ClientESXi ホストに直接接続しているときではなく、vCenter Server 接続時に使用します。
    2. ovfEnv.xml ファイルが空の場合、vSphere Web ClientESXi ホストに直接接続しているときではなく、vCenter Server 接続時に使用して、vSphere Replication アプライアンスをパワーオフおよびオンします。
  3. vSphere Replication アプライアンスのパワーオフとオンによって問題が解決されない場合、アプライアンスは必ず一時的に削除され、vCenter Server に再度追加されています。その場合、OVF 環境をリストアするための解決策はありません。空のデータベースを使用して vSphere Replication アプライアンスを再デプロイし、最初からすべてのレプリケーションを構成する必要があります。