대규모 Site Recovery Manager 환경에서 공유 복구 사이트의 가상 시스템의 전원을 켤 때 시간 초과 오류가 발생할 수 있습니다.

문제점

공유 복구 사이트에서 가상 시스템의 전원을 켤 때 오류:작업 시간(900초)이 초과되었습니다.라는 오류 메시지가 표시됩니다.

원인

이 문제는 단일 vCenter Server 인스턴스가 공유 복구 사이트에서 1000개 이상의 많은 가상 시스템을 관리하는 경우 발생할 수 있습니다.

해결 방법

  1. 복구 사이트의 Site Recovery Manager ServerremoteManager.defaultTimeout 시간 제한 값을 늘립니다.

    예를 들어 기본값인 300초에서 1200초로 시간 제한을 늘립니다. remoteManager.defaultTimeout 설정을 늘리는 방법에 대한 자세한 내용은 Site Recovery Manager 관리 원격 관리자 설정 변경을 참조하십시오.

  2. 복구 사이트에서 Site Recovery Manager Server 호스트 시스템의 C:\Program Files\VMware\VMware vCenter Site Recovery Manager\config로 이동합니다.
  3. 텍스트 편집기에서 vmware-dr.xml을 엽니다.
  4. vSphere Web Client에서 읽을 때의 시간 초과를 설정합니다.

    <vmacore><http> 요소에 라인을 추가하여 시간 초과를 900초(15분)로 설정합니다.

    <vmacore>
      <http>
        <defaultClientReadTimeoutSeconds>900</defaultClientReadTimeoutSeconds>
      </http>
    </vmacore>
  5. Site Recovery Manager Server 서비스를 다시 시작합니다.

다음에 수행할 작업

RemoteManager 시간 초과 값을 늘린 후에도 여전히 시간 초과 문제가 발생하는 경우 계속해서 더 긴 시간 초과 설정으로 실험합니다. 시간 초과 기간을 지나치게 늘리지 마십시오. 시간 초과 값을 비현실적으로 긴 기간으로 설정하면 Site Recovery Manager ServervCenter Server 간의 통신이나 Site Recovery Manager가 필요로 하는 다른 서비스와 관련한 문제와 같은 다른 문제를 숨길 수 있습니다.