Site Recovery Manager를 실행하려면 다른 서비스가 필요합니다. 이러한 서비스 중 하나가 실행 중이지 않으면 Site Recovery Manager Server가 시작되지 않습니다.
문제
Site Recovery Manager 설치 관리자를 실행하여
Site Recovery Manager를 설치, 복구 또는 수정한 후에 또는
Site Recovery Manager Server를 재부팅한 후에
Site Recovery Manager Server가 시작되지 않거나 시작된 다음 중지됩니다.
원인
Platform Services Controller 또는 vCenter Server가 실행 중이 아니거나, Site Recovery Manager 데이터베이스에 연결할 수 없거나, Site Recovery Manager에 필요한 다른 서비스가 실행 중이 아닐 경우 Site Recovery Manager Server를 시작하지 못할 수 있습니다.
해결책
- 최신 Site Recovery Manager Server 로그 파일과 Windows 이벤트 뷰어에서 오류를 확인합니다.
대부분의 오류는
Site Recovery Manager Server 로그 파일에 표시됩니다. "
Site Recovery Manager 관리" 가이드에서 "
Site Recovery Manager 로그 파일 수집" 을 참조하십시오. 기타 오류는 Windows 이벤트 뷰어에 표시될 수 있습니다. 예를 들어
Site Recovery Manager 데이터베이스는
Site Recovery Manager 로깅 서비스가 시작되기 전에 초기화됩니다. 데이터베이스 초기화 중에 오류가 발생하면 해당 오류가 Windows 이벤트 뷰어에 표시됩니다. Windows 이벤트 뷰어에는 인증서 유효성과 관련된 오류도 표시됩니다.
- Site Recovery Manager가 확장하는 Platform Services Controller 및 vCenter Server 인스턴스가 실행 중인지 확인합니다.
Platform Services Controller 또는
vCenter Server 서비스가
Site Recovery Manager Server와 다른 호스트에서 실행 중이고
vCenter Server 서비스가 중지되는 경우
Site Recovery Manager Server가 성공적으로 시작되었다가 잠시 후 바로 중지됩니다.
- Site Recovery Manager 데이터베이스 서비스가 실행 중인지 확인합니다.
- 내장형 데이터베이스를 사용하는 경우에는 Site Recovery Manager 호스트에서 Windows Server Manager 유틸리티를 열고 를 선택하여 VMware vCenter Site Recovery Manager 내장형 데이터베이스 서비스가 실행 중인지 확인합니다.
- 외부 데이터베이스를 사용하는 경우 데이터베이스 호스트에서 적절한 SQL Server 또는 Oracle Server 서비스가 실행 중인지 확인합니다.
- Site Recovery Manager Server를 설치한 시스템에 로그인합니다.
- Site Recovery Manager 설치 관리자를 수정 모드로 실행하여 설치가 올바르게 구성되었는지 확인합니다.
인프라 내의 IP 주소 변경을 용이하게 하기 위해 가능하면 항상 IP 주소 대신 FQDN(정규화된 도메인 이름)을 제공합니다.
- Platform Services Controller의 주소가 올바른지 확인합니다.
- Site Recovery Manager 설치 이후 vCenter Single Sign-On 암호가 변경된 경우 새 암호를 입력합니다.
- vCenter Server 주소가 올바른지 확인합니다. vCenter Server 시스템이 정적 주소 대신 DHCP를 사용하는 경우와 같이 Site Recovery Manager 설치 이후 Site Recovery Manager 주소가 변경되었다면 Site Recovery Manager를 제거하고 다시 설치한 다음 재구성하십시오.
- Site Recovery Manager Server에 대한 로컬 호스트 주소가 올바른지 확인합니다.
- Site Recovery Manager 데이터베이스에 대한 자격 증명이 올바른지 확인합니다.
- Site Recovery Manager 데이터베이스가 충분한 연결 수를 허용하는지 확인합니다. Site Recovery Manager 로그에 GetConnection: 사용 가능한 연결을 기다리는 중 메시지가 포함된 경우 최대 데이터베이스 연결 수를 늘립니다. 이러한 설정을 변경하기 전에 데이터베이스 관리자에게 문의하십시오.
- Site Recovery Manager 서비스에 대한 사용자 계정이 올바른지 확인합니다. 로컬 시스템 계정 외의 다른 계정을 사용할 경우 사용자 이름 및 암호가 올바른지 확인합니다.
- Windows ODBC 데이터 소스 관리자 유틸리티를 실행하여 Site Recovery Manager가 Site Recovery Manager 데이터베이스에 연결할 수 있는지 확인합니다.
- C:\Windows\System32\Odbcad32.exe를 엽니다.
- Site Recovery Manager에 대한 시스템 DSN을 선택하고 구성을 클릭합니다.
- 데이터베이스 설정을 확인합니다.
- Site Recovery Manager가 올바른 데이터베이스 서버로 연결을 시도하는지 확인합니다.
- Site Recovery Manager 데이터베이스에 대한 로그인 자격 증명이 올바른지 확인합니다.
- 인증 방법이 올바른지 확인합니다.
- 데이터 원본 테스트를 클릭합니다.
연결이 올바르게 구성된 경우
ODBC 데이터 원본 테스트 창에 긍정적 결과가 표시됩니다.
- 연결 테스트에 실패하면 데이터베이스 공급자에서 제공한 관리 소프트웨어를 사용하여 Site Recovery Manager 데이터베이스를 재구성합니다.
- Windows Server Manager 유틸리티를 열고 를 선택합니다.
- Site Recovery Manager에 필요한 서비스가 실행 중인지 확인합니다.
- Windows Server
- Windows 워크스테이션
- 보호된 스토리지
- Windows Server Manager 유틸리티에서 VMware vCenter Site Recovery Manager Server 서비스를 선택하고 시작 또는 다시 시작을 클릭합니다.