VMware Aria Automation 클라우드 계정으로 사용하기 위해 기존 클라우드 프록시를 업그레이드하려고 시도하면 매니페스트 액세스 오류로 인해 실패합니다.

문제

기존 또는 새 VMware Aria Automation 클라우드 계정에 대해 새 클라우드 프록시를 생성하고 구성하는 대신 기존에 구성된 클라우드 프록시를 업그레이드할 수 있습니다. 하지만 다음 오류 또는 유사한 오류 메시지가 표시되고 업그레이드가 실패할 수 있습니다.
Details
Checking for available updates, this process can take a few minutes ...
Failure: Error downloading manifest. Please contact your vendor.  
The requested URL returned error: 404 Not Found URL: <https:// ...>

원인

클라우드 프록시를 구성할 때 사용된 /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml 매니페스트 파일에 업그레이드 프로세스에 필요한 일부 정보가 누락되었을 수 있습니다.
참고: 이 매니페스트 파일 문제는 최신 버전의 VMware Aria Automation에서 해결되었습니다. 하지만 이전 버전의 클라우드 프록시를 사용 중이고 언급된 오류 메시지가 표시되는 경우에는 이 해결 방법을 사용하여 클라우드 프록시 provider-runtime.xml 매니페스트 파일을 업그레이드하십시오.

해결책

  1. 클라우드 프록시 매니페스트 파일을 찾아서 검토합니다. /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml 예제가 아래에 나와 있습니다.
    <service>
      <properties>
         <property name="jobId" value="1" />_
         <property name="jobList" value='{ "Check":{ "JobStatus": "Failed", "JobState": 8, "TimeOfLastStateChange": "20210120101111.982008+000", "ErrorCode": 20, "ErrorDescription": "Error downloading manifest. Please contact your vendor. The requested URL returned error: 404 Not Found URL: https:\/\/vapp-updates.vmware.com\/vai-catalog\/valm\/vmw\/a1ba78af-ec67-4333-8e25-a4be022f97c7\/7.2.0.33184.latest\/manifest\/manifest-latest.xml", "TimeBeforeRemoval": "00000000000500.000000:000", "TimeSubmitted": "20210120101031.385064+000", "InstanceID": "VMware-VAMI:Job_1" }}' />_
      </properties>
    </service>
  2. 파일에 위와 유사한 컨텐츠가 포함된 경우 다음 컨텐츠로 파일을 수동으로 업데이트합니다.
    <service>
        <properties>
            <property name="localRepositoryAddress" value="https://ci-data-collector-sandbox.s3.amazonaws.com/upgrade" />
            <property name="localRepositoryPasswordFormat" value="base64" />
        </properties>
    </service>
  3. vCenter에서 클라우드 프록시를 다시 시작합니다.
  4. 이전에 실행했고 위에 언급된 오류가 발생한 동일한 클라우드 프록시 업그레이드 프로세스를 실행합니다.
  5. 오류가 지속되면 VMware 지원에 문의하십시오.