vCloud Director Object Storage Extension을 배포하기 전에 환경을 준비해야 합니다. vCloud Director Object Storage Extension은 특정 외부 구성 요소를 필요로 하며, 외부 구성 요소의 특정 버전을 지원합니다.

다음 표에는 배포 및 구성해야 하는 소프트웨어 구성 요소와 지원되는 구성 요소 버전이 나와 있습니다.
필수 구성 요소 지원되는 버전
vCloud Director
  • 10
  • 9.7
  • 9.5
  • 9.1
참고: vCloud Director Object Storage Extension에서 작업하려면 사용하는 vCloud Director 인스턴스가 vCloud Director Service Provider Admin PortalvCloud Director Tenant Portal을 지원해야 합니다.
Cloudian HyperStore 3개 이상의 Cloudian HyperStore 노드로 이루어진 클러스터가 필요합니다.
  • vCloud Director Object Storage Extension 1.0.1의 경우 Cloudian HyperStore 7.1.6을 설치하고 구성합니다.
  • vCloud Director Object Storage Extension 1.0의 경우 Cloudian HyperStore 7.1.4를 설치하고 구성합니다.
Cloudian HyperStore 관련 요구 사항에 대한 자세한 내용은 Cloudian 요구 사항 항목을 참조하십시오.
데이터베이스
  • PostgreSQL 10
  • PostgreSQL 9

vCloud Director Object Storage Extension에는 테이블을 생성하고 데이터베이스 스키마를 변경할 수 있는 충분한 권한이 있는 데이터베이스 사용자와 전용 데이터베이스 인스턴스가 필요합니다.

vCloud Director Object Storage Extension에는 vCloud Director와의 통신을 위한 RabbitMQ 메시지 버스가 필요하지 않습니다.