VMware Cloud Director 장치를 최신 버전으로 업그레이드하거나 외부 PostgreSQL 데이터베이스가 있는 이전 버전의 기존 VMware Cloud DirectorVMware Cloud Director 장치로 마이그레이션할 수 있습니다.

VMware Cloud Director 장치에는 고가용성 기능이 있는 내장형 PostgreSQL 데이터베이스가 포함되어 있습니다. VMware Cloud Director 장치를 이후 버전으로 업그레이드할 수 있습니다. 외부 PostgreSQL 데이터베이스를 사용하는 이전 버전의 기존 VMware Cloud DirectorVMware Cloud Director 장치 배포 버전 10.2 이상으로 구성된 VMware Cloud Director 환경으로 마이그레이션할 수 있습니다.

VMware Cloud Director 장치 업그레이드

Microsoft SQL Server 데이터베이스는 지원되지 않습니다.

VMware Cloud Director를 업그레이드 하는 경우 새 버전이 기존 설치의 다음 구성 요소와 호환되어야 합니다.
  • VMware Cloud Director 데이터베이스에 현재 사용 중인 데이터베이스 소프트웨어. 자세한 내용은 업그레이드 및 마이그레이션 경로 테이블을 참조하십시오.
  • 현재 사용 중인 VMware vSphere® 릴리스입니다.
  • 현재 사용 중인 VMware NSX® 릴리스입니다.
  • VMware Cloud Director와 직접 상호 작용하는 모든 타사 구성 요소.

VMware Cloud Director와 다른 VMware 제품 및 타사 데이터베이스와의 호환성에 대한 정보는 http://partnerweb.vmware.com/comp_guide/sim/interop_matrix.php에서 "VMware 제품 상호 운용성 매트릭스" 를 참조하십시오. VMware Cloud Director 업그레이드의 일환으로 vSphere 또는 NSX 구성 요소를 업그레이드하려면 VMware Cloud Director를 업그레이드한 후에 업그레이드해야 합니다. VMware Cloud Director 업그레이드 후 작업의 내용을 참조하십시오.

하나 이상의 VMware Cloud Director 서버를 업그레이드한 후에 VMware Cloud Director 데이터베이스를 업그레이드할 수 있습니다. 데이터베이스는 실행 중인 모든 VMware Cloud Director 작업의 상태를 비롯한 서버의 런타임 상태에 대한 정보를 저장합니다. 업그레이드 후 잘못된 작업 정보가 데이터베이스에 남아 있지 않도록 하려면 업그레이드를 시작하기 전에 모든 서버에서 활성 상태의 작업이 없는지를 확인해야 합니다.

또한 업그레이드 시 로컬 및 글로벌 속성 파일이 보존되어 새 설치에 복사되고 VMware Cloud Director 데이터베이스에는 저장되지 않습니다.

이 업그레이드에는 서버 그룹 및 데이터베이스의 모든 서버를 업그레이드하기에 충분한 VMware Cloud Director 다운타임이 필요합니다. 로드 밸런서를 사용하는 경우 메시지(예: 시스템이 업그레이드를 위해 오프라인 상태입니다.)를 반환하도록 로드 밸런서를 구성할 수 있습니다.

서비스 제공자, 하위 제공자 및 테넌트는 VMware Cloud Director API를 사용하여 원격 서버에 대한 연결을 테스트하고, 서버 ID를 SSL 핸드셰이크의 일부로 확인할 수 있습니다. VMware Cloud Director 네트워크 연결을 보호하려면 연결 테스트를 위해 VMware Cloud Director API를 사용하는 테넌트가 연결할 수 없는 내부 호스트의 거부 목록을 구성합니다. VMware Cloud Director 설치 또는 업그레이드 후 그리고 테넌트에 VMware Cloud Director에 대한 액세스 권한을 부여하기 전에 거부 목록을를 구성합니다. 테스트 연결 거부 목록 구성을 참조하십시오.

중요: VMware Cloud Director는 연결된 모든 인프라 끝점에 대한 인증서를 항상 확인합니다. 업그레이드 전에 인증서를 VMware Cloud Director로 가져오지 않으면 SSL 확인 문제로 인해 vCenterNSX 연결에 실패한 연결 오류가 표시될 수 있습니다. 이 경우 업그레이드 후 다음 두 가지 옵션이 제공됩니다.
  1. 셀 관리 도구 trust-infra-certs 명령을 실행하여 모든 인증서를 중앙 집중식 인증서 저장소로 자동으로 가져옵니다. vSphere 리소스에서 끝점 인증서 가져오기를 참조하십시오.
  2. Service Provider Admin Portal UI에서 각 vCenterNSX 인스턴스를 선택하고 인증서를 수락하는 동안 자격 증명을 다시 입력합니다.

VMware Cloud Director 장치 마이그레이션

VMware Cloud Director 환경에서 외부 Oracle 데이터베이스나 외부 Microsoft SQL 데이터베이스를 사용하는 경우에는 VMware Cloud Director 10.6으로 업그레이드하기 전에 PostgreSQL 데이터베이스로 마이그레이션해야 합니다. 업그레이드 경로는 Linux에서 VMware Cloud Director 업그레이드의 내용을 참조하십시오.

업그레이드 및 마이그레이션 경로 및 워크플로

소스 환경 대상 환경
내장형 PostgreSQL 데이터베이스를 사용하는 VMware Cloud Director 장치 10.6
외부 PostgreSQL 데이터베이스를 사용하는 Linux의 VMware Cloud Director 10.3
  1. VMware Cloud Director 장치 10.3으로 마이그레이션합니다. 외부 PostgreSQL 데이터베이스를 사용하는 VMware Cloud Director를 VMware Cloud Director 장치에 마이그레이션을 참조하십시오.
  2. 환경을 VMware Cloud Director 장치 10.6으로 업그레이드합니다. 업데이트 패키지를 사용하여 VMware Cloud Director 장치 업그레이드의 내용을 참조하십시오.
외부 PostgreSQL 데이터베이스를 사용하는 Linux의 VMware Cloud Director 10.4
  1. VMware Cloud Director 장치 10.4로 마이그레이션합니다. 외부 PostgreSQL 데이터베이스를 사용하는 VMware Cloud Director를 VMware Cloud Director 장치에 마이그레이션을 참조하십시오.
  2. 환경을 VMware Cloud Director 장치 10.6으로 업그레이드합니다. 업데이트 패키지를 사용하여 VMware Cloud Director 장치 업그레이드의 내용을 참조하십시오.
외부 PostgreSQL 데이터베이스를 사용하는 Linux의 VMware Cloud Director 10.5
  1. VMware Cloud Director 장치 10.5로 마이그레이션합니다. 외부 PostgreSQL 데이터베이스를 사용하는 VMware Cloud Director를 VMware Cloud Director 장치에 마이그레이션을 참조하십시오.
  2. 환경을 VMware Cloud Director 장치 10.6으로 업그레이드합니다. 업데이트 패키지를 사용하여 VMware Cloud Director 장치 업그레이드의 내용을 참조하십시오.
내장형 PostgreSQL 데이터베이스를 사용하는 VMware Cloud Director 장치 10.2 이상 환경을 VMware Cloud Director 장치 10.6으로 업그레이드합니다. 업데이트 패키지를 사용하여 VMware Cloud Director 장치 업그레이드의 내용을 참조하십시오.