사용자가 스마트 카드 인증서 해지 검사를 구성하지 않은 경우 스마트 카드가 연결된 연결 서버 인스턴스 또는 보안 서버가 서버의 TLS 인증서에 대한 인증서 해지 검사를 수행할 수 없습니다.

문제

조직에서 프록시 서버를 사용해 인터넷에 액세스하거나 연결 서버 인스턴스 또는 보안 서버가 방화벽 또는 기타 컨트롤 때문에 해지 검사를 제공하는 서버에 도달할 수 없는 경우 인증서 해지 검사가 실패할 수 있습니다.

중요: CRL 파일이 최신 버전인지 확인하십시오.

원인

Horizon 7에서는 인증서 해지 목록(CRL) 및 온라인 인증서 상태 프로토콜(OCSP)을 사용하여 인증서 해지 확인을 지원합니다. CRL은 인증서를 발행한 CA(인증 기관)에서 게시한 해지된 인증서 목록입니다. OCSP는 X.509 인증서의 해지 상태를 얻는 데 사용되는 인증서 유효성 검사 프로토콜입니다. CA는 연결 서버 인스턴스 또는 보안 서버 호스트에서 액세스할 수 있어야 합니다. 이 문제는 스마트 카드 인증서의 해지 검사를 구성한 경우에 발생할 수 있습니다. 스마트 카드 인증서 해지 검사 사용의 내용을 참조하십시오.

해결책

  1. Horizon 7 Server에서 경로로 사용할 CA 웹 사이트에서 최신 CRL을 다운로드하는 절차를 직접(수동으로) 생성합니다.
  2. 연결 서버 또는 보안 서버 호스트의 TLS/SSL 게이트웨이 구성 폴더에 locked.properties 파일을 생성 또는 편집합니다.
    예: install_directory\VMware\VMware View\Server\SSLgateway\conf\locked.properties
  3. locked.properties 파일의 enableRevocationCheckingcrlLocation 속성을 CRL이 저장된 로컬 경로에 추가합니다.
  4. 변경 내용을 적용하려면 연결 서버 서비스 또는 보안 서버 서비스를 다시 시작합니다.