View는 오류 상태에 있는 연결된 클론 및 전체 클론 시스템을 반복적으로 삭제하고 재생성할 수 있습니다.
문제
연결된 클론 또는 전체 클론 시스템이 오류 상태로 생성되고, 삭제된 후 다시 오류 상태로 재생성됩니다. 이 사이클이 계속해서 반복됩니다.
원인
대형 데스크톱 풀이 프로비저닝되면 하나 이상의 가상 데스크톱이 오류 상태로 종료될 수 있습니다. View 자동 복구 메커니즘이 오류가 발생한 가상 시스템의 전원을 켜려고 시도합니다. 지정한 횟수만큼 시도한 후에도 가상 시스템 전원을 켤 수 없는 경우 View는 해당 가상 시스템을 삭제합니다.
View는 풀 크기 요구 사항에 따라 새 가상 시스템을 생성하며, 이때 종종 원래 시스템과 동일한 시스템 이름으로 가상 시스템을 생성합니다. 새 가상 시스템을 프로비저닝할 때 동일한 오류가 발생하면 가상 시스템이 삭제되고 사이클이 반복됩니다.
연결된 클론 및 전체 클론 시스템에 대해 자동 복구가 수행됩니다.
가상 시스템에 대해 시도한 자동 복구가 실패하면 View는 사용자에게 할당되지 않은 부동 시스템 또는 전용 시스템인 경우에 한해 가상 시스템을 삭제합니다. 또한 풀 프로비저닝을 사용하지 않도록 설정된 경우에는 View에서 가상 시스템을 삭제하지 않습니다.
해결책
상위 가상 시스템 또는 데스크톱 풀을 생성하는 데 사용된 템플릿을 검사하십시오. 가상 시스템 또는 게스트 운영 체제에 가상 시스템 오류를 유발할 수 있는 오류가 있는지 확인하십시오.
연결된 클론의 경우 상위 가상 시스템의 오류를 해결하고 새 스냅샷을 생성하십시오.
- 오류 상태인 시스템이 여러 개인 경우에는 새 스냅샷이나 템플릿을 사용하여 풀을 재생성하십시오.
- 대부분의 시스템이 정상인 경우에는 View Administrator에서 데스크톱 풀을 선택하고 편집을 클릭한 다음 vCenter 설정 탭을 선택하고 새 스냅샷을 기본 이미지로 선택한 후 편집한 내용을 저장하십시오.
새 스냅샷을 사용하여 연결된 클론 시스템이 새로 생성됩니다.
완전 클론의 경우 가상 시스템의 오류를 해결하고, 새 템플릿을 생성하고, 풀을 재생성하십시오.