Horizon 7 이상 구성 요소에서는 TLSv1.0 보안 프로토콜이 기본적으로 사용 안 함으로 설정됩니다. 배포에 TLSv1.0만 지원하는 이전 버전의 vCenter Server가 포함되어 있는 경우에는 View Composer 연결 서버 7.0 이상 릴리스를 설치 또는 업그레이드한 후에 View Composer 연결 서버에 대해 TLSv1.0 연결을 사용하도록 설정해야 할 수도 있습니다.

이 태스크 정보

vCenter Server 5.0, 5.1, 5.5의 일부 초기 유지 보수 릴리스에서는 Horizon 7 이상 릴리스에서 더 이상 기본적으로 사용하도록 설정되지 않는 TLSv1.0만 지원합니다. vCenter Server를 TLSv1.1 또는 TLSv1.2를 지원하는 버전으로 업그레이드할 수 없는 경우에는 View Composer 연결에 대해 TLSv1.0을 사용하도록 설정할 수 있습니다.

ESXi 호스트가 ESXi 6.0 U1b 이상을 실행하지 않고 업그레이드도 할 수 없는 경우에는 View Composer에서 ESXi 호스트로의 TLSv1.0 연결도 사용하도록 설정해야 할 수 있습니다.

필수 조건

  • View Composer 7.0 이상 릴리스가 설치되어 있는지 확인합니다.

  • View Composer 시스템에 관리자로 로그인하여 Windows 레지스트리 편집기를 사용할 수 있는지 확인합니다.

프로시저

  1. View Composer를 호스팅하는 시스템에서 Windows 레지스트리 편집기(regedit.exe)를 엽니다.
  2. HKLM\System\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client로 이동합니다.

    이 키가 아직 없는 경우에는 이 키를 만듭니다.

  3. Enabled 값이 있으면 삭제합니다.
  4. DWORDDisabledByDefault를 만들거나 편집하여 0으로 설정합니다.
  5. VMware Horizon View Composer 서비스가 다시 시작됩니다.

    View Composer에서 vCenter로의 TLSv1.0 연결이 이제 사용되도록 설정됩니다.

  6. View Composer 시스템의 Windows 레지스트리에서 HKLM\SOFTWARE\VMware, Inc.\VMware View Composer로 이동합니다.
  7. 문자열 값 EnableTLS1.0을 만들거나 편집하여 1로 설정합니다.
  8. View Composer 호스트가 64비트 시스템인 경우에는 HKLM\SOFTWARE\WOW6432Node\VMware, Inc\VMware View Composer로 이동합니다.
  9. 문자열 값 EnableTLS1.0을 만들거나 편집하여 1로 설정합니다.
  10. VMware Horizon View Composer 서비스가 다시 시작됩니다.

    View Composer에서 ESXi 호스트로의 TLSv1.0 연결이 이제 사용하도록 설정됩니다.