View Composer 업그레이드 프로세스에는 특정 요구 사항과 제약 사항이 있습니다.

View Composer 설치 관리자를 실행하려면 시스템에서 관리자 권한을 가진 도메인 사용자여야 합니다.

보안 관련 요구 사항

  • View Composer에는 CA(인증 기관)에서 서명한 SSL 인증서가 필요합니다. View Composer를 설치한 후 기존 인증서 또는 기본 자체 서명 인증서를 새 인증서와 교체하려는 경우, 새 인증서를 가져온 다음 SviConfig ReplaceCertificate 유틸리티를 실행하여 새 인증서를 View Composer에서 사용하는 포트에 바인딩해야 합니다.

    동일한 Windows Server 컴퓨터에 vCenter Server 및 View Composer를 설치하는 경우, 동일한 SSL 인증서를 사용할 수 있지만 각 구성 요소의 인증서를 별도로 구성해야 합니다.

    보안 인증서 요구 사항에 대한 자세한 정보는 View 설치 문서의 "View Server를 위한 SSL 인증서 구성"을 참조하십시오.

  • vCenter Server, View Composer 및 View 서버의 인증서는 CRL(인증서 해지 목록)을 포함해야 합니다. 자세한 내용은 View 설치 가이드의 "서버 인증서에 대한 인증서 해지 확인 구성"을 참조하십시오.

  • View Composer 컴퓨터에서 실행되는 애플리케이션이 Microsoft Secure Channel(Schannel) 보안 패키지를 통해 제공된 SSLv2가 필요한 Windows SSL 라이브러리를 사용하지 않는지 확인하십시오. View Composer 설치 관리자는 Microsoft Schannel에서 SSLv2를 사용하지 않습니다. Java SSL을 사용하는 Tomcat 또는 OpenSSL을 사용하는 Apache와 같은 애플리케이션은 이 제약 조건의 영향을 받지 않습니다. SSLv3, TLSv1.0 및 RC4도 기본적으로 사용하지 않도록 설정됩니다. 자세한 내용은 View 보안 문서의 "이전 프로토콜 및 암호가 View에서 사용되지 않도록 설정됨"을 참조하십시오.

  • View Composer의 보안을 향상하려면 View Composer 서비스가 설치되는 Windows Server 컴퓨터에서 취약 암호화 암호 제품군을 사용하지 마십시오. View 설치 문서의 "View Composer Server에서 취약한 암호화 암호 제품군 사용 안 함"을 참조하십시오.

  • vSphere의 호환성을 계속 유지하려면 보안 프로토콜 구성을 변경해야 할 수도 있습니다. 가능하면 View Composer를 업그레이드하기 전에 TLSv1.1 및 TLSv1.2를 지원하도록 ESXi 및 vCenter Server에 패치를 적용하십시오. 패치를 적용할 수 없는 경우에는 업그레이드하기 전에 View Composer에서 TLSv1.0을 다시 사용하도록 설정하십시오. 자세한 내용은 View Composer에서 vCenter의 TLSv1.0 및 ESXi 연결 사용의 내용을 참조하십시오.

  • Horizon 7 버전 7.0.3부터 보안 향상을 위해 View Composer에 대해 다이제스트 액세스 인증을 사용하도록 설정할 수 있습니다. 자세한 내용은 View Composer에 다이제스트 액세스 인증 사용의 내용을 참조하십시오.