실시간 오디오-비디오는 표준 웹캠, USB 오디오 및 아날로그 오디오 디바이스와 Skype, WebEx 및 Google Hangout과 같은 표준 회의 애플리케이션에서 작동합니다. 실시간 오디오-비디오를 지원하려면 Horizon 배포가 특정 소프트웨어 및 하드웨어 요구 사항을 충족해야 합니다.

원격 데스크톱

데스크톱에는 View Agent 5.2 이상이나 Horizon Agent 7.0 이상이 설치되어 있어야 합니다. View Agent 5.2 데스크톱의 경우 데스크톱에 해당 Remote Experience Agent도 설치되어 있어야 합니다. 예를 들어 View Agent 5.2가 설치된 경우 View 5.2 기능 팩 2에서 Remote Experience Agent도 설치해야 합니다. View Feature Pack 설치 및 관리 문서를 참조하십시오. View Agent 6.0 이상 또는 Horizon Agent 7.0 이상의 경우 기능 팩은 필요하지 않습니다. 게시된 데스크톱 및 애플리케이션에서 실시간 오디오-비디오를 사용하려면 Horizon Agent 7.0.2 이상을 설치해야 합니다.

Horizon Client 컴퓨터 또는 클라이언트 액세스 디바이스

  • x86 및 x64 디바이스에서는 실시간 오디오-비디오가 지원됩니다. 이 기능은 ARM 프로세서에서 지원되지 않습니다. 클라이언트 시스템은 다음과 같은 최소 하드웨어 요구 사항을 충족해야 합니다.

    해상도

    프레임 속도

    CPU

    필요한 메모리

    320 x 240

    15FPS

    2코어, 1800MHz

    105MB

    640 x 480

    15FPS

    2코어, 2700MHz

    150MB

    1280 x 720

    15FPS

    4코어, 3400MHz

    210MB

  • Horizon Client에는 다음과 같은 라이브러리가 필요합니다.

    • Video4Linux2

    • libv4l

    • Pulse Audio

    플러그인 파일(/usr/lib/pcoip/vchan_plugins/libviewMMDevRedir.so)은 다음과 같은 종속성이 있습니다.

    libuuid.so.1
    libv4l2.so.0
    libspeex.so.1
    libudev0
    libtheoradec.so.1
    libtheoraenc.so.1
    libv4lconvert.so.0
    libjpeg.so.8
    

    이러한 모든 파일이 클라이언트 시스템에 있어야 합니다. 그렇지 않을 경우 실시간 오디오-비디오 기능이 작동하지 않습니다. Horizon Client에 대해 필요한 종속성 이외에 이러한 종속성이 있는지 확인하십시오.

  • 웹캠 및 오디오 디바이스 드라이버가 설치되어 있어야 하며, 클라이언트 컴퓨터에서 웹캠 및 오디오 디바이스를 작동할 수 있어야 합니다. 실시간 오디오-비디오를 지원하기 위해 에이전트가 설치되어 있는 데스크톱 운영 체제에 디바이스 드라이버를 설치할 필요는 없습니다.

디스플레이 프로토콜

  • PCoIP

  • VMware Blast(Horizon Agent 7.0 이상 필요)