문제

View Edge가 연결 보류 중 상태에서 중단됨

원인

vCentre에 Edge 게이트웨이를 배포하는 동안 연결 문자열이 제공되지 않았습니다. 이러한 연결 문자열은 Edge 게이트웨이에 Edge를 다른 상태로 표시하는 데 필요한 모듈이 있는 Kubernetes 네임스페이스를 생성하는 데 필요합니다(경우에 따라 최대 15~20분이 소요될 수 있음). 연결 문자열은 vCentre의 두 번째 화면에서 root 암호 아래에 있습니다.

연결 문자열이 올바르게 제공된 경우 다음과 같은 edge-deployments API 호출을 확인합니다.

admin/v2/edge-deployments/63da2d9216884348cf96a0f5?include_reported_status=true

UI에서 Edge 배포의 세부 정보 페이지가 열릴 때 호출됩니다. view-cs-moduleregisteredModules 아래, reportedStatus > moduleConnectionDetails 내부에 있는지와 view-cs-module이 있고 연결됨 상태인지 확인합니다.

자세한 내용은 https://kb.vmware.com/s/article/92056 항목을 참조하십시오.

해결책

view-cs-moduleregisteredModules 아래, reportedStatus > moduleConnectionDetails 내부에 있는지와 view-cs-module이 있고 연결됨 상태인지 확인합니다.

또한
  1. Edge 게이트웨이가 올바르게 배포되었으며 전원이 켜진 상태인지 확인합니다. 배포에 문제가 있는 경우 네트워킹, 스토리지 등을 확인하십시오.
  2. ccadmin 사용자가 로그인할 수 있도록 공용 키를 지정하려면 2.3.1.0 이상의 Edge 게이트웨이 OVA 버전을 사용합니다. 이전 버전의 OVA는 ccadmin 사용자에 대한 공개 키가 지정된 경우 Kubernetes를 초기화하는 동안 문제가 발생합니다.
  3. 디버그 모드에서 진단 스크립트를 실행합니다. 자세한 내용은 https://kb.vmware.com/s/article/92056을 참조하십시오. ‘Kubernetes 클러스터 섹션’에서 Edge 게이트웨이의 전원을 처음 켤 때 생성된 네임스페이스가 표시됩니다.
    1. 그렇지 않은 경우(예: 이름 공간이 생성되지 않은 경우) 2단계 또는 네트워크가 제대로 구성되지 않았거나 Edge 게이트웨이 OVA를 배포하는 동안 Edge 게이트웨이 생성 중에 연결 문자열이 제공되지 않았기 때문일 수 있습니다.

      Edge 게이트웨이 장치를 배포하는 동안 제공되지 않은 경우 Edge 게이트웨이 장치를 배포한 후 연결 문자열을 구성할 수 있습니다. Horizon Universal Console에서 연결 코드를 복사하고 다음 명령을 실행하여 Edge 게이트웨이 장치를 배포한 후 연결 문자열을 구성합니다.

    2. 네임스페이스가 생성되었으며 Edge에서 연결 보류 중 상태에서 계속 중단된 경우 이는 일부 네트워크 연결 문제, Edge에서 클라우드 URL에 연결할 수 없는 문제(프록시 구성 또는 일부 기타 네트워크 관련 문제 때문일 수 있음) 또는 프록시 구성이 Edge에서 업데이트된 문제 때문일 수 있습니다.
    3. 그런 후 네임스페이스가 성공적으로 생성되면 Edge가 UI에서 구성되지 않음 상태가 되거나 API에서 POST_PROVISIONING_CONFIG_IN_PROGRESS가 표시되는 데 15~20분이 소요될 수 있습니다. 이 경우 이제 연결 서버를 구성할 수 있습니다.

      그래도 발생하지 않은 경우 진단 스크립트를 실행하고 Kubernetes 클러스터 섹션에서 view-cs-module 포드가 실행 중 상태가 될 때까지 기다립니다. 디버그 모드에서 진단 스크립트를 실행합니다. 자세한 내용은 https://kb.vmware.com/s/article/92056을 참조하십시오.

  4. ops 콘솔에서 로그를 다운로드하고 분석하여 명백한 문제를 확인합니다. 또는 버그를 제기하고 해당 위치에서 로그를 첨부합니다. 로그 다운로드 단계:
    1. ops 콘솔에 로그인하고 특정 고객으로 이동한 후 [고객 정보] 탭을 확인합니다.
    2. Edge 배포로 이동하여 edge-deployment의 API 응답에 있는 edgeGatewayLocation 필드에서 deviceId를 가져옵니다.
    3. Edgehub 관리로 이동한 후 deviceId를 사용하여 검색합니다.
    4. 로그 수집을 클릭하고 최신 로그 준비를 클릭하여 최신 로그를 준비합니다.
    5. 로그를 클릭하여 진단 로그를 다운로드합니다.
    6. 파일의 압축을 풀고 log 폴더 내부로 이동하여 관련 모듈 로그를 찾습니다.