플로팅 VDI 데스크톱은 App Volumes Agent가 설치된 다중 포드 이미지를 기준으로 하며, App Volumes 애플리케이션에 대한 사용 권한이 부여된 최종 사용자가 데스크톱에 로그인하면 "가상화가 사용하지 않도록 설정됨" 문장이 포함된 오류 메시지가 표시됩니다.

문제

플로팅 VDI 데스크톱에 로그인하면 "연결 오류. App Volumes Manager에 연결할 수 없습니다. 가상화가 사용하지 않도록 설정되었습니다." 또는 "Manager의 오류(오류 코드: 400) 가상화가 사용하지 않도록 설정되었습니다." 줄을 따라 정보를 전달하는 오류 메시지가 표시됩니다.

참고: Horizon Cloud on Microsoft Azure 배포에 사용되는 App Volumes는 플로팅 VDI 데스크톱에서만 사용할 수 있습니다. 전용 VDI 데스크톱은 현재 이러한 Horizon Cloud 포드에서 App Volumes와 사용할 수 없으므로 이 설명서 페이지에서는 플로팅 VDI 데스크톱 시나리오에 대해 설명합니다.

원인

이 문제는 다음과 같은 시나리오에서 발생합니다.

  • 테넌트의 포드 그룹에 여러 Horizon Cloud on Microsoft Azure 포드가 있습니다.
  • 플로팅 VDI 데스크톱은 콘솔의 인벤토리 > 이미지 - 다중 포드 페이지의 게시 워크플로를 사용하여 다중 포드 이미지로 생성되었습니다.
  • 게시 워크플로에서 Horizon Agent 설치 토글이 해제되었습니다. 즉, 게시 워크플로 중에 이미지 관리 서비스가 에이전트를 설치하도록 하는 옵션이 선택 취소되었습니다.

1세대 Horizon Cloud Service에서는 기본적으로 각 포드에 고유한 App Volumes Manager IP 주소가 있습니다.

다중 포드 이미지의 게시 워크플로에서 복사본이 각 대상 포드에 게시됩니다.

다중 포드 이미지의 각 포드 복사본은 해당 포드에 대한 특정 App Volumes Manager IP를 알고 있어야 합니다.

각 복사본이 연결된 포드의 App Volumes Manager IP를 파악하게 되는 경우는 IMS(이미지 관리 서비스)가 Horizon Agent를 설치할 때입니다.

게시 워크플로에 대해 Horizon Agent 설치 토글이 켜져 있는 경우에만 IMS는 포드의 특정 App Volumes Manager IP를 사용하여 각 복사본을 구성하기 위해 설계된 작업을 수행합니다.

게시 워크플로에서 Horizon Agent 설치 토글이 꺼져 있으면 IMS는 해당 작업을 건너뛰며, 모든 복사본은 해당 포드와 관련된 개별 IP가 아닌 동일한 App Volumes Manager IP로 구성됩니다.

따라서 이 문제가 발생하지 않도록 하려면 IMS가 게시 워크플로의 일부로 에이전트 설치를 수행하도록 합니다. 게시 워크플로에서 Horizon Agent 설치 토글이 켜져 있는지 확인합니다.

참고: 이 문제는 다중 포드 이미지로 이동 작업을 사용하여 게시된 이미지를 생성한 경우에도 발생합니다. 이 경우에는 가져온 이미지를 콘솔의 영향 있는 VM 페이지에서 이미지 - 다중 포드 페이지로 이동한 다음, 첫 번째 이미지 버전을 게시하고 데스크톱 할당에서 해당 이미지를 사용했습니다. 다중 포드 이미지로 이동 작업의 사용 사례에서 콘솔은 가져온 VM 이미지에 에이전트가 이미 설치되어 있기 때문에 Horizon Agent 설치 토글을 사용할 수 있게 설정하지 않습니다. 이 특정 시나리오에서 해결하려면 아래의 첫 번째 솔루션을 사용하십시오.

해결책

기존 데스크톱 및 게시된 다중 포드 이미지에 대해 이 문제를 해결하려면
  1. 콘솔의 [이미지 - 다중 포드] 페이지(인벤토리 > 이미지 - 다중 포드)에서 이미지를 찾습니다.
    녹색 화살표로 클릭할 위치를 가리키는 [다중 포드 이미지] 페이지의 이미지 스크린샷
  2. 이미지의 이름을 클릭하여 [이미지 버전] UI 페이지로 이동합니다.

    이전 스크린샷과 같이 녹색 화살표가 나타내는 이미지의 이름을 클릭합니다.

    그런 다음, 해당 이미지 버전 페이지에서 라디오 버튼을 클릭하여 새 버전 작업을 사용할 수 있도록 합니다.


    녹색 화살표로 선택하기 위한 버튼과 [새 버전] 버튼을 가리키는 이미지 버전 페이지의 스크린샷
  3. 새 버전을 클릭하여 새 버전의 이미지를 생성합니다.

    이 새 이미지 버전에 Horizon Agent를 설치하는 옵션과 함께 이 새 버전을 게시합니다.

    다음 스크린샷은 새 버전을 클릭하고 정보를 채운 이후의 UI를 보여 줍니다.

    중요: 마커를 입력하고 Enter 키를 클릭하여 이 창을 제출하기 전에 마커가 마커 필드에 표시되는지 확인합니다. 버전에 대한 마커가 없으면 이 새 이미지 버전을 사용하도록 플로팅 VDI 데스크톱 할당을 업데이트하는 마지막 단계를 성공적으로 완료할 수 없습니다.

    [새 버전] UI가 채워지고 [제출 준비 완료]가 표시되는 스크린샷

    제출을 클릭하여 이 새 이미지 버전 생성을 완료합니다.

    시스템에서 새 이미지 버전에 대한 기본 VM을 배포하는 중입니다.

  4. [이미지 버전] 페이지에서 UI에 새 이미지 버전이 배포 완료 상태라고 표시되면 해당 이미지 버전을 선택하고 게시를 클릭합니다.
    녹색 화살표로 선택된 새 버전과 [게시] 작업을 둘 다 가리키는 스크린샷
  5. [게시] 워크플로에서 Horizon Agent 설치 옵션이 켜져 있는지 확인합니다.
    주의: 이러한 문제 해결 단계를 완료할 때 "가상화가 사용하지 않도록 설정됨" 문제가 발생하지 않도록 하려면 이 새 이미지 버전에 대해 Horizon Agent 설치 옵션이 켜져 있어야 합니다.
  6. 그런 다음, 새 이미지 버전이 준비되었을 때 해당 버전을 사용하도록 플로팅 VDI 데스크톱 할당을 업데이트합니다.
새 이미지에서 이 문제를 방지하려면
콘솔의 이미지 - 다중 포드 페이지에서 항상 이미지 가져오기 워크플로를 사용하고, Horizon Agent 설치를 켠 상태로 표준 워크플로를 사용하여 이미지를 게시합니다.