VMware NSX Data Center for vSphere 6.4.12 | 2021년 12월 21일 수요일 릴리스 | 빌드 19066632

이 문서의 개정 이력을 참조하십시오.

릴리스 정보에 포함된 내용

릴리스 정보에는 다음과 같은 항목이 포함됩니다.

NSX Data Center for vSphere 6.4.12의 새로운 기능

VMware NSX Data Center for vSphere 6.4.12 패치는 VMSA-2021-0028에 설명된 보안 취약성을 해결하기 위해 NSX for vSphere 6.4.x 버전을 실행하는 모든 배포에 대한 필수 보안 업데이트입니다. Log4j의 버전이 2.16으로 업데이트되었습니다.

현재 알려진 문제는 VMware NSX Data Center for vSphere 6.4.11 릴리스 정보를 참조하십시오.

버전, 시스템 요구 사항 및 설치

참고:

  • 다음 표에서는 권장 VMware 소프트웨어 버전을 나열합니다. 이러한 권장 릴리스는 일반적인 것이며, 환경별 권장 사항을 대신하거나 재정의하지 않습니다. 이 정보는 이 문서 발행 당시를 기준으로 최신 정보입니다.

  • NSX 및 기타 VMware 제품의 최소 지원 버전에 대해서는 VMware 제품 상호 운용성 매트릭스를 참조하십시오. VMware는 내부 테스트를 기준으로 최소 지원 버전을 선언합니다.

제품 또는 구성 요소 버전
NSX Data Center for vSphere

새로 배포할 경우 최신 NSX 릴리스를 사용하는 것이 좋습니다.

기존 배포를 업그레이드할 경우 업그레이드를 계획하기 전에 특정 문제에 관한 자세한 내용은 NSX Data Center for vSphere 릴리스 정보를 검토하거나 VMware 기술 지원 담당자에게 문의하십시오.

vSphere

vSphere 6.5:
권장: 6.5 업데이트 3
참고: vSphere 6.5 Update 1은 메모리 부족으로 인한 EAM 실패 문제를 해결합니다. 자세한 내용은 VMware 기술 자료 문서 2135378을 참조하십시오.
중요:

  • vSphere 6.5에서 멀티캐스트 라우팅을 사용하는 경우 vSphere 6.5 Update 2 이상이 권장됩니다.
  • vSphere 6.5에서 NSX Guest Introspection을 사용하는 경우 vSphere 6.5 P03 이상이 권장됩니다.

vSphere 6.7:
권장: 6.7 업데이트 2
중요: 

  • NSX Guest Introspection vSphere 6.7을 사용하는 경우 NSX 6.4.6을 설치하기 전에 기술 자료 문서 57248을 참조하고 VMware 고객 지원 서비스에 자세한 내용을 문의하십시오.

참고: vSphere 5.5는 NSX 6.4에서 지원되지 않습니다.

참고: vSphere 6.0은 일반 지원 종료에 도달했으며 NSX 6.4.7부터 지원되지 않습니다.

Windows용 Guest Introspection

NSX for vSphere를 업그레이드하기 전에 VMware Tools를 10.3.10으로 업그레이드하는 것이 좋습니다.

Linux용 Guest Introspection

게스트 가상 시스템에 지원되는 Linux 버전이 설치되어 있는지 확인하십시오. 지원되는 최신 Linux 버전 목록은 VMware NSX 관리 가이드를 참조하십시오.

시스템 요구 사항 및 설치

NSX 설치 사전 요구 사항의 전체 목록을 보려면 "NSX 설치 가이드"에서 NSX 시스템 요구 사항 섹션을 참조하십시오.

설치 지침을 보려면 NSX 설치 가이드 또는 크로스 vCenter NSX 설치 가이드 참조하십시오.

제거 및 지원 중단된 기능

수명 종료 또는 지원 종료 경고

곧 업그레이드해야 하는 NSX 및 기타 VMware 제품에 대한 자세한 내용은 VMware 수명 주기 제품 매트릭스를 참조하십시오.

  • NSX for vSphere 6.1.x는 2017년 1월 15일에 EOA(End of Availability) 및 EOGS(End of General Support)에 도달했습니다. (VMware 기술 자료 문서 2144769도 참조하십시오.)

  • vCNS Edge가 더 이상 지원되지 않음. NSX 6.3 이상으로 업그레이드하기 전에 먼저 NSX Edge로 업그레이드해야 합니다.

  • NSX for vSphere 6.2.x는 2018년 8월 20일 기준으로 EOGS(일반 지원 종료)에 도달했습니다.

  • 보안 권장 사항에 따라 NSX Edge IPsec VPN 서비스에서는 더 이상 3DES를 암호화 알고리즘으로 지원하지 않습니다.
    IPsec 서비스에서 사용할 수 있는 보안 암호 중 하나로 전환하는 것이 좋습니다. 암호화 알고리즘과 관련된 이러한 변경 사항은 IPsec 사이트의 IPsec SA(2단계) 협상뿐 아니라 IKE SA(1단계)에도 적용됩니다.
     
    3DES 암호화 알고리즘의 지원이 제거된 릴리스로 업그레이드한 다음 NSX Edge IPsec 서비스에서 이 알고리즘을 사용하는 경우 권장되는 다른 암호 방식으로 대체됩니다. 따라서 원격 피어의 구성이 NSX Edge에서 사용되는 암호화 알고리즘과 일치하도록 수정되지 않는 한, 3DES를 사용하는 IPsec 사이트는 나타나지 않을 것입니다.
     
    3DES 암호화를 사용하는 경우 3DES를 지원되는 AES 변형(AES / AES256 / AES-GCM) 중 하나로 교체하도록 IPsec 사이트 구성에서 암호화 알고리즘을 수정합니다. 예를 들어, 암호화 알고리즘이 3DES인 각 IPsec 사이트 구성의 경우 이를 AES로 바꿉니다. 그에 따라, 피어 끝점의 IPsec 구성을 업데이트하십시오.

일반적인 동작 변경

둘 이상의 vSphere Distributed Switch가 있고 이러한 스위치 중 하나에 VXLAN이 구성된 경우, 모든 논리적 분산 라우터 인터페이스를 해당 vSphere Distributed Switch의 포트 그룹에 연결해야 합니다. NSX 6.4.1부터 이 구성이 UI 및 API에 적용됩니다. 이전 릴리스에서는 사용자가 잘못된 구성을 생성하는 것을 막을 수 없었습니다.  NSX 6.4.1 이상으로 업그레이드하며 DLR 인터페이스를 잘못 연결한 경우 이 문제를 해결하기 위한 작업을 수행해야 합니다. 자세한 내용은 업그레이드 정보를 참조하십시오.

사용자 인터페이스 제거 및 변경

  • NSX 6.4.1에서 Service Composer 캔버스가 제거되었습니다.
  • NSX 6.4.7에서 다음 기능은 vSphere Client 7.0에서 더 이상 사용되지 않습니다.
    • NSX Edge: SSL VPN-Plus(자세한 내용은 KB 79929 참조)
    • 도구: Endpoint Monitoring(모든 기능)
    • 도구: Flow Monitoring(Flow Monitoring 대시보드, 서비스별 세부 정보 및 구성)
    • 시스템 이벤트: NSX 티켓 로거

설치 동작 변경

버전 6.4.2부터, ixgbe 드라이버를 포함하는 물리적 NIC가 있는 호스트에서 NSX Data Center for vSphere를 설치할 때 ixgbe 드라이버에 대해 RSS(수신 측 크기 조정)가 기본적으로 사용되도록 설정되지 않습니다. NSX Data Center를 설치하기 전에 호스트에서 RSS를 수동으로 사용하도록 설정해야 합니다. ixgbe 드라이버를 포함하는 NIC가 있는 호스트에서만 RSS를 사용하도록 설정해야 합니다. RSS를 사용하도록 설정하는 방법에 대한 자세한 단계는 VMware 기술 자료 문서(https://kb.vmware.com/s/article/2034676)를 참조하십시오. 이 기술 자료 문서에서는 향상된 VXLAN 패킷 처리량에 대해 권장되는 RSS 설정을 설명합니다.

이 새 동작은 ESXi 호스트에 커널 모듈(VIB 파일)을 새로 설치할 때만 적용됩니다. NSX 관리 호스트를 6.4.2로 업그레이드할 때는 변경이 필요하지 않습니다.

API 제거 및 동작 변경

NSX 6.4.2에서 더 이상 사용되지 않는 기능

다음 항목은 더 이상 사용되지 않으며 향후 릴리스에서 제거될 수 있습니다.

  • GET/POST/DELETE /api/2.0/vdn/controller/{controllerId}/syslog. 대신 GET/PUT /api/2.0/vdn/controller/cluster/syslog를 사용합니다.

NSX 6.4.1의 동작 변경

POST /api/2.0/services/ipam/pools/scope/globalroot-0를 사용하여 새 IP 풀을 생성하거나 PUT /api/2.0/services/ipam/pools/를 사용하여 기존 IP 풀을 수정하고, 풀에 여러 IP 범위가 정의되어 있으면 범위가 중복되지 않는지 검증됩니다. 이 검증 작업이 이전에는 수행되지 않았습니다.

NSX 6.4.0에서 더 이상 사용되지 않는 기능
다음 항목은 더 이상 사용되지 않으며 향후 릴리스에서 제거될 수 있습니다.

  • GET /api/4.0/edges/edgeID/statussystemStatus 매개 변수는 더 이상 사용되지 않습니다.
  • GET /api/2.0/services/policy/serviceprovider/firewall/은 더 이상 사용되지 않습니다. 대신 GET /api/2.0/services/policy/serviceprovider/firewall/info를 사용하십시오.
  • 분산 방화벽의 글로벌 구성 섹션에서 tcpStrict를 설정하는 것은 더 이상 사용되지 않습니다. NSX 6.4.0부터 tcpStrict는 섹션 수준에서 정의됩니다. 참고: NSX 6.4.0 이상으로 업그레이드하는 경우 tcpStrict에 대한 글로벌 구성 설정이 각각의 기존 계층 3 섹션에서 tcpStrict를 구성하는 데 사용됩니다. tcpStrict는 계층 2 및 계층 3 리디렉션 섹션에서 false로 설정됩니다. 자세한 내용은 NSX API 가이드의 "분산 방화벽 구성 사용"을 참조하십시오.

NSX 6.4.0의 동작 변경
NSX 6.4.0에서 <name> 매개 변수는 POST /api/2.0/vdn/controller를 사용하여 컨트롤러를 생성할 때 필요합니다.

NSX 6.4.0에서는 오류 처리가 다음과 같이 변경되었습니다.

  • 이전에는 컨트롤러 생성 작업을 나타내기 위해 201 생성됨으로 응답된 POST /api/2.0/vdn/controller가 생성되었습니다. 그러나 컨트롤러 생성이 계속 실패할 수 있습니다. NSX 6.4.0부터 이 응답은 202 수락됨입니다.
  • 이전에 전송 또는 독립형 모드에서 허용되지 않는 API 요청을 전송하는 경우 응답 상태는 400 잘못된 요청이었습니다. 6.4.0부터 응답 상태는 403 사용 권한 없음입니다.

CLI 제거 및 동작 변경

NSX Controller 노드에서 지원되지 않는 명령을 사용하지 않도록 할 것
NSX Controller 노드에서 NTP 및 DNS를 구성하기 위한 문서화되지 않은 명령이 있습니다. 이러한 명령은 지원되지 않으므로 NSX Controller 노드에서 사용하지 않아야 합니다. NSX CLI 가이드에 나오는 명령만 사용해야 합니다.

업그레이드 정보

참고: 설치 및 업그레이드에 영향을 주는 알려진 문제 목록은 설치 및 업그레이드에 대한 알려진 문제를 참조하십시오.

일반 업그레이드 정보

  • vCSA 또는 ESXi 7.0 이상으로 업그레이드한 후 호스트의 VM에서 동/서 및 북/남 연결 문제가 발생합니다. 자세한 내용은 VMware 기술 자료 문서 85070을 참조하십시오.
  • NSX Controller API를 호출할 때 취약한 암호를 사용하는 타사 통합은 NSX Data Center for vSphere 6.4.11로 업그레이드한 후 작동을 중지할 수 있습니다.
  • NSX를 업그레이드하려면 호스트 클러스터 업그레이드(호스트 VIB를 업그레이드)를 포함하여 전체 NSX 업그레이드를 수행해야 합니다. 지침을 보려면 "호스트 클러스터 업그레이드" 섹션을 포함한 "NSX 업그레이드 가이드"를 참조하십시오.

  • VUM을 사용하여 호스트 클러스터에서 NSX VIB를 업그레이드하는 것은 지원되지 않습니다. 업그레이드 코디네이터, 호스트 준비 또는 연결된 REST API를 사용하여 호스트 클러스터에서 NSX VIB를 업그레이드합니다.

  • 시스템 요구 사항: NSX를 설치하고 업그레이드할 때의 시스템 요구 사항에 관해서는 NSX 설명서의 NSX의 시스템 요구 사항 섹션을 참조하십시오.

  • NSX의 업그레이드 경로: VMware 제품 상호 운용성 매트릭스에는 VMware NSX에서의 업그레이드 경로에 대한 자세한 내용이 나와 있습니다.
  • 크로스 vCenter NSX 업그레이드NSX 업그레이드 가이드에서 다룹니다.

  • 다운그레이드는 지원되지 않습니다.
    • 항상 업그레이드를 진행하기 전에 NSX Manager의 백업을 캡처하십시오.

    • NSX가 업그레이드되면 NSX를 다운그레이드할 수 없습니다.

  • NSX 6.4.x로의 업그레이드에 성공했는지 검증하려면 기술 자료 문서 2134525를 참조하십시오.
  • vCloud Networking and Security에서 NSX 6.4.x로의 업그레이드는 지원되지 않습니다. 먼저 지원되는 6.2.x 릴리스로 업그레이드해야 합니다.

  • 상호 운용성: 업그레이드하기 전에 모든 관련 VMware 제품에 대한 VMware 제품 상호 운용성 매트릭스를 확인하십시오.
    • NSX Data Center for vSphere 6.4.7로 업그레이드: 여러 확장 문제로 인해 VIO가 NSX 6.4.7과 호환되지 않습니다.
    • NSX Data Center for vSphere 6.4로 업그레이드: NSX 6.4는 vSphere 5.5와 호환되지 않습니다.
    • NSX Data Center for vSphere 6.4.5로 업그레이드: 버전 5.0으로의 스프링 패키지 업데이트로 인해 6.4.5가 이전 릴리스와 호환되지 않기 때문에 NSX가 VIO(VMware Integrated OpenStack)와 함께 배포된 경우 VIO를 4.1.2.2 또는 5.1.0.1로 업그레이드합니다.
    • vSphere 6.5로 업그레이드: vSphere 6.5a 이상 6.5 버전으로 업그레이드하는 경우 먼저 NSX 6.3.0 이상으로 업그레이드해야 합니다. NSX 6.2.x는 vSphere 6.5와 호환되지 않습니다. "NSX 업그레이드 가이드"의 "NSX 환경에서 vSphere 업그레이드"를 참조하십시오.
    • vSphere 6.7로 업그레이드: vSphere 6.7로 업그레이드하는 경우 먼저 NSX 6.4.1 이상으로 업그레이드해야 합니다. 이전 버전의 NSX는 vSphere 6.7과 호환되지 않습니다. “NSX 업그레이드 가이드"의 "NSX 환경에서 vSphere 업그레이드"를 참조하십시오. 
  • 파트너 서비스 호환성: 사이트에서 Guest Introspection 또는 네트워크 검사에 대해 VMware 파트너 서비스를 사용하는 경우 업그레이드하기 전에 VMware 호환성 가이드를 검토하여 벤더의 서비스가 이 NSX 릴리스와 호환되는지 확인해야 합니다.
  • Networking and Security 플러그인: NSX Manager를 업그레이드한 후에 로그아웃했다가 vSphere Web Client에 다시 로그인해야 합니다. NSX 플러그인이 제대로 표시되지 않으면 브라우저 캐시 및 기록을 지우십시오. Networking and Security 플러그인이 vSphere Web Client에 나타나지 않으면 NSX 업그레이드 가이드에 설명된 대로 vSphere Web Client 서버를 재설정하십시오.
  • 상태 비저장 환경: 상태 비저장 호스트 환경에서 NSX를 업그레이드할 경우, NSX 업그레이드 프로세스 중에 새로운 VIB가 호스트 이미지 프로파일에 미리 추가됩니다. 그 결과 상태 비저장 호스트의 NSX에 대한 업그레이드 프로세스는 다음과 같은 순서로 진행됩니다.

    NSX 6.2.0 전에는 특정 버전의 ESX 호스트에 대한 VIB를 찾을 수 있는 URL이 NSX Manager에 하나밖에 없었습니다. 즉, 관리자는 NSX 버전에 관계없이 하나의 URL만 알고 있으면 되었습니다. NSX 6.2.0 이상에서는 새로운 NSX VIB가 서로 다른 URL을 통해 제공됩니다. 올바른 VIB를 찾으려면 다음과 같은 단계를 수행해야 합니다.

    1. https://<nsxmanager>/bin/vdn/nwfabric.properties에서 새 VIB URL을 찾습니다.
    2. 해당하는 URL에서 필요한 ESX 호스트 버전의 VIB를 가져옵니다.
    3. 그런 다음 VIB를 호스트 이미지 프로파일에 추가합니다.
  • 서비스 정의 기능은 vSphere Client 7.0이 포함된 NSX 6.4.7 UI에서 지원되지 않습니다.
    예를 들어, 이전 Trend Micro 서비스 정의가 vSphere 6.5 또는 6.7에 등록된 경우 다음 두 가지 옵션 중 하나를 수행합니다.
    • 옵션 #1: vSphere 7.0으로 업그레이드하기 전에 vSphere Web Client의 서비스 정의 탭으로 이동하고 서비스 정의를 7.0으로 편집한 다음, vSphere 7.0으로 업그레이드합니다.
    • 옵션 #2: vSphere 7.0으로 업그레이드한 후 다음 NSX API를 실행하여 서비스 정의를 7.0에 추가하거나 편집합니다.

                      POST  https://<nsmanager>/api/2.0/si/service/<service-id>/servicedeploymentspec/versioneddeploymentspec

NSX 구성 요소에 대한 업그레이드 정보

NSX용 VM 하드웨어 버전 11 구성 요소에 대한 지원

  • NSX Data Center for vSphere 6.4.2를 새로 설치하는 경우 NSX 구성 요소(Manager, Controller, Edge, Guest Introspection)는 VM 하드웨어 버전 11이 됩니다.
  • NSX Data Center for vSphere 6.4.2로 업그레이드하는 경우 NSX Edge 및 Guest Introspection 구성 요소는 자동으로 VM 하드웨어 버전 11로 업그레이드됩니다. NSX Manager 및 NSX Controller 구성 요소는 업그레이드 후에도 VM 하드웨어 버전 8 상태를 유지합니다. VM 하드웨어를 버전 11로 업그레이드하는 옵션이 제공됩니다. VM 하드웨어 버전 업그레이드에 대한 지침은 KB(https://kb.vmware.com/s/article/1010675)를 참조하십시오.
  • NSX 6.3.x, 6.4.0, 6.4.1을 새로 설치하는 경우 NSX 구성 요소(Manager, Controller, Edge, Guest Introspection)는 VM 하드웨어 버전 8이 됩니다.

NSX Manager 업그레이드

  • 중요: NSX 6.2.0, 6.2.1 또는 6.2.2를 NSX 6.3.5 이상으로 업그레이드하는 경우 업그레이드를 시작하기 전에 해결 방법을 완료해야 합니다. 자세한 내용은 VMware 기술 자료 문서 000051624를 참조하십시오.

  • NSX 6.3.3에서 NSX 6.3.4 이상으로 업그레이드하는 경우 VMware 기술 자료 문서 2151719 해결 방법 지침을 먼저 수행해야 합니다.

  • NSX 백업을 위해 SFTP를 사용하는 경우 hmac-sha1에 대한 지원이 없으므로 6.3.0 이상으로 업그레이드한 후 hmac-sha2-256으로 변경합니다. 지원되는 보안 알고리즘 목록은 VMware 기술 자료 문서 2149282 참조하십시오.

  • NSX Manager를 NSX 6.4.1로 업그레이드하면 업그레이드 프로세스의 일부로 백업이 자동으로 생성되어 로컬에 저장됩니다. 자세한 내용은 NSX Manager 업그레이드를 참조하십시오.

  • NSX 6.4.0으로 업그레이드하는 경우 TLS 설정이 유지됩니다. TLS 1.0만 사용되도록 설정하면, vSphere Web Client에서 NSX 플러그인을 볼 수 있지만 NSX Manager는 표시되지 않습니다. 데이터 경로에 미치는 영향은 없지만 NSX Manager 구성을 변경할 수 없습니다. https://nsx-mgr-ip/에서 NSX 장치 관리 웹 UI에 로그인하고 TLS 1.1 및 TLS 1.2를 사용하도록 설정합니다. 이렇게 하면 NSX Manager 장치가 재부팅됩니다.

Controller 업그레이드

  • NSX Controller 클러스터에는 세 개의 컨트롤러 노드가 있어야 합니다. 컨트롤러가 3개보다 적으면 업그레이드를 시작하기 전에 컨트롤러를 추가해야 합니다. 자세한 내용은 NSX Controller 클러스터 배포를 참조하십시오.
  • NSX 6.3.3에서는 NSX Controller의 기본 운영 체제가 변경됩니다. 즉, NSX 6.3.2 또는 이전 버전에서 NSX 6.3.3 이상으로 업그레이드할 경우 인플레이스 소프트웨어 업그레이드 대신, 기존 컨트롤러가 한 번에 하나씩 삭제되고 새 Photon OS 기반 컨트롤러가 동일한 IP 주소를 사용해서 배포됩니다.

    컨트롤러가 삭제되면 연결된 모든 DRS 반선호도 규칙도 삭제됩니다. 새 컨트롤러 VM이 동일한 호스트에 상주하지 않도록 하려면 vCenter에서 새로운 반선호도 규칙을 생성해야 합니다.

    컨트롤러 업그레이드에 대한 자세한 내용은 NSX Controller 클러스터 업그레이드를 참조하십시오.

호스트 클러스터 업그레이드

  • NSX 6.3.2 또는 이전 버전에서 NSX 6.3.3 이상으로 업그레이드하는 경우 NSX VIB 이름이 변경됨
    ESXi 6.0 이상에 NSX 6.3.3 이상이 설치된 경우 esx-vxlan 및 esx-vsip VIB가 esx-nsxv로 교체됩니다.

  • 호스트에서 재부팅이 필요 없는 업그레이드 및 제거: vSphere 6.0 이상에서는 NSX 6.2.x에서 NSX 6.3.x 이상으로 업그레이드하고 나면 다음 NSX VIB 변경 시 재부팅이 필요 없습니다. 대신 호스트는 VIB 변경을 완료하도록 유지 보수 모드를 입력해야 합니다. 이러한 상황은 NSX 호스트 클러스터 업그레이드와 ESXi 업그레이드 모두에 영향을 줍니다. 자세한 내용은 NSX 업그레이드 가이드를 참조하십시오.

NSX Edge 업그레이드

  • 잘못된 논리적 분산 라우터 구성을 허용하지 않기 위해 NSX 6.4.1에 유효성 검사가 추가됨: VXLAN이 구성되어 있고 둘 이상의 vSphere Distributed Switch가 있는 환경에서는 논리적 분산 라우터 인터페이스가 VXLAN이 구성된 vSphere Distributed Switch에만 연결되어야 합니다. DLR의 인터페이스가 VXLAN용으로 구성되지 않은 vSphere Distributed Switch에 연결된 환경에서는 DLR을 NSX 6.4.1 이상으로 업그레이드할 수 없습니다. 이 API를 사용하여 잘못 구성된 인터페이스를 VXLAN 구성 vSphere Distributed Switch의 포트 그룹에 연결하십시오. 구성이 올바르지 않으면 업그레이드를 다시 시도하십시오. PUT /api/4.0/edges/{edgeId} 또는 PUT /api/4.0/edges/{edgeId}/interfaces/{index}를 사용하여 인터페이스 구성을 변경할 수 있습니다. 자세한 내용은 NSX API 가이드 참조하십시오.
  • UDLR을 6.2.7에서 6.4.5로 업그레이드하기 전에 보조 NSX Manager와 연결된 vCenter Server에서 UDLR 제어 VM을 삭제합니다.
    다중 vCenter 환경에서 NSX UDLR을 6.2.7에서 6.4.5로 업그레이드하는 경우, UDLR 제어 VM에서 HA를 사용하도록 설정하면 UDLR 제어 VM(UDLR 제어 가상 장치)의 업그레이드가 보조 NSX Manager에서 실패합니다. 업그레이드하는 동안 HA 쌍에 HA 인덱스 #0이 있는 VM이 NSX 데이터베이스에서 제거되지만 이 VM은 vCenter Server에 계속 존재합니다. 따라서 UDLR 제어 VM이 보조 NSX Manager에서 업그레이드될 때 VM의 이름이 vCenter Server의 기존 VM과 충돌하므로 업그레이드가 실패합니다. 이 문제를 해결하려면 보조 NSX Manager의 UDLR과 연결된 vCenter Server의 제어 VM을 삭제한 다음, UDLR을 6.2.7에서 6.4.5로 업그레이드합니다.

  • NSX Edge 장치로 업그레이드하기 전에 NSX에 사용할 수 있게 호스트 클러스터를 준비해야 합니다. VIX 채널을 통한 NSX Manager 및 Edge 간 관리부 통신이 6.3.0부터 더 이상 지원되지 않습니다. 메시지 버스 채널만 지원됩니다. NSX 6.2.x 이하 버전에서 NSX 6.3.0 이상으로 업그레이드할 때는 NSX Edge 장치가 배포된 호스트 클러스터가 NSX에 사용할 수 있게 준비되어 있는지와 메시징 인프라 상태가 녹색인지 확인해야 합니다. 호스트 클러스터가 NSX에 사용할 수 있게 준비되지 않은 경우 NSX Edge 장치 업그레이드가 실패합니다. 자세한 내용은 "NSX 업그레이드 가이드"의 “NSX Edge 업그레이드"를 참조하십시오.

  • ESG(Edge Services Gateway) 업그레이드:
    NSX 6.2.5부터 NSX Edge 업그레이드 시에 리소스 예약이 수행됩니다. 리소스가 부족한 클러스터에서 vSphere HA가 사용되도록 설정되면 vSphere HA 제약 조건 위반으로 인해 업그레이드 작업이 실패할 수 있습니다.

    이러한 업그레이드 실패를 방지하려면 ESG를 업그레이드하기 전에 다음 단계를 수행하십시오.

    설치 또는 업그레이드 시에 값을 명시적으로 설정하지 않은 경우 다음 리소스 예약이 NSX Manager에서 사용됩니다.

    NSX Edge
    폼 팩터
    CPU 예약 메모리 예약
    소형 1000MHz 512MB
    대형 2000MHz 1024MB
    4배 대형 4000MHz 2048MB
    초대형 6000MHz 8192MB
    1. 항상 vSphere HA에 대한 모범 사례에 따라 설치를 수행합니다. 기술 자료 문서 1002080 문서를 참조하십시오.

    2. NSX 튜닝 구성 API를 사용합니다.
      PUT https://<nsxmanager>/api/4.0/edgePublish/tuningConfiguration
      edgeVCpuReservationPercentageedgeMemoryReservationPercentage 값이 폼 팩터에 대해 사용 가능한 리소스 범위 내에 있는지 확인합니다(기본값은 위의 표 참조).

  • vSphere HA가 사용되도록 설정되고 Edge가 배포되는 경우 vSphere의 [가상 시스템 시작] 옵션을 사용하지 않도록 설정합니다. 6.2.4 또는 이전 NSX Edge를 6.2.5 이상으로 업그레이드한 후 vSphere HA가 사용되도록 설정되고 Edge가 배포된 클러스터에서 각 ESX Edge에 대해 vSphere [가상 시스템 시작] 옵션을 해제해야 합니다. 이를 수행하려면 vSphere Web Client를 열고, NSX Edge 가상 시스템이 있는 ESXi 호스트를 찾은 다음 [관리] > [설정]을 클릭하고 가상 시스템 아래에서 [VM 시작/종료]를 선택하고 [편집]을 클릭한 다음 가상 시스템이 수동 모드인지 확인합니다(즉, [자동 시작/종료] 목록에 추가되어 있지 않아야 합니다).

  • NSX 6.2.5 이상으로 업그레이드하기 전에 모든 로드 밸런서 암호 목록이 콜론으로 구분되어야 합니다. 암호 목록이 쉼표 등의 다른 구분 기호를 사용하는 경우 https://nsxmgr_ip/api/4.0/edges/EdgeID/loadbalancer/config/applicationprofiles에 PUT 호출을 수행하고 <clientssl> </clientssl><serverssl> </serverssl>에 있는 각 <ciphers> </ciphers> 목록을 콜론으로 구분된 목록으로 교체합니다. 예를 들어 요청 본문의 관련 세그먼트는 다음과 같이 표시될 수 있습니다. 모든 애플리케이션 프로파일에 대해 다음 절차를 반복하십시오.

    <applicationProfile>
      <name>https-profile</name>
      <insertXForwardedFor>false</insertXForwardedFor>  
      <sslPassthrough>false</sslPassthrough> 
      <template>HTTPS</template>  
      <serverSslEnabled>true</serverSslEnabled>  
      <clientSsl> 
        <ciphers>AES128-SHA:AES256-SHA:ECDHE-ECDSA-AES256-SHA</ciphers>
        <clientAuth>ignore</clientAuth>  
        <serviceCertificate>certificate-4</serviceCertificate> 
      </clientSsl>  
      <serverSsl> 
        <ciphers>AES128-SHA:AES256-SHA:ECDHE-ECDSA-AES256-SHA</ciphers>
        <serviceCertificate>certificate-4</serviceCertificate> 
      </serverSsl>
      ...
    </applicationProfile>
  • 6.2.0 이전의 vROP 버전에서 로드 밸런싱된 클라이언트에 대한 올바른 암호 버전 설정: 6.2.0 이전 vROP 버전의 vROP 풀 멤버는 TLS 버전 1.0을 사용하므로 NSX 로드 밸런서 구성에서 "ssl-version=10"을 설정하여 모니터 확장 값을 명시적으로 설정해야 합니다. 지침에 대해서는 "NSX 관리 가이드”의 "서비스 모니터 생성"을 참조하십시오.
    {
                    "expected" : null,
                    "extension" : “ssl-version=10",
                    "send" : null,
                    "maxRetries" : 2,
                  "name" : "sm_vrops",
                  "url" : "/suite-api/api/deployment/node/status",
                  "timeout" : 5,
                  "type" : "https",
                  "receive" : null,
                  "interval" : 60,
                  "method" : "GET"
               }
  • NSX 6.4.6으로 업그레이드한 후 DLR의 L2 브리지 및 인터페이스는 다른 전송 영역에 속하는 논리적 스위치에 연결할 수 없습니다.  NSX 6.4.5 또는 이전 버전에서는 DLR(논리적 분산 라우터)의 L2 브리지 인스턴스 및 인터페이스가 다른 전송 영역에 속한 논리적 스위치의 사용을 지원했습니다. NSX 6.4.6부터는 이 구성이 지원되지 않습니다. DLR의 L2 브리지 인스턴스 및 인터페이스는 단일 전송 영역에 있는 논리적 스위치에 연결해야 합니다. 여러 전송 영역의 논리적 스위치를 사용하는 경우 NSX를 6.4.6으로 업그레이드할 때 사전 업그레이드 유효성 검사 중 Edge 업그레이드가 차단됩니다. 이 Edge 업그레이드 문제를 해결하려면 DLR의 브리지 인스턴스 및 인터페이스가 단일 전송 영역의 논리적 스위치에 연결되어 있는지 확인합니다.

  • NSX 6.4.7로 업그레이드한 후 DLR의 브리지 및 인터페이스는 다른 VDS에 속하는 dvPortGroups에 연결할 수 없습니다. 이러한 구성이 있는 경우 6.4.7로의 NSX Manager 업그레이드가 사전 업그레이드 유효성 검사에서 차단됩니다. 이 문제를 해결하려면 DLR의 인터페이스 및 L2 브리지가 단일 VDS에 연결되어 있는지 확인하십시오.

  • NSX 6.4.7로 업그레이드한 후 논리적 스위치의 전송 영역이 둘 이상의 VDS에 걸쳐 연결된 경우 DLR을 VLAN 지원 포트 그룹에 연결할 수 없습니다. 따라서 DLR 인스턴스가 여러 호스트에 있는 논리적 스위치 dvPortGroups에 올바르게 맞춰질 수 있습니다. 이러한 구성이 있는 경우 6.4.7로의 NSX Manager 업그레이드가 사전 업그레이드 유효성 검사에서 차단됩니다. 이 문제를 해결하려면 여러 VDS에 걸친 전송 영역에 속하는 논리적 스위치가 있는 논리적 인터페이스가 있는 경우, VLAN 지원 포트 그룹에 연결된 논리적 인터페이스가 없는지 확인하십시오. 

  • NSX 6.4.7로 업그레이드한 후에는 서로 다른 DLR의 인터페이스와 L2 브리지가 동일한 네트워크에 있을 수 없습니다. 이러한 구성이 있는 경우 6.4.7로의 NSX Manager 업그레이드가 사전 업그레이드 유효성 검사에서 차단됩니다. 이 문제를 해결하려면 네트워크가 단일 DLR에서만 사용되는지 확인하십시오.

FIPS에 대한 업그레이드 정보

NSX 6.3.0 이전의 NSX 버전에서 NSX 6.3.0 이상으로 업그레이드하는 경우 업그레이드를 완료하기 전에 FIPS 모드를 사용하도록 설정해서는 안 됩니다. 업그레이드를 완료하기 전에 FIPS 모드를 사용하도록 설정하면 업그레이드된 구성 요소와 업그레이드되지 않은 구성 요소 간 통신이 중단됩니다. 자세한 내용은 "NSX 업그레이드 가이드”의 "FIPS 모드 및 NSX 업그레이드 이해"를 참조하십시오.

  • OS X Yosemite 및 OS X El Capitan에서 지원되는 암호: OS X 10.11(EL Capitan)에서 SSL VPN 클라이언트를 사용 중인 경우 AES128-GCM-SHA256, ECDHE-RSA-AES128-GCM-SHA256, ECDHE-RSA-AES256-GCM-SHA38, AES256-SHAAES128-SHA 암호를 사용하여 연결할 수 있으며 OS X 10.10(Yosemite)을 사용 중인 경우 AES256-SHAAES128-SHA 암호만 사용하여 연결할 수 있습니다.

  • NSX 6.3.x로의 업그레이드가 완료되기 전에는 FIPS를 사용하도록 설정하지 마십시오. 자세한 내용은 "NSX 업그레이드 가이드"의 "FIPS 모드 및 NSX 업그레이드 이해"를 참조하십시오.

  • FIPS를 사용하도록 설정하기 전에 파트너 솔루션이 FIPS 모드 인증을 받았는지 확인하십시오. VMware 호환성 가이드 및 관련 파트너 설명서를 참조하십시오.

FIPS 준수

NSX 6.4는 올바르게 구성될 경우 모든 보안 관련 암호화에 대한 FIPS 140-2 검증 암호화 모듈을 사용합니다.

참고:

  • Controller 및 클러스터링 VPN: NSX Controller는 IPsec VPN을 사용하여 Controller 클러스터를 연결합니다. IPsec VPN은 CMVP 유효성 검사 중인 VMware Linux 커널 암호화 모듈(VMware Photon OS 1.0 환경)을 사용합니다.
  • Edge IPsec VPN: NSX Edge IPsec VPN은 CMVP 유효성 검사 중인 VMware Linux 커널 암호화 모듈(VMware NSX OS 4.4 환경)을 사용합니다.

문서 개정 이력

2021년 12월 21일: 1차 개정판.

해결된 문제

  • 해결된 문제: CVE-2021-44228 및 CVE-2021-45046을 해결하기 위해 Apache Log4j가 2.16 버전으로 업데이트되었습니다.

    VMware NSX for vSphere 6.4.12 패치는 VMSA-2021-0028에 설명된 보안 취약성을 해결하기 위해 NSX for vSphere 6.4.x 버전을 실행하는 모든 배포에 대한 필수 보안 업데이트입니다. Log4j의 버전이 2.16으로 업데이트되었습니다.

  • 해결된 문제 2835975: 기본 경로 구성이 누락되어 NSX for vSphere 6.4.11로 새로 배포되거나 업그레이드된 컨트롤러를 외부에서 ping할 수 없습니다.

    자세한 내용은 VMware KB 문서 86011을 참조하십시오.

check-circle-line exclamation-circle-line close-line
Scroll to top icon