NSX-T Data Center를 구성한 후 Arista CVX(CloudVision eXchange)에 대한 구성 절차를 완료하여 CVX가 NSX-T Data Center와 상호 작용하도록 설정합니다.

사전 요구 사항

NSX-T Data Center에서는 CVX를 적용 지점으로 등록했습니다.

프로시저

  1. NSX Manager에 루트 사용자로 로그인하고 다음 명령을 실행하여 CVX에서 NSX Manager와 통신하는 데 필요한 지문을 생성합니다.
    openssl s_client -connect <IP address of nsx-manager>:443 | openssl x509 -pubkey -noout | openssl rsa -pubin -outform der | openssl dgst -sha256 -binary | openssl base64
    샘플 출력:
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify error:num=18:self signed certificate
    verify return:1
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify return:1
    writing RSA key
    S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
  2. CVX CLI에서 다음 명령을 실행합니다.
    cvx
    no shutdown
    service pcs
    no shutdown
    controller <IP address of nsx-manager>
    username <NSX administrator user name>
    password <NSX administrator password>
    enforcement-point cvx-default-ep
    pinned-public-key <thumbprint for CVX to communicate with NSX
    				  Manager>
    notification-id <notification ID created while registering CVX with NSX>
    end
    
  3. CVX CLI에서 다음 명령을 실행하여 구성을 확인합니다.
    show running-config
    샘플 출력:
    cvx
          no shutdown
       source-interface Management1
       !
       service hsc
          no shutdown
    
       !
       service pcs
          no shutdown
          controller 192.168.2.80
          username admin
          password 7 046D26110E33491F482F2800131909556B
          enforcement-point cvx-default-ep
          pinned-public-key sha256//S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
          notification-id a0286cb6-de4d-41de-99a0-294465345b80
  4. 물리적 서버에 연결하는 물리적 스위치의 이더넷 인터페이스에서 태그를 구성합니다. CVX에서 관리하는 물리적 스위치에서 다음 명령을 실행합니다.
    configure terminal
    interface ethernet 4
    tag phy_app_server
    end
    copy running-config startup-config
    Copy completed successfully.
  5. 다음 명령을 실행하여 스위치에 대한 태그 구성을 확인합니다.
    show running-config section tag
    샘플 출력:
    interface Ethernet4
       description connected-to-7150s-3
       switchport trunk allowed vlan 1-4093
       switchport mode trunk
       tag sx4_app_server
    

    ARP를 사용하여 태그가 지정된 인터페이스에서 확인된 IP 주소는 NSX-T Data Center와 공유됩니다.

  6. NSX Manager에 로그인하여 CVX에서 관리하는 물리적 워크로드의 방화벽 규칙을 생성하고 게시합니다. 규칙 생성에 대한 자세한 내용은 보안 항목을 참조하십시오. 예:

    NSX-T Data Center에 게시된 NSX-T Data Center 정책 및 규칙은 CVX에서 관리하는 물리적 스위치에 동적 ACL로 나타납니다.

    자세한 내용은 CVX HA 설정, CVX HA 가상 IP 설정물리적 스위치 Mlag 설정을 참조하십시오.