NSX Manager UI를 사용하여 NSX Application Platform 지원 번들을 수집할 수 없습니다.
문제
NSX Application Platform을 배포 또는 삭제하려고 했지만 배포 또는 삭제 작업을 완료하기 전에 배포에 실패했습니다. NSX Application Platform에 더 이상 액세스할 수 없으므로 NSX Manager UI를 통해 지원 번들에 액세스하여 작업의 실패 원인을 확인할 수 있는 방법이 없습니다.
원인
배포 또는 삭제 작업이 실패한 이유에는 여러 가지가 있을 수 있습니다.
해결책
배포 또는 삭제 작업 실패의 원인을 확인하려면 다음 정보를 사용하여
NSX Manager CLI를 사용하여 지원 번들을 수집합니다.
- NSX Manager 장치 CLI에admin 사용자로 로그인합니다.
- 지원 번들을 생성하기 전에 CLI 프롬프트에서 다음 명령을 입력합니다.
set napp kubeconfig
- kubeconfig 파일 컨텐츠를 입력하고 Ctrl+D를 누릅니다.
이 작업은 NSX Application Platform에서 사용하는 기존 kubeconfig 파일을 재정의합니다.
- 다음 명령을 사용하여 지원 번들 파일을 가져옵니다. 여기서 "support-bundle-filename" 은 시스템에서 생성된 지원 번들 파일에 사용할 파일 이름입니다.
get support-bundle file "support-bundle-filename" .tgz
올바른 kubeconfig 파일 컨텐츠를 입력한 경우 NSX Application Platformsupport-bundle-filename ".tgz 파일의 압축을 푼 후 " /napp 폴더에서 지원 로그 파일을 찾을 수 있습니다.
입력한 kubeconfig 파일 컨텐츠가 잘못된 경우 /napp 폴더가 비어 있습니다.
- 지원 번들 파일을 NSX Manager 호스트에서 원격 호스트 위치로 안전하게 전송하려면 다음 명령을 사용합니다.
copy file "support-bundle-filename" .tgz url "remote-host-url"
"remote-host-url" 은
scp:// "<username>@<ip-address>:<dir>"
형식입니다. 여기서 "<username>" 은 원격 호스트에 액세스할 수 있는 유효한 사용자 계정이고, "<ip-address>" 는 원격 호스트의 IP 주소이고 "<dir>" 은 지원 번들 파일이 전송될 파일 폴더입니다.