문제

전송 노드로 준비된 ESXi 호스트는 NSX Manager에 대한 연결이 끊어졌으므로 알 수 없음 또는 연결 끊김 상태가 됩니다. NSXNSX 관리 노드와 호스트 <uuid> 간의 하트비트가 종료됨 오류를 표시합니다.

원인

ESXi 디스크가 가득 찼거나 메모리가 유출되어 호스트 인프라 서비스가 종료되면 이 상태가 될 수 있습니다. ESXi인 경우

ESXi 디스크가 가득 찼거나 메모리가 유출되는 경우 특정 프로세스가 충돌하고 전송 노드가 연결 끊김 상태가 될 수 있습니다. Admin CLI get managers를 실행할 때 관리자 등록에 성공한 후 충돌이 발생하면 NSX가 활성 관리자 노드를 반환할 수 있습니다. Admin CLI get controllers를 실행하면 NSX에서 컨트롤러 목록을 가져오지 못함 오류가 발생합니다.

해결책

  1. Admin CLI get core-dumps를 실행하여 서비스 충돌로 인해 코어가 생성되었는지(/var/core 또는 /image/core에서) 확인합니다.
  2. 코어 덤프가 발생하면 cmd esxtop을 실행하여 메모리를 너무 많이 사용하는 NSX 프로세스를 확인하고, df -h를 실행하여 NSX에서 사용되는 디스크 파티션이 가득 찼거나 거의 가득 차지 않았는지 확인합니다.
  3. /etc/init.d/nsx-proxy | nsx-nestdb status를 실행하여 호스트의 인프라 서비스 상태를 가져옵니다.
  4. 디스크 공간을 정리한 다음, /etc/init.d/<service-name> start 명령을 실행하여 호스트에서 중지된 인프라 서비스를 시작합니다(임시 해결 방법).
  5. 코어가 표시되면 VMware에서 지원 사례를 엽니다.