VMware Tools 10.1.5 릴리스 정보

|

업데이트 날짜: 2017년 3월 27일

VMware Tools | 2017년 2월 23일 | 빌드 5055683

이 릴리스 정보의 추가 사항 및 업데이트 사항을 확인하십시오.

릴리스 정보에 포함된 내용

릴리스 정보에는 다음과 같은 항목이 포함됩니다.

새로운 기능

VMware Tools는 가상 시스템의 게스트 운영 체제 성능을 향상시키고 가상 시스템 관리를 개선하는 유틸리티 제품군입니다.

  • 10.1.5에서 게스트 운영 체제에 대한 VMware Tools 지원
    • windows.iso는 Windows Vista 이상을 지원합니다.
    • linux.iso는 RHEL(Red Hat Enterprise Linux) 이상, SLES(SUSE Linux Enterprise Server) 11 이상 및 Ubuntu 10.04 이상의 Linux 게스트 운영 체제를 지원합니다. 또한 glibc 버전이 2.5 이상인 기타 배포를 지원합니다.
    • darwin.iso는 Mac OS X 버전 10.11 이상을 지원합니다.
    • freebsd.iso는 FreeBSD 버전을 지원합니다.
    • solaris.iso는 Solaris 버전을 지원합니다.
  • 드라이버 및 인증서: VMware Tools 10.1.5용의 서명된 WDDM(Windows Display Driver Model) 8.15.1.50 그래픽 드라이버 드라이버에 대한 자세한 내용은 VMware Tools에 의해 설치된 Windows 게스트 드라이버를 참조하십시오.
  • 해결된 문제: 이번 VMware Tools 10.1.5 릴리스에서는 해결된 문제 섹션에 설명된 문제를 해결합니다.

이전 릴리스의 VMware Tools

VMware Tools 10.1.0 릴리스 정보

VMware Tools 10.0.0 이전 릴리스의 경우에는 VMware Tools 설명서 페이지를 참조하십시오.

시작하기 전에

극히 일부의 수명 종료 게스트 운영 체제에 대한 VMware Tools ISO 이미지가 중지됩니다. 일부 ISO 이미지는 tools-light VIB에 ESXi와 함께 제공되지 않습니다. 자세한 내용은 VMware Tools 설명서 페이지를 참조하십시오. 모든 VMware Tools ISO 이미지는 http://my.vmware.com에서 다운로드할 수 있습니다.

Windows용 VMware Tools는 32비트 및 64비트 설치 관리자 실행 파일(.exe)로 다운로드할 수 있습니다. 이러한 파일은 Windows 게스트 운영 체제에서 VMware Tools를 보다 쉽게 액세스하고 설치하기 위해 제공됩니다.

ESXi 5.5 업데이트 3b 이상으로 업그레이드하는 방법에 대한 중요 참고 사항

이전 버전의 Horizon View Agent를 사용하는 경우 ESXi 호스트를 ESXi 5.5 업데이트 3b 또는 ESXi 6.0 업데이트 1 이상으로 업그레이드할 때 발생할 수 있는 비호환성을 해결하는 방법 및 일반적인 지침은 아래의 기술 자료 문서를 참조하십시오.

국제화

VMware Tools 10.1.5는 다음의 언어로 제공됩니다.

  • 영어
  • 프랑스어
  • 독일어
  • 스페인어
  • 이탈리아어
  • 일본어
  • 한국어
  • 중국어 간체
  • 중국어 번체

호환성

VMware Tools 10.1.5는 지원되는 VMware vSphere ESXi 5.5 이상 버전, VMware Workstation 12.0 및 VMware Fusion 8.0과 호환됩니다. 자세한 내용은 VMware 호환성 가이드를 참조하십시오.

VMware Tools 10.1.5를 가상 디바이스가 필수 기능을 지원하는 VMware vSphere의 릴리스, VMware Workstation 12.0 및 VMware Fusion 8.0과 함께 사용하면 Windows 게스트에서 DirectX 10.0 및 OpenGL 3.3을 지원합니다. Windows 및 Linux용 VMware 게스트 운영 체제 OpenGL 드라이버는 OpenGL 3.3 코어 프로파일만 지원합니다. OpenGL 3.3 호환성 프로파일은 지원하지 않습니다. OpenGL 게스트 드라이버는 호환성 프로파일에 대해 버전 3.0만 지원합니다.

운영 체제와 함께 제공되는 Linux 커널 모듈을 중단시키는 VMware Tools 설치 관리자 옵션은 더 이상 지원되지 않습니다. 예정된 Linux용 VMware Tools 버전에서는 설치 관리자에서 중단 옵션이 제거됩니다.

게스트 운영 체제 사용자 지정 지원

게스트 OS 사용자 지정 지원 매트릭스에는 사용자 지정이 지원되는 게스트 운영 체제에 대한 자세한 내용이 나와 있습니다.

이 릴리스의 설치 및 업그레이드

VMware Tools는 제품 다운로드 페이지에서 다운로드할 수 있습니다.

VMware Tools 운영 체제별 패키지는 http://packages.vmware.com/tools/releases/index.html에서 다운로드할 수 있습니다. OSP 설치에 대한 자세한 내용은 운영 체제별 패키지에 대한 VMware Tools 설치 가이드(ESXi 버전 5.x 및 6.x)를 참조하십시오.

VMware Tools를 설치하는 단계는 사용하는 VMware 제품 및 설치한 게스트 운영 체제에 따라 다릅니다. 대부분의 VMware 제품에서 VMware Tools를 설치하는 일반적인 단계는 일반 VMware Tools 설치 지침(1014294)을 참조하십시오. 공유 데이터스토어를 가리키도록 productLocker를 설정하려면 KB 2004018을 참조하십시오.

VMware Tools의 설치, 업그레이드 및 구성에 대한 세부적인 지침은 VMware Tools 설명서 페이지를 참조하십시오.

업그레이드 정보

향후 VMware Tools 릴리스에 대한 업그레이드 지원

지원이 종료된 ESXi와 함께 제공된 이전 버전의 VMware Tools를 이전 ESXi 릴리스의 지원이 종료된 후에 바로 릴리스된 ESXi 버전과 함께 동시에 제공된 최신 버전의 VMware Tools로 업그레이드할 수 있습니다.

ESXi 5.0 및 ESXi 5.1 VMware Tools에 대한 지원

  • 확장된 지원 - ESXi 5.0 및 ESXi 5.1과 함께 제공되는 VMware Tools 버전에 대해 확장된 지원을 사용할 수 있습니다.
  • 업그레이드 - 레거시 게스트 운영 체제에 대해 VMware Tools를 버전 10.0.12로 업그레이드하는 작업은 ESXi 5.0 및 ESXi 5.1에서 지원되지 않습니다. VMware Tools 10.0.12를 실행하는 가상 시스템은 ESXi 5.0 및 5.1에서 지원됩니다.

업그레이드가 미치는 영향

업그레이드 지원을 받으려면 사용자는 2단계 업그레이드 프로세스를 진행하여 비레거시 게스트 운영 체제에서 10.1.0 버전 이상의 VMware Tools를 받아야 합니다.

  1. ESXi 5.0 또는 ESXi 5.1과 함께 제공되는 VMware Tools를 최신 버전의 VMware Tools로 업그레이드(ESXi 5.5에서 VMware Tools 9.4.6 버전을 최신 버전의 ESXi에서 VMware Tools 10.1.0 버전으로)
  2. VMware Tools를 상위 버전으로 업그레이드

간편하게 업그레이드를 하려면 지원되는 ESXi 버전과 함께 번들로 제공되는 VMware Tools로 업그레이드합니다. 

VMware Tools는 ESXi의 버전과 관계없이 호환됩니다. 최신 버전의 VMware Tools는 지원되는 이전 ESXi 버전과 호환되고 그 반대로도 호환됩니다. 버전 10.0.12로의 VMware Tools 업그레이드는 VMware ESXi 5.5(패치 릴리스 ESXi550-201608001) 및 VMware ESXi 6.0(패치 릴리스 ESXi600-201608001) 이상의 레거시 게스트 운영 체제에 대해 지원되는 마지막 업그레이드입니다.

VMware Tools에 의해 설치되는 Windows 게스트 드라이버

VMware Tools 10.1.5는 Windows 게스트 운영 체제에서 다음 드라이버 버전을 지원합니다.

    하드웨어 드라이버
    드라이버
    버전
    vmci 9.8.6.0
    vsock 9.8.8.0
    pvscsi 1.3.8.0
    wddm 8.15.1.50
    xpdm 12.1.8.0
    vmxnet3 1.7.3.0 - NDIS 6.0
    vmxnet2 2.2.0.0
    vmmouse 12.5.7.0
    vmusbmouse 12.5.7.0
    vmaudio 5.10.0.3506

    소프트웨어 드라이버
    드라이버
    버전
    vmrawdsk.sys 1.1.0.1
    vmmemctl.sys 7.4.1.1
    vmhgfs.sys 11.0.14.2 - Windows Vista 이상의 운영 체제
    vsepflt.sys 10.1.0.0
    vnetflt.sys 10.1.0.0 - 커널 모드 코드 서명
    vnetWFP.sys 10.1.0.0

해결된 문제

  • VMware Tools를 업그레이드한 후에 VMware Tools 서비스에 대한 PAM(Pluggable Authentication Modules) 구성이 손실됨.
    VMware Tools를 업그레이드한 후에 /etv/pam.d/vmtoolsd의 사용자 지정된 PAM 구성이 손실되어 인증이 실패합니다.

    이 문제는 이 릴리스에서 해결되었습니다.

  • CentOS 및 Oracle Linux 가상 시스템에서 VMware Tools 설치 및 업그레이드가 실패함.
    CentOS 및 Oracle Linux 가상 시스템에서 VMware Tools 설치 및 업그레이드가 실패합니다. 가상 하드웨어 버전 13을 지원하지 않는 버전 6.5 이전의 ESXi 호스트에서는 모든 CentOS 및 Oracle Linux 가상 시스템에 하나의 게스트 OS가 지정됩니다. VMware Tools 10.1.0의 경우 CentOS 및 Oracle Linux 게스트가 2.5 이전 버전의 glibc를 사용하는 빌드로 제한됩니다.

    이 문제는 linuxPreGlibc25.iso가 표준 ESXi 설치에 속하지 않기 때문에 발생합니다. vCenter Server 또는 vSphere Update Manager에 의해 설치되기 위해 VMware Tools ISO를 자동으로 마운트하려고 하면 다음과 비슷한 오류를 나타내며 실패할 수 있습니다.

    An error occurred while trying to access image file "/usr/lib/vmware/isoimages/linuxPreGlibc25.iso"

    이 문제는 이 릴리스에서 해결되었습니다.

  • 인증 실패가 알려지지 않은 일반 시스템 오류로 보고됨.
    VGAuth 서비스를 통해 인증하려고 하면 만료된 계정 또는 암호와 같은 인증과 관련된 오류가 발생할 수 있습니다. 인증과 관련된 오류는 다음과 비슷한 알려지지 않은 일반 시스템 오류로 잘못 보고될 수 있습니다.

    CommunicationException: Failed to create temp file on target <IP 주소>: A general system error occurred: Unknown error

    이 문제는 이 릴리스에서 해결되었습니다.

  • 이전 커널 버전이 있는 Linux 가상 시스템이 VMXNET3 드라이버에서 실패함.
    커널 버전 2.6.18이 있는 RHEL 5 가상 시스템이 트렁크 포트 그룹에 연결되고 게스트 VLAN이 가상 시스템에서 구성되지 않을 때 커널 패닉 메시지를 표시할 수 있습니다.

    이 문제는 이 릴리스에서 해결되었습니다.

  • 활성 Docker 컨테이너로 가상 시스템을 백업할 수 없음.
    Docker 컨테이너가 실행되는 RHEL 7 게스트 운영 체제에서 중지된 스냅샷을 작성하려고 하면 실패할 수 있습니다. Docker 버전 1.12.x 이상은 컨테이너에 대한 특별 마운트 지점을 생성합니다. 이러한 마운트 지점은 시스템에서 /proc/self/mounts의 절대 경로 대신 ‘net:[NUMBER]’로 기록됩니다.

    참고: Red Hat에서 추적된 문제를 보려면 Red Hat Bugzilla를 참조하십시오.

    이 문제는 이 릴리스에서 해결되었습니다.

알려진 문제

  • VMware Tools 설치 관리자에서 FreeBSD 11.0 가상 시스템 오류가 발생함
    FreeBSD 11.0 가상 시스템의 VMware Tools 설치 관리자에서 다음과 유사한 오류가 발생합니다.
    ‘VMware Tools에 대한 서비스를 시작할 수 없음’
    설치 관리자에서 게스트 메모리 관리자를 표시하며 차단 파일 시스템 서비스가 VMware Tools 설치 프로세스 끝에 시작할 수 없습니다.

    해결 방법: 다음 단계를 수행합니다.

    1. -d 옵션 없이 VMware Tools를 설치합니다. 
    2. “이 프로그램에서 지금 명령을 호출하도록 하시겠습니까?”에 “아니요”라고 답하여 /usr/local/bin/vmware-config-tools.pl을 호출합니다.
    3. 처음으로 VMware Tools를 실행하기 전에 다음 명령을 호출하여 구성해야 합니다.
      "/usr/local/bin/vmware-config-tools.pl"
    4. 다음 구성 스크립트를 실행합니다.
      /usr/local/bin/vmware-config-tools.pl --skip-stop-start
    5. 다음 명령을 실행합니다.
      echo "answer VMMEMCTL_CONFED no" >> /etc/vmware-tools/locations
    6. VMware Tools를 시작합니다.
      /usr/local/etc/rc.d/vmware-tools.sh start

이전 릴리스의 알려진 문제

이전 릴리스의 적용 가능한 알려진 문제 목록을 보려면 여기를 클릭하십시오.

  • VMware Tools 10.1.0은 VMware Site Recovery Manager 6.1.1 또는 이전 버전과 호환되지 않음
    VMware Site Recovery Manager 6.1.1 또는 이전 버전에서 관리되는 가상 시스템에서 VMware Tools를 10.1.0으로 업그레이드하면 VMware Site Recovery Manager 워크플로가 중단됩니다. VMware Site Recovery Manager 6.1.2 및 6.5 버전은 VMware Tools 10.1.0과 호환됩니다.

    해결 방법: VMware Tools를 설치하거나 버전 10.1.0으로 업그레이드하기 전에 VMware Site Recovery Manager를 버전 6.1.2 또는 6.5로 업그레이드하십시오. 가상 시스템이 VMware Site Recovery Manager 6.1.1 또는 이전 버전에 의해 관리되는 경우 VMware Tools를 설치하거나 버전 10.1.0으로 업그레이드하지 마십시오. 이 호환성 요구 사항은 다양한 Linux 배포판에 패키징된 open-vm-tools 10.1.0에도 적용됩니다. 호환성에 대한 자세한 내용은 VMware 제품 상호 운용성 매트릭스를 참조하십시오.
  • FreeBSD 6.x 또는 7.x 게스트 운영 체제에서 VMware Tools를 설치하려고 하면 오류를 나타내며 실패할 수 있음
    FreeBSD 6.x 또는 7.x 게스트 운영 체제에서 VMware Tools를 설치하려고 하면 다음과 유사한 오류를 나타내며 실패할 수 있습니다.

    Guest operating system daemon: failed
    Attempting to run vmtoolsd after installation will result in the following error
    "Segmentation fault: 11 (core dumped)"


    해결 방법: FreeBSD 6.x 또는 7.x VM에 VMware Tools 10.1.0을 설치하기 전에 다음을 수행합니다.
    1. 파일이 생성되지 않은 경우 파일을 생성합니다.
       
       /etc/libmap.conf
    2. /etc/libmap.conf 파일에 다음을 추가합니다.

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so


    VMware Tools 10.1.0이 이미 설치되어 있는 경우 다음을 수행합니다.
    1. 다음을 사용하여 /etc/libmap.conf를 업데이트합니다.

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so
    2. /usr/local/bin/vmware-config-tools.pl을 실행하여 구성을 완료합니다.

    참고: 이 해결 방법은 7.x 이상의 FreeBSD 버전을 실행하는 가상 시스템에 적용되지 않습니다.

  • open-vm-tools의 Common Agent Framework가 Ubuntu 14.04에서 빌드되지 않음
    open-vm-tools의 Common Agent Framework가 rabbitmq-c 버전이 0.8.0보다 낮은 Ubuntu 14.04에서 빌드되지 않음

    해결 방법: Common Agent Framework의 TLSv1.2 지원을 위해 rabbitmq-c를 버전 0.8.0 이상으로 업그레이드합니다.
  • Solaris 10 업데이트 11에서 vmusr 플러그인이 로드되지 않음
    Solaris 10 U11 게스트 운영 체제에서 VMware Tools 10.1을 실행하는 동안 다음 vmusr 플러그인이 로드되지 않습니다.
    • libdesktopEvents.so
    • libdndcp.so
    • libresolutionSet.so

    이 문제는 Solaris 버전 11.2에서도 발생할 수 있습니다.

    해결 방법: Solaris 11.3으로 업그레이드합니다.
  • VMware Tools 10.0.x를 사용하면 복제 드라이버가 Linux 커널에 로드될 수 있음
    이 문제는 드라이버가 /lib/modules/<커널 버전>/ 에 직접 설치될 때 발생합니다. 이로 인해 VMware Tools에서 잘못된 드라이버가 감지되어 원치 않는 드라이버가 설치될 수 있습니다.
  • 해결 방법: 이 문제를 해결하려면 VMware Tools를 설치하거나 다시 설치하기 전에 /lib/modules/<커널 버전>/ / 의 하위 디렉토리에 모듈을 설치합니다.

    예를 들면 다음과 같습니다.
    cd /lib/modules/$(uname -r)/
    mkdir foobar
    mv foo.ko bar.ko foobar/
    depmod -a

     

이전 알려진 문제의 목록 축소