Workspace ONE Access Connector 21.08로 마이그레이션하려면 다음 요구 사항을 따라야 합니다.

  • 21.08 Connector를 설치하려면 하나 이상의 Windows 서버가 필요합니다. 디렉토리 동기화, 사용자 인증, Kerberos 인증 서비스 및 가상 애플리케이션 서비스를 하나의 서버에 함께 설치하거나 서로 다른 서버에 별도로 설치할 수 있습니다. 요구 사항에 대해서는 Workspace ONE Access Connector 21.08 설치 가이드를 참조하십시오.

    21.08 Connector를 새 서버 또는 레거시 19.03.x 커넥터 서버에 설치할 수 있습니다. 하지만 레거시 커넥터에 Kerberos 인증이 구성된 경우 별도의 Windows 서버를 사용하여 21.08 Kerberos 인증 서비스를 설치해야 합니다. 19.03.x 커넥터 서버에서 새 Kerberos 인증 서비스를 설치하지 마십시오. Workspace ONE Access는 동일한 서버에서 여러 Kerberos 인스턴스를 지원하지 않습니다.

    새 Windows 서버에 21.08 Connector를 설치할 계획인 경우 Workspace ONE Access Connector 21.08 설치를 참조하십시오. 19.03.x Connector 서버에 21.08 Connector를 설치하려는 경우 Workspace ONE Access 19.03.x를 실행하는 Windows Server에서 최신 커넥터로 마이그레이션을 참조하십시오.

  • 기존 설치에 Citrix 가상 애플리케이션이 포함된 경우 가상 애플리케이션 서비스를 설치할 때 Workspace ONE Access Connector 21.08 설치 가이드에 설명된 Citrix 통합에 대한 요구 사항 및 전제 조건을 따라야 합니다. 여기에는 다음이 포함됩니다.
    • 커넥터 서버가 디렉토리 도메인에 가입되어 있어야 합니다.
    • 가상 애플리케이션 서비스를 실행하는 데 사용할 도메인 사용자 계정을 지정해야 합니다. 또한 해당 도메인 사용자는 Citrix PSSnapin을 로드할 수 있는 Citrix 서버 읽기 전용 관리자여야 합니다.
    • 커넥터 서버에 Citrix Studio를 설치해야 합니다. Citrix Studio에는 Citrix와 Workspace ONE Access 간의 통합에 필요한 Citrix PowerShell SDK가 포함되어 있습니다. Citrix Studio 버전이 Citrix 배포 버전과 호환되어야 합니다.
  • 마이그레이션 프로세스 중에 이전 커넥터와 새 커넥터를 번갈아 사용하며 마이그레이션을 테스트합니다. 마이그레이션 프로세스 동안 19.03.x 레거시 커넥터 서버는 실행 중인 상태여야 합니다. 마이그레이션을 완료하기 전까지는 19.03.x 커넥터를 제거하지 마십시오.
  • 테넌트의 모든 기존 커넥터는 버전 19.03.x여야 합니다. 이전 커넥터가 있는 경우 먼저 19.03.x로 업그레이드하십시오.
  • Workspace ONE Access 서비스의 온-프레미스 인스턴스가 있으면 21.08 Connector로 마이그레이션하기 전에 서비스를 버전 21.08로 업그레이드합니다.
  • 마이그레이션하는 동안 테넌트의 모든 디렉토리 및 지원되는 가상 애플리케이션 수집을 21.08 Connector로 마이그레이션해야 합니다. 디렉토리 또는 가상 애플리케이션의 하위 집합을 마이그레이션하도록 선택하거나 디렉토리 또는 가상 애플리케이션만 마이그레이션하도록 선택할 수는 없습니다.
  • 사용자 인증 서비스를 설치하는 경우 사용자 인증 서비스가 설치된 모든 커넥터의 버전이 21.08이어야 합니다. 사용자 환경에서 20.x 및 21.08 사용자 인증 서비스 노드를 혼합해서 사용할 수는 없습니다.
  • 마이그레이션 후에는 새로운 21.08 Connector만 사용할 수 있습니다. 사용자 환경에서 19.03.x Connector 및 21.08 Connector를 혼합해서 사용할 수는 없습니다.
  • Workspace ONE Access Connector 21.08은 다음과 같은 유형의 프록시를 지원합니다.
    • 인증되지 않은 HTTP 프록시
    • 인증되지 않은 HTTPS(SSL) 프록시
    • 인증된 HTTPS(SSL) 프록시

Workspace ONE Access Connector 19.03.x를 실행하는 Windows Server에서 최신 커넥터로 마이그레이션

Workspace ONE Access Connector 21.08로 마이그레이션하기 위한 새 Windows 서버를 제공할 수 없는 경우 Workspace ONE Access 19.03.x Connector가 실행되는 Windows 서버에 21.08 Connector를 설치할 수 있습니다. 그런 다음, 레거시 커넥터를 마이그레이션할 수 있습니다.

경고: 레거시 커넥터에 Kerberos 인증이 구성된 경우 별도의 Windows 서버를 사용하여 21.08 Kerberos 인증 서비스를 설치해야 합니다. 19.03. x 커넥터 서버에서 새 Kerberos 인증 서비스를 설치하지 마십시오. Workspace ONE Access는 동일한 서버에서 여러 Kerberos 인스턴스를 지원하지 않습니다.

19.03.x Connector가 설치된 기존 Windows Server를 사용하는 경우 다음 지침을 따라야 합니다.

  • 21.08 Connector를 설치하기 전에 서버의 CPU 및 메모리를 늘려야 합니다. 마이그레이션이 완료될 때까지 두 개의 커넥터 버전이 실행됩니다.

    19.03.x 및 21.08 Connector의 요구 사항을 모두 충족하려면 CPU와 메모리를 늘려야 합니다. "VMware Workspace ONE Access Connector 21.08 설치" 에서 21.08 크기 조정 지침을 참조하십시오.

  • 중요: 21.08 Connector 설치 관리자를 실행하기 전에 시스템의 스냅샷을 생성하십시오. 21.08 Connector를 설치할 때 설치 프로세스가 끝나면 커넥터 호스트를 다시 시작하라는 메시지가 표시될 수 있습니다. 호스트를 다시 시작하지 마십시오. 이렇게 하면 마이그레이션 프로세스가 실패하고 19.03.x Connector를 사용할 수 없게 됩니다. 전체 마이그레이션 프로세스가 완료될 때까지 시스템을 다시 시작하지 않는 것이 중요합니다. 마이그레이션이 성공적으로 완료되면 시스템을 안전하게 다시 시작할 수 있습니다.
  • 전체 마이그레이션 프로세스를 완료하기 전까지는 19.03.x Connector를 중지하거나 제거하지 마십시오.

마이그레이션이 완료되면 19.03.x Connector를 중지하고 제거할 수 있습니다.