Workspace ONE Access는 감사, 보고서 및 디렉토리 동기화 로그에 대해 Workspace ONE Access 장치에 내장된 Elasticsearch를 사용합니다. Workspace ONE Access 버전 21.08에서 Elasticsearch가 버전 6.8.12로 업그레이드되었습니다.

Workspace ONE Access 20.10.X는 Elasticsearch 5.6.15를 사용합니다. Elasticsearch 6.8.12는 5.6.15에서 생성된 인덱스를 읽을 수 있지만 Elasticsearch 6.8.12에서 사용하려면 이전 인덱스를 5.6.15로 다시 인덱싱해야 합니다. 그렇지 않으면 삭제해야 합니다. Workspace ONE Access 19.03.X 및 20.01은 Elasticsearch 버전 2.3.5를 사용하므로 Workspace ONE Access 21.08로 업그레이드하기 전에 Workspace ONE Access 19.03.X 및 20.01을 Workspace ONE Access 20.10.X로 업그레이드해야 합니다.

버전 21.08로 업그레이드하는 동안 인덱스를 재인덱싱하기 위해 수행되는 작업은 다음과 같습니다.

  • 데이터를 재인덱싱하기 위한 공간이 충분한지 확인합니다. 디스크 공간이 충분하지 않은 경우 디스크 공간을 필요한 최소 공간으로 확장한 다음, 업그레이드를 다시 시작하라는 메시지가 표시됩니다.
  • 장치에 있는 모든 닫힌 2.3.5 및 5.6.15 인덱스를 삭제합니다. 닫힌 인덱스에는 90일보다 오래된 데이터가 포함됩니다.
    참고: 닫힌 인덱스에서 데이터를 추출해야 하는 경우 업그레이드하기 전에 VMware 지원 서비스에 문의하십시오.
  • 모든 2.3.5 인덱스에 대한 새 인덱스를 생성하고 이전 인덱스 매핑을 다시 생성합니다.